diff mbox series

[v4,1/2] less: switch to github URI

Message ID 20230706130934.586539-2-jstephan@baylibre.com
State New
Headers show
Series Add ptest for less | expand

Commit Message

Julien Stephan July 6, 2023, 1:09 p.m. UTC
as of today, release tarballs are fetched from [1] but the less test code is not
bundled within these releases. A github issue has been opened asking for
maintainer to bundle it [2]

In order to add ptest for less, switch to github URI. This commit can be reverted
if release tarballs from [1] bundle the test code in the future.

[YOCTO #15073]

[1]: http://www.greenwoodsoftware.com/
[2]: https://github.com/gwsw/less/issues/344

Signed-off-by: Julien Stephan <jstephan@baylibre.com>
---
 meta/recipes-extended/less/less_633.bb | 17 ++++++++++++-----
 1 file changed, 12 insertions(+), 5 deletions(-)
diff mbox series

Patch

diff --git a/meta/recipes-extended/less/less_633.bb b/meta/recipes-extended/less/less_633.bb
index 2defb5ccb7a..e6535d16a78 100644
--- a/meta/recipes-extended/less/less_633.bb
+++ b/meta/recipes-extended/less/less_633.bb
@@ -23,16 +23,23 @@  LICENSE = "GPL-3.0-or-later | BSD-2-Clause"
 LIC_FILES_CHKSUM = "file://COPYING;md5=1ebbd3e34237af26da5dc08a4e440464 \
                     file://LICENSE;md5=1b2446f5c8632bf63a97d7a49750e1c6 \
                     "
-DEPENDS = "ncurses"
+DEPENDS = "ncurses groff-native"
 
-SRC_URI = "http://www.greenwoodsoftware.com/${BPN}/${BPN}-${PV}.tar.gz"
+SRC_URI = "git://github.com/gwsw/less.git;protocol=https;branch=master"
+SRCREV = "0d7ca880375bde651313f03f7115d26921b43722"
 
-SRC_URI[sha256sum] = "2f201d64b828b88af36dfe6cfdba3e0819ece2e446ebe6224813209aaefed04f"
-
-UPSTREAM_CHECK_URI = "http://www.greenwoodsoftware.com/less/download.html"
+S = "${WORKDIR}/git"
 
 inherit autotools update-alternatives
 
+# According to the README of the project when getting code from git we should run
+# the following command before running the configure script
+do_configure:prepend () {
+        cd ${S}
+        make -f Makefile.aut distfiles
+        cd -
+}
+
 do_install () {
         oe_runmake 'bindir=${D}${bindir}' 'mandir=${D}${mandir}' install
 }