diff mbox series

[v2,2/2] openssl: fix the PERLEXTERNAL path

Message ID 20230705184847.587503-2-jose.quaresma@foundries.io
State New
Headers show
Series [v2,1/2] openssl: check the existence of the PERL5LIB path | expand

Commit Message

Jose Quaresma July 5, 2023, 6:48 p.m. UTC
The Text-Template was updated from 1.46 to 1.56

| ERROR: openssl-native-3.1.1-r0 do_configure: PERLEXTERNAL '/build/tmp/work/x86_64-linux/openssl-native/3.1.1-r0/openssl-3.1.1/external/perl/Text-Template-1.46/lib' not found!

Signed-off-by: Jose Quaresma <jose.quaresma@foundries.io>
---
 meta/recipes-connectivity/openssl/openssl_3.1.1.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Ross Burton July 6, 2023, 10:37 a.m. UTC | #1
On 5 Jul 2023, at 19:48, Jose Quaresma via lists.openembedded.org <quaresma.jose=gmail.com@lists.openembedded.org> wrote:
> 
> The Text-Template was updated from 1.46 to 1.56
> 
> | ERROR: openssl-native-3.1.1-r0 do_configure: PERLEXTERNAL '/build/tmp/work/x86_64-linux/openssl-native/3.1.1-r0/openssl-3.1.1/external/perl/Text-Template-1.46/lib' not found!
> 
> Signed-off-by: Jose Quaresma <jose.quaresma@foundries.io>
> ---
> meta/recipes-connectivity/openssl/openssl_3.1.1.bb | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/meta/recipes-connectivity/openssl/openssl_3.1.1.bb b/meta/recipes-connectivity/openssl/openssl_3.1.1.bb
> index b849f9ca79..5f30a37c8a 100644
> --- a/meta/recipes-connectivity/openssl/openssl_3.1.1.bb
> +++ b/meta/recipes-connectivity/openssl/openssl_3.1.1.bb
> @@ -137,7 +137,7 @@ do_configure () {
> fi
> # WARNING: do not set compiler/linker flags (-I/-D etc.) in EXTRA_OECONF, as they will fully replace the
> # environment variables set by bitbake. Adjust the environment variables instead.
> - PERLEXTERNAL="${S}/external/perl/Text-Template-1.46/lib"
> + PERLEXTERNAL="${S}/external/perl/Text-Template-1.56/lib"

As you’ve demonstrated that is very fragile, can’t we just use a glob to get the right path?

Ross
Jose Quaresma July 6, 2023, 11:05 a.m. UTC | #2
Ross Burton <Ross.Burton@arm.com> escreveu no dia quinta, 6/07/2023 à(s)
11:38:

> On 5 Jul 2023, at 19:48, Jose Quaresma via lists.openembedded.org
> <quaresma.jose=gmail.com@lists.openembedded.org> wrote:
> >
> > The Text-Template was updated from 1.46 to 1.56
> >
> > | ERROR: openssl-native-3.1.1-r0 do_configure: PERLEXTERNAL
> '/build/tmp/work/x86_64-linux/openssl-native/3.1.1-r0/openssl-3.1.1/external/perl/Text-Template-1.46/lib'
> not found!
> >
> > Signed-off-by: Jose Quaresma <jose.quaresma@foundries.io>
> > ---
> > meta/recipes-connectivity/openssl/openssl_3.1.1.bb | 2 +-
> > 1 file changed, 1 insertion(+), 1 deletion(-)
> >
> > diff --git a/meta/recipes-connectivity/openssl/openssl_3.1.1.bb
> b/meta/recipes-connectivity/openssl/openssl_3.1.1.bb
> > index b849f9ca79..5f30a37c8a 100644
> > --- a/meta/recipes-connectivity/openssl/openssl_3.1.1.bb
> > +++ b/meta/recipes-connectivity/openssl/openssl_3.1.1.bb
> > @@ -137,7 +137,7 @@ do_configure () {
> > fi
> > # WARNING: do not set compiler/linker flags (-I/-D etc.) in
> EXTRA_OECONF, as they will fully replace the
> > # environment variables set by bitbake. Adjust the environment variables
> instead.
> > - PERLEXTERNAL="${S}/external/perl/Text-Template-1.46/lib"
> > + PERLEXTERNAL="${S}/external/perl/Text-Template-1.56/lib"
>
> As you’ve demonstrated that is very fragile, can’t we just use a glob to
> get the right path?
>

I don't know the best way to do this but this way works, so I will send a v3

-       PERLEXTERNAL="${S}/external/perl/Text-Template-1.56/lib"
+       PERLEXTERNAL="$(realpath ${S}/external/perl/Text-Template-*/lib)"

Jose


>
> Ross
>
>
diff mbox series

Patch

diff --git a/meta/recipes-connectivity/openssl/openssl_3.1.1.bb b/meta/recipes-connectivity/openssl/openssl_3.1.1.bb
index b849f9ca79..5f30a37c8a 100644
--- a/meta/recipes-connectivity/openssl/openssl_3.1.1.bb
+++ b/meta/recipes-connectivity/openssl/openssl_3.1.1.bb
@@ -137,7 +137,7 @@  do_configure () {
 	fi
 	# WARNING: do not set compiler/linker flags (-I/-D etc.) in EXTRA_OECONF, as they will fully replace the
 	# environment variables set by bitbake. Adjust the environment variables instead.
-	PERLEXTERNAL="${S}/external/perl/Text-Template-1.46/lib"
+	PERLEXTERNAL="${S}/external/perl/Text-Template-1.56/lib"
 	test -d "$PERLEXTERNAL" || bberror "PERLEXTERNAL '$PERLEXTERNAL' not found!"
 	HASHBANGPERL="/usr/bin/env perl" PERL=perl PERL5LIB="$PERLEXTERNAL" \
 	perl ${S}/Configure ${EXTRA_OECONF} ${PACKAGECONFIG_CONFARGS} ${DEPRECATED_CRYPTO_FLAGS} --prefix=$useprefix --openssldir=${libdir}/ssl-3 --libdir=${libdir} $target