diff mbox series

[master/kirkstone,2/3] libcamera: Add support for TI CSI-RX

Message ID 20230705130928.1201894-2-j-luthra@ti.com
State Superseded
Delegated to: Ryan Eatmon
Headers show
Series [master/kirkstone,1/3] libcamera: Add recipe for v0.0.5 | expand

Commit Message

Jai Luthra July 5, 2023, 1:09 p.m. UTC
TI's CSI-RX driver is not yet upstream, so the libcamera simple pipeline
does not recognize it.

Apply a patch to the simple pipeline so that it can recognize the media
entity for TI's CSI-RX driver.

Signed-off-by: Jai Luthra <j-luthra@ti.com>
---
 .../0001-simple-Support-TI-CSI-RX.patch       | 26 +++++++++++++++++++
 .../libcamera/libcamera_0.0.5.bb              |  1 +
 2 files changed, 27 insertions(+)
 create mode 100644 meta-arago-extras/recipes-multimedia/libcamera/libcamera/0001-simple-Support-TI-CSI-RX.patch

Comments

Denys Dmytriyenko July 5, 2023, 11:14 p.m. UTC | #1
On Wed, Jul 05, 2023 at 06:39:27PM +0530, Jai Luthra via lists.yoctoproject.org wrote:
> TI's CSI-RX driver is not yet upstream, so the libcamera simple pipeline
> does not recognize it.
> 
> Apply a patch to the simple pipeline so that it can recognize the media
> entity for TI's CSI-RX driver.
> 
> Signed-off-by: Jai Luthra <j-luthra@ti.com>
> ---
>  .../0001-simple-Support-TI-CSI-RX.patch       | 26 +++++++++++++++++++
>  .../libcamera/libcamera_0.0.5.bb              |  1 +
>  2 files changed, 27 insertions(+)
>  create mode 100644 meta-arago-extras/recipes-multimedia/libcamera/libcamera/0001-simple-Support-TI-CSI-RX.patch
> 
> diff --git a/meta-arago-extras/recipes-multimedia/libcamera/libcamera/0001-simple-Support-TI-CSI-RX.patch b/meta-arago-extras/recipes-multimedia/libcamera/libcamera/0001-simple-Support-TI-CSI-RX.patch
> new file mode 100644
> index 00000000..66b94863
> --- /dev/null
> +++ b/meta-arago-extras/recipes-multimedia/libcamera/libcamera/0001-simple-Support-TI-CSI-RX.patch
> @@ -0,0 +1,26 @@
> +From 2a82bce49ce4098ac17b4a654a9db5f2dee56415 Mon Sep 17 00:00:00 2001
> +From: Jai Luthra <j-luthra@ti.com>
> +Date: Thu, 23 Mar 2023 11:38:46 +0530
> +Subject: [PATCH] simple: Support TI CSI-RX

Upstream-Status is missing here


> +Signed-off-by: Jai Luthra <j-luthra@ti.com>
> +---
> + src/libcamera/pipeline/simple/simple.cpp | 2 ++
> + 1 file changed, 2 insertions(+)
> +
> +diff --git a/src/libcamera/pipeline/simple/simple.cpp b/src/libcamera/pipeline/simple/simple.cpp
> +index e1f8b989..520405a1 100644
> +--- a/src/libcamera/pipeline/simple/simple.cpp
> ++++ b/src/libcamera/pipeline/simple/simple.cpp
> +@@ -194,6 +194,8 @@ static const SimplePipelineInfo supportedDevices[] = {
> + 	{ "mxc-isi", {} },
> + 	{ "qcom-camss", {} },
> + 	{ "sun6i-csi", {} },
> ++	{ "j721e-csi2rx", {} },
> ++
> + };
> + 
> + } /* namespace */
> +-- 
> +2.41.0
> +
> diff --git a/meta-arago-extras/recipes-multimedia/libcamera/libcamera_0.0.5.bb b/meta-arago-extras/recipes-multimedia/libcamera/libcamera_0.0.5.bb
> index 6ad376f2..b2eb5fac 100644
> --- a/meta-arago-extras/recipes-multimedia/libcamera/libcamera_0.0.5.bb
> +++ b/meta-arago-extras/recipes-multimedia/libcamera/libcamera_0.0.5.bb
> @@ -10,6 +10,7 @@ LIC_FILES_CHKSUM = "\
>  
>  SRC_URI = " \
>          git://git.libcamera.org/libcamera/libcamera.git;protocol=https;branch=master \
> +        file://0001-simple-Support-TI-CSI-RX.patch \
>  "
>  
>  SRCREV = "fb44403f1c5571549ac128c21daee9761eb9249c"
> -- 
> 2.41.0
Ryan Eatmon July 5, 2023, 11:49 p.m. UTC | #2
On 7/5/2023 6:14 PM, Denys Dmytriyenko wrote:
> On Wed, Jul 05, 2023 at 06:39:27PM +0530, Jai Luthra via lists.yoctoproject.org wrote:
>> TI's CSI-RX driver is not yet upstream, so the libcamera simple pipeline
>> does not recognize it.
>>
>> Apply a patch to the simple pipeline so that it can recognize the media
>> entity for TI's CSI-RX driver.
>>
>> Signed-off-by: Jai Luthra <j-luthra@ti.com>
>> ---
>>   .../0001-simple-Support-TI-CSI-RX.patch       | 26 +++++++++++++++++++
>>   .../libcamera/libcamera_0.0.5.bb              |  1 +
>>   2 files changed, 27 insertions(+)
>>   create mode 100644 meta-arago-extras/recipes-multimedia/libcamera/libcamera/0001-simple-Support-TI-CSI-RX.patch
>>
>> diff --git a/meta-arago-extras/recipes-multimedia/libcamera/libcamera/0001-simple-Support-TI-CSI-RX.patch b/meta-arago-extras/recipes-multimedia/libcamera/libcamera/0001-simple-Support-TI-CSI-RX.patch
>> new file mode 100644
>> index 00000000..66b94863
>> --- /dev/null
>> +++ b/meta-arago-extras/recipes-multimedia/libcamera/libcamera/0001-simple-Support-TI-CSI-RX.patch
>> @@ -0,0 +1,26 @@
>> +From 2a82bce49ce4098ac17b4a654a9db5f2dee56415 Mon Sep 17 00:00:00 2001
>> +From: Jai Luthra <j-luthra@ti.com>
>> +Date: Thu, 23 Mar 2023 11:38:46 +0530
>> +Subject: [PATCH] simple: Support TI CSI-RX
> 
> Upstream-Status is missing here

Good catch.


> 
>> +Signed-off-by: Jai Luthra <j-luthra@ti.com>
>> +---
>> + src/libcamera/pipeline/simple/simple.cpp | 2 ++
>> + 1 file changed, 2 insertions(+)
>> +
>> +diff --git a/src/libcamera/pipeline/simple/simple.cpp b/src/libcamera/pipeline/simple/simple.cpp
>> +index e1f8b989..520405a1 100644
>> +--- a/src/libcamera/pipeline/simple/simple.cpp
>> ++++ b/src/libcamera/pipeline/simple/simple.cpp
>> +@@ -194,6 +194,8 @@ static const SimplePipelineInfo supportedDevices[] = {
>> + 	{ "mxc-isi", {} },
>> + 	{ "qcom-camss", {} },
>> + 	{ "sun6i-csi", {} },
>> ++	{ "j721e-csi2rx", {} },
>> ++
>> + };
>> +
>> + } /* namespace */
>> +--
>> +2.41.0
>> +
>> diff --git a/meta-arago-extras/recipes-multimedia/libcamera/libcamera_0.0.5.bb b/meta-arago-extras/recipes-multimedia/libcamera/libcamera_0.0.5.bb
>> index 6ad376f2..b2eb5fac 100644
>> --- a/meta-arago-extras/recipes-multimedia/libcamera/libcamera_0.0.5.bb
>> +++ b/meta-arago-extras/recipes-multimedia/libcamera/libcamera_0.0.5.bb
>> @@ -10,6 +10,7 @@ LIC_FILES_CHKSUM = "\
>>   
>>   SRC_URI = " \
>>           git://git.libcamera.org/libcamera/libcamera.git;protocol=https;branch=master \
>> +        file://0001-simple-Support-TI-CSI-RX.patch \
>>   "
>>   
>>   SRCREV = "fb44403f1c5571549ac128c21daee9761eb9249c"
>> -- 
>> 2.41.0
Jai Luthra July 6, 2023, 3:39 a.m. UTC | #3
Hi Denys,

On Jul 05, 2023 at 19:14:54 -0400, Denys Dmytriyenko wrote:
> On Wed, Jul 05, 2023 at 06:39:27PM +0530, Jai Luthra via lists.yoctoproject.org wrote:
> > TI's CSI-RX driver is not yet upstream, so the libcamera simple pipeline
> > does not recognize it.
> > 
> > Apply a patch to the simple pipeline so that it can recognize the media
> > entity for TI's CSI-RX driver.
> > 
> > Signed-off-by: Jai Luthra <j-luthra@ti.com>
> > ---
> >  .../0001-simple-Support-TI-CSI-RX.patch       | 26 +++++++++++++++++++
> >  .../libcamera/libcamera_0.0.5.bb              |  1 +
> >  2 files changed, 27 insertions(+)
> >  create mode 100644 meta-arago-extras/recipes-multimedia/libcamera/libcamera/0001-simple-Support-TI-CSI-RX.patch
> > 
> > diff --git a/meta-arago-extras/recipes-multimedia/libcamera/libcamera/0001-simple-Support-TI-CSI-RX.patch b/meta-arago-extras/recipes-multimedia/libcamera/libcamera/0001-simple-Support-TI-CSI-RX.patch
> > new file mode 100644
> > index 00000000..66b94863
> > --- /dev/null
> > +++ b/meta-arago-extras/recipes-multimedia/libcamera/libcamera/0001-simple-Support-TI-CSI-RX.patch
> > @@ -0,0 +1,26 @@
> > +From 2a82bce49ce4098ac17b4a654a9db5f2dee56415 Mon Sep 17 00:00:00 2001
> > +From: Jai Luthra <j-luthra@ti.com>
> > +Date: Thu, 23 Mar 2023 11:38:46 +0530
> > +Subject: [PATCH] simple: Support TI CSI-RX
> 
> Upstream-Status is missing here
> 

Thanks, will fix in v2.

> 
> > +Signed-off-by: Jai Luthra <j-luthra@ti.com>
> > +---
> > + src/libcamera/pipeline/simple/simple.cpp | 2 ++
> > + 1 file changed, 2 insertions(+)
> > +
> > +diff --git a/src/libcamera/pipeline/simple/simple.cpp b/src/libcamera/pipeline/simple/simple.cpp
> > +index e1f8b989..520405a1 100644
> > +--- a/src/libcamera/pipeline/simple/simple.cpp
> > ++++ b/src/libcamera/pipeline/simple/simple.cpp
> > +@@ -194,6 +194,8 @@ static const SimplePipelineInfo supportedDevices[] = {
> > + 	{ "mxc-isi", {} },
> > + 	{ "qcom-camss", {} },
> > + 	{ "sun6i-csi", {} },
> > ++	{ "j721e-csi2rx", {} },
> > ++
> > + };
> > + 
> > + } /* namespace */
> > +-- 
> > +2.41.0
> > +
> > diff --git a/meta-arago-extras/recipes-multimedia/libcamera/libcamera_0.0.5.bb b/meta-arago-extras/recipes-multimedia/libcamera/libcamera_0.0.5.bb
> > index 6ad376f2..b2eb5fac 100644
> > --- a/meta-arago-extras/recipes-multimedia/libcamera/libcamera_0.0.5.bb
> > +++ b/meta-arago-extras/recipes-multimedia/libcamera/libcamera_0.0.5.bb
> > @@ -10,6 +10,7 @@ LIC_FILES_CHKSUM = "\
> >  
> >  SRC_URI = " \
> >          git://git.libcamera.org/libcamera/libcamera.git;protocol=https;branch=master \
> > +        file://0001-simple-Support-TI-CSI-RX.patch \
> >  "
> >  
> >  SRCREV = "fb44403f1c5571549ac128c21daee9761eb9249c"
> > -- 
> > 2.41.0
diff mbox series

Patch

diff --git a/meta-arago-extras/recipes-multimedia/libcamera/libcamera/0001-simple-Support-TI-CSI-RX.patch b/meta-arago-extras/recipes-multimedia/libcamera/libcamera/0001-simple-Support-TI-CSI-RX.patch
new file mode 100644
index 00000000..66b94863
--- /dev/null
+++ b/meta-arago-extras/recipes-multimedia/libcamera/libcamera/0001-simple-Support-TI-CSI-RX.patch
@@ -0,0 +1,26 @@ 
+From 2a82bce49ce4098ac17b4a654a9db5f2dee56415 Mon Sep 17 00:00:00 2001
+From: Jai Luthra <j-luthra@ti.com>
+Date: Thu, 23 Mar 2023 11:38:46 +0530
+Subject: [PATCH] simple: Support TI CSI-RX
+
+Signed-off-by: Jai Luthra <j-luthra@ti.com>
+---
+ src/libcamera/pipeline/simple/simple.cpp | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/src/libcamera/pipeline/simple/simple.cpp b/src/libcamera/pipeline/simple/simple.cpp
+index e1f8b989..520405a1 100644
+--- a/src/libcamera/pipeline/simple/simple.cpp
++++ b/src/libcamera/pipeline/simple/simple.cpp
+@@ -194,6 +194,8 @@ static const SimplePipelineInfo supportedDevices[] = {
+ 	{ "mxc-isi", {} },
+ 	{ "qcom-camss", {} },
+ 	{ "sun6i-csi", {} },
++	{ "j721e-csi2rx", {} },
++
+ };
+ 
+ } /* namespace */
+-- 
+2.41.0
+
diff --git a/meta-arago-extras/recipes-multimedia/libcamera/libcamera_0.0.5.bb b/meta-arago-extras/recipes-multimedia/libcamera/libcamera_0.0.5.bb
index 6ad376f2..b2eb5fac 100644
--- a/meta-arago-extras/recipes-multimedia/libcamera/libcamera_0.0.5.bb
+++ b/meta-arago-extras/recipes-multimedia/libcamera/libcamera_0.0.5.bb
@@ -10,6 +10,7 @@  LIC_FILES_CHKSUM = "\
 
 SRC_URI = " \
         git://git.libcamera.org/libcamera/libcamera.git;protocol=https;branch=master \
+        file://0001-simple-Support-TI-CSI-RX.patch \
 "
 
 SRCREV = "fb44403f1c5571549ac128c21daee9761eb9249c"