diff mbox series

python3-urllib3: upgrade 2.0.2 -> 2.0.3

Message ID 20230703085205.3129883-1-tim.orling@konsulko.com
State Accepted, archived
Commit 38464a98571d8c2c321b976fbf7963262531c25c
Headers show
Series python3-urllib3: upgrade 2.0.2 -> 2.0.3 | expand

Commit Message

Tim Orling July 3, 2023, 8:52 a.m. UTC
https://github.com/urllib3/urllib3/blob/main/CHANGES.rst#203-2023-06-07

* Allowed alternative SSL libraries such as LibreSSL, while still issuing a
  warning as we cannot help users facing issues with implementations other
  than OpenSSL. (#3020)
* Deprecated URLs which don't have an explicit scheme (#2950)
* Fixed response decoding with Zstandard when compressed data is made of
  several frames. (#3008)
* Fixed assert_hostname=False to correctly skip hostname check. (#3051)

License-Update: Removed outdated reference to CONTRIBUTORS.txt

Signed-off-by: Tim Orling <tim.orling@konsulko.com>
---
 .../{python3-urllib3_2.0.2.bb => python3-urllib3_2.0.3.bb}    | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
 rename meta/recipes-devtools/python/{python3-urllib3_2.0.2.bb => python3-urllib3_2.0.3.bb} (76%)

Comments

Khem Raj July 3, 2023, 4:01 p.m. UTC | #1
On Mon, Jul 3, 2023 at 1:52 AM Tim Orling <ticotimo@gmail.com> wrote:
>
> https://github.com/urllib3/urllib3/blob/main/CHANGES.rst#203-2023-06-07
>
> * Allowed alternative SSL libraries such as LibreSSL, while still issuing a
>   warning as we cannot help users facing issues with implementations other
>   than OpenSSL. (#3020)
> * Deprecated URLs which don't have an explicit scheme (#2950)
> * Fixed response decoding with Zstandard when compressed data is made of
>   several frames. (#3008)
> * Fixed assert_hostname=False to correctly skip hostname check. (#3051)
>

Thanks for this update, I have reverted the previous upgrade to 2.0.2
since several
recipes in meta-python started failing ptests. I will give this a shot
and see if that
improves the situation.

> License-Update: Removed outdated reference to CONTRIBUTORS.txt
>
> Signed-off-by: Tim Orling <tim.orling@konsulko.com>
> ---
>  .../{python3-urllib3_2.0.2.bb => python3-urllib3_2.0.3.bb}    | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
>  rename meta/recipes-devtools/python/{python3-urllib3_2.0.2.bb => python3-urllib3_2.0.3.bb} (76%)
>
> diff --git a/meta/recipes-devtools/python/python3-urllib3_2.0.2.bb b/meta/recipes-devtools/python/python3-urllib3_2.0.3.bb
> similarity index 76%
> rename from meta/recipes-devtools/python/python3-urllib3_2.0.2.bb
> rename to meta/recipes-devtools/python/python3-urllib3_2.0.3.bb
> index bc1cdb009f4..64b21db86d2 100644
> --- a/meta/recipes-devtools/python/python3-urllib3_2.0.2.bb
> +++ b/meta/recipes-devtools/python/python3-urllib3_2.0.3.bb
> @@ -1,9 +1,9 @@
>  SUMMARY = "Python HTTP library with thread-safe connection pooling, file post support, sanity friendly, and more"
>  HOMEPAGE = "https://github.com/shazow/urllib3"
>  LICENSE = "MIT"
> -LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=c2823cb995439c984fd62a973d79815c"
> +LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=52d273a3054ced561275d4d15260ecda"
>
> -SRC_URI[sha256sum] = "61717a1095d7e155cdb737ac7bb2f4324a858a1e2e6466f6d03ff630ca68d3cc"
> +SRC_URI[sha256sum] = "bee28b5e56addb8226c96f7f13ac28cb4c301dd5ea8a6ca179c0b9835e032825"
>
>  inherit pypi python_hatchling
>
> --
> 2.30.2
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#183798): https://lists.openembedded.org/g/openembedded-core/message/183798
> Mute This Topic: https://lists.openembedded.org/mt/99923355/1997914
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python3-urllib3_2.0.2.bb b/meta/recipes-devtools/python/python3-urllib3_2.0.3.bb
similarity index 76%
rename from meta/recipes-devtools/python/python3-urllib3_2.0.2.bb
rename to meta/recipes-devtools/python/python3-urllib3_2.0.3.bb
index bc1cdb009f4..64b21db86d2 100644
--- a/meta/recipes-devtools/python/python3-urllib3_2.0.2.bb
+++ b/meta/recipes-devtools/python/python3-urllib3_2.0.3.bb
@@ -1,9 +1,9 @@ 
 SUMMARY = "Python HTTP library with thread-safe connection pooling, file post support, sanity friendly, and more"
 HOMEPAGE = "https://github.com/shazow/urllib3"
 LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=c2823cb995439c984fd62a973d79815c"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=52d273a3054ced561275d4d15260ecda"
 
-SRC_URI[sha256sum] = "61717a1095d7e155cdb737ac7bb2f4324a858a1e2e6466f6d03ff630ca68d3cc"
+SRC_URI[sha256sum] = "bee28b5e56addb8226c96f7f13ac28cb4c301dd5ea8a6ca179c0b9835e032825"
 
 inherit pypi python_hatchling