diff mbox series

libssh2: disable rpath to fix curl-native build

Message ID 20230630153246.5062-1-sudipm.mukherjee@gmail.com
State Accepted, archived
Commit c213d8579951e168a19231cf5b2f81d55e059a22
Headers show
Series libssh2: disable rpath to fix curl-native build | expand

Commit Message

Sudip Mukherjee June 30, 2023, 3:32 p.m. UTC
When curl is built with PACKAGECONFIG:append = " libssh2", the build fails
with the error:
gcc: error: unrecognized command-line option '-R'

It was trying to set the rpath for libssh2.

Signed-off-by: Sudip Mukherjee <sudipm.mukherjee@gmail.com>
---
 meta/recipes-support/libssh2/libssh2_1.11.0.bb | 1 +
 1 file changed, 1 insertion(+)
diff mbox series

Patch

diff --git a/meta/recipes-support/libssh2/libssh2_1.11.0.bb b/meta/recipes-support/libssh2/libssh2_1.11.0.bb
index 711bf937f5..edc25db1b1 100644
--- a/meta/recipes-support/libssh2/libssh2_1.11.0.bb
+++ b/meta/recipes-support/libssh2/libssh2_1.11.0.bb
@@ -18,6 +18,7 @@  inherit autotools pkgconfig ptest
 EXTRA_OECONF += "\
                  --with-libz \
                  --with-libz-prefix=${STAGING_LIBDIR} \
+                 --disable-rpath \
                 "
 DISABLE_STATIC = ""