[meta-python,4/5] python3-dnspython: Upgrade 2.1.0 -> 2.2.0

Message ID 20220119121858.1575699-4-leon.anavi@konsulko.com
State New
Headers show
Series [meta-python,1/5] python3-aenum: Upgrade 3.1.5 -> 3.1.6 | expand

Commit Message

Leon Anavi Jan. 19, 2022, 12:18 p.m. UTC
Upgrade to release 2.2.0:

- SVCB and HTTPS records have been updated to track the evolving
  draft standard.
- The ZONEMD type has been added.
- The resolver now returns a LifetimeTimeout exception which
  includes an error trace like the NoNameservers exception. This
  class is a subclass of dns.exception.Timeout for backwards
  compatibility.
- DNS-over-HTTPS will try to use HTTP/2 if the httpx and h2
  packages are installed.
- DNS-over-HTTPS is now supported for asynchronous queries and
  resolutions.
- dns.zonefile.read_rrsets() has been added, which allows rrsets
  in zonefile format, or a restrition of it, to be read. This
  function is useful for applications that want to read DNS data
  in text format, but do not want to use a Zone.
- On Windows systems, if the WMI module is available, the resolver
  will retrieve the nameserver from WMI instead of trying to
  figure it out by reading the registry. This may lead to more
  accurate results in some cases.
- The CERT rdatatype now supports certificate types IPKIX, ISPKI,
  IPGP, ACPKIX, and IACPKIX.
- The CDS rdatatype now allows digest type 0.
- Dnspython zones now enforces that a node is either a CNAME node
  or an "other data" node. A CNAME node contains only CNAME,
  RRSIG(CNAME), NSEC, RRSIG(NSEC), NSEC3, or RRSIG(NSEC3) rdatasets.
  An "other data" node contains any rdataset other than a CNAME or
  RRSIG(CNAME) rdataset. The enforcement is "last update wins". For
  example, if you have a node which contains a CNAME rdataset, and
  then add an MX rdataset to it, then the CNAME rdataset will be
  deleted. Likewise if you have a node containing an MX rdataset
  and add a CNAME rdataset, the MX rdataset will be deleted.
- Extended DNS Errors, as specified in RFC 8914, are now supported.

Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
---
 ...on3-dnspython_2.1.0.bb => python3-dnspython_2.2.0.bb} | 9 ++++++---
 1 file changed, 6 insertions(+), 3 deletions(-)
 rename meta-python/recipes-devtools/python/{python3-dnspython_2.1.0.bb => python3-dnspython_2.2.0.bb} (76%)

Patch

diff --git a/meta-python/recipes-devtools/python/python3-dnspython_2.1.0.bb b/meta-python/recipes-devtools/python/python3-dnspython_2.2.0.bb
similarity index 76%
rename from meta-python/recipes-devtools/python/python3-dnspython_2.1.0.bb
rename to meta-python/recipes-devtools/python/python3-dnspython_2.2.0.bb
index 5466b4061..ee670af82 100644
--- a/meta-python/recipes-devtools/python/python3-dnspython_2.1.0.bb
+++ b/meta-python/recipes-devtools/python/python3-dnspython_2.2.0.bb
@@ -3,9 +3,7 @@  HOMEPAGE = "http://www.dnspython.org/"
 LICENSE = "ISC"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=5af50906b5929837f667dfe31052bd34"
 
-SRC_URI[sha256sum] = "e4a87f0b573201a0f3727fa18a516b055fd1107e0e5477cded4a2de497df1dd4"
-
-PYPI_PACKAGE_EXT = "zip"
+SRC_URI[sha256sum] = "e79351e032d0b606b98d38a4b0e6e2275b31a5b85c873e587cc11b73aca026d6"
 
 inherit pypi setuptools3 ptest
 
@@ -22,6 +20,11 @@  do_install_ptest() {
 	cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
 }
 
+DEPENDS += "\
+    ${PYTHON_PN}-wheel-native \
+    ${PYTHON_PN}-setuptools-scm-native \
+"
+
 RDEPENDS:${PN} += " \
     ${PYTHON_PN}-crypt \
     ${PYTHON_PN}-io \