diff mbox series

python3: add cgitb, zipapp ptest dependencies

Message ID 20230629194813.1171680-1-tgamblin@baylibre.com
State New
Headers show
Series python3: add cgitb, zipapp ptest dependencies | expand

Commit Message

Trevor Gamblin June 29, 2023, 7:48 p.m. UTC
Without these, test_cgitb and test_zipapp both fail when running the
python3 ptests. Since cgitb is deprecated, I have only added it to
${PN}-ptest's RDEPENDS specifically, but zipapp is more current and
therefore I've put it in the ${PN}-misc list instead.

Also reorder the ${PN}-misc list to be alphabetical.

Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
---
 meta/recipes-devtools/python/python3_3.11.4.bb | 11 ++++++-----
 1 file changed, 6 insertions(+), 5 deletions(-)

Comments

Ross Burton July 4, 2023, 11:15 a.m. UTC | #1
On 29 Jun 2023, at 20:48, Trevor Gamblin via lists.openembedded.org <tgamblin=baylibre.com@lists.openembedded.org> wrote:
> 
> Without these, test_cgitb and test_zipapp both fail when running the
> python3 ptests. Since cgitb is deprecated, I have only added it to
> ${PN}-ptest's RDEPENDS specifically, but zipapp is more current and
> therefore I've put it in the ${PN}-misc list instead.

The RDEPENDS on misc to other modules should only be needed so that modules in misc actually work.

In this case, the problem is that test_zipapp fails because it’s not installed, so these should be dependencies on the ptest package to the split-out modules, and not a change to the -misc RDEPENDS.

Basically, add the depends to -ptest, and leave -misc as it is.

Ross
Trevor Gamblin July 4, 2023, 12:58 p.m. UTC | #2
On 2023-07-04 07:15, Ross Burton wrote:
> On 29 Jun 2023, at 20:48, Trevor Gamblin via lists.openembedded.org <tgamblin=baylibre.com@lists.openembedded.org> wrote:
>> Without these, test_cgitb and test_zipapp both fail when running the
>> python3 ptests. Since cgitb is deprecated, I have only added it to
>> ${PN}-ptest's RDEPENDS specifically, but zipapp is more current and
>> therefore I've put it in the ${PN}-misc list instead.
> The RDEPENDS on misc to other modules should only be needed so that modules in misc actually work.
>
> In this case, the problem is that test_zipapp fails because it’s not installed, so these should be dependencies on the ptest package to the split-out modules, and not a change to the -misc RDEPENDS.
>
> Basically, add the depends to -ptest, and leave -misc as it is.
Noted. v2 coming shortly.
>
> Ross
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python3_3.11.4.bb b/meta/recipes-devtools/python/python3_3.11.4.bb
index 6b074c48cf..cdd8bd0ab7 100644
--- a/meta/recipes-devtools/python/python3_3.11.4.bb
+++ b/meta/recipes-devtools/python/python3_3.11.4.bb
@@ -406,13 +406,14 @@  INSANE_SKIP:${PN}-ptest = "dev-deps"
 # catch all the rest (unsorted)
 PACKAGES += "${PN}-misc"
 RDEPENDS:${PN}-misc += "\
+  ${PN}-audio \
+  ${PN}-codecs \
   ${PN}-core \
   ${PN}-email \
-  ${PN}-codecs \
-  ${PN}-pydoc \
-  ${PN}-pickle \
-  ${PN}-audio \
   ${PN}-numbers \
+  ${PN}-pickle \
+  ${PN}-pydoc \
+  ${PN}-zipapp \
 "
 RDEPENDS:${PN}-modules:append:class-target = " ${MLPREFIX}python3-misc"
 RDEPENDS:${PN}-modules:append:class-nativesdk = " ${MLPREFIX}python3-misc"
@@ -426,7 +427,7 @@  FILES:${PN}-man = "${datadir}/man"
 # See https://bugs.python.org/issue18748 and https://bugs.python.org/issue37395
 RDEPENDS:libpython3:append:libc-glibc = " libgcc"
 RDEPENDS:${PN}-ctypes:append:libc-glibc = " ${MLPREFIX}ldconfig"
-RDEPENDS:${PN}-ptest = "${PN}-modules ${PN}-tests ${PN}-dev unzip bzip2 libgcc tzdata coreutils sed"
+RDEPENDS:${PN}-ptest = "${PN}-modules ${PN}-tests ${PN}-dev ${PN}-cgitb unzip bzip2 libgcc tzdata coreutils sed"
 RDEPENDS:${PN}-ptest:append:libc-glibc = " locale-base-fr-fr locale-base-en-us locale-base-tr-tr locale-base-de-de"
 RDEPENDS:${PN}-tkinter += "${@bb.utils.contains('PACKAGECONFIG', 'tk', '${MLPREFIX}tk ${MLPREFIX}tk-lib', '', d)}"
 RDEPENDS:${PN}-idle += "${@bb.utils.contains('PACKAGECONFIG', 'tk', '${PN}-tkinter ${MLPREFIX}tcl', '', d)}"