Patchwork xf86-video-vesa: Add recommendation for xserver libint10 module which this driver needs

login
register
mail settings
Submitter Richard Purdie
Date April 26, 2012, 1:08 p.m.
Message ID <1335445736.20130.13.camel@ted>
Download mbox | patch
Permalink /patch/26459/
State Accepted
Commit 04e5102e6d9f2332dd39467c3261d610338358fc
Headers show

Comments

Richard Purdie - April 26, 2012, 1:08 p.m.
Without this module, the driver doesn't work correctly.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
---

Patch

diff --git a/meta/recipes-graphics/xorg-driver/xf86-video-vesa_2.3.0.bb b/meta/recipes-graphics/xorg-driver/xf86-video-vesa_2.3.0.bb
index 30e3dee..f0c0167 100644
--- a/meta/recipes-graphics/xorg-driver/xf86-video-vesa_2.3.0.bb
+++ b/meta/recipes-graphics/xorg-driver/xf86-video-vesa_2.3.0.bb
@@ -11,12 +11,14 @@  can drive most VESA-compatible video cards, but only makes use of the \
 basic standard VESA core that is common to these cards. The driver \
 supports depths 8, 15 16 and 24."
 
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
 
 DEPENDS += "virtual/libx11 libxvmc drm xf86driproto glproto \
 	    virtual/libgl xineramaproto xf86driproto libpciaccess"
 
 COMPATIBLE_HOST = '(i.86|x86_64).*-linux'
 
+RRECOMMENDS_${PN} += "xserver-xorg-module-libint10"
+
 SRC_URI[md5sum] = "07fa32958aff9b463dd3af5481ef6626"
 SRC_URI[sha256sum] = "8ed85a0e94523539d81d5ae6639fa22ceb1c1e3baf89128915db65d4d2900d7a"