diff mbox series

[meta-ti,master/kirkstone] ti-img-rogue-umlibs: use rrecommends for components

Message ID 20230622223749.3106570-1-rs@ti.com
State Accepted
Delegated to: Ryan Eatmon
Headers show
Series [meta-ti,master/kirkstone] ti-img-rogue-umlibs: use rrecommends for components | expand

Commit Message

Randolph Sapp June 22, 2023, 10:37 p.m. UTC
From: Randolph Sapp <rs@ti.com>

Use RRECOMMENDS for components. Apparently I made an resolvable
dependency cycle that Yocto silently clipped. My best guess at the
culprit was: mesa-megadriver (RR) -> rogue-km (RR) -> rogue-um (RD) ->
libgles1-rogue (RD) -> mesa-megadriver

That killed the ti-img-rogue-umlibs recipe during do_rootfs. The rogue
GLES libs do depend on mesa-megadriver at runtime but I guess the UM
components should only really recommend the rogue GLES components be
present at runtime to make the cycle resolvable by opkg.

Fixes:
1705f6d3 (ti-img-rogue-umlibs: make all components optional, 2023-06-21)

Signed-off-by: Randolph Sapp <rs@ti.com>
---
 .../ti-img-rogue-umlibs_23.1.6404501.bb         | 17 ++++++-----------
 1 file changed, 6 insertions(+), 11 deletions(-)
diff mbox series

Patch

diff --git a/meta-ti-bsp/recipes-graphics/powervr-umlibs/ti-img-rogue-umlibs_23.1.6404501.bb b/meta-ti-bsp/recipes-graphics/powervr-umlibs/ti-img-rogue-umlibs_23.1.6404501.bb
index c012859f..9f129c9d 100644
--- a/meta-ti-bsp/recipes-graphics/powervr-umlibs/ti-img-rogue-umlibs_23.1.6404501.bb
+++ b/meta-ti-bsp/recipes-graphics/powervr-umlibs/ti-img-rogue-umlibs_23.1.6404501.bb
@@ -33,9 +33,9 @@  PACKAGECONFIG ?= " \
     ${@bb.utils.filter('DISTRO_FEATURES', 'opengl opencl', d)} \
 "
 
-PACKAGECONFIG[opengl] = ",,,${GLES_LIB_PACKAGES}"
-PACKAGECONFIG[vulkan] = ",,,${VULKAN_LIB_PACKAGES}"
-PACKAGECONFIG[opencl] = ",,,${OPENCL_LIB_PACKAGES},libopencl-rogue-tools"
+PACKAGECONFIG[opengl] = ",,,,${GLES_PACKAGES}"
+PACKAGECONFIG[vulkan] = ",,,,${VULKAN_PACKAGES}"
+PACKAGECONFIG[opencl] = ",,,,${OPENCL_PACKAGES}"
 
 def get_file_list(package_list_var, d):
     file_list = []
@@ -72,14 +72,9 @@  do_install:append() {
     fi
 }
 
-GLES_LIB_PACKAGES = "libgles1-rogue libgles2-rogue libgles3-rogue"
-GLES_PACKAGES = "${GLES_LIB_PACKAGES}"
-
-VULKAN_LIB_PACKAGES = "libvk-rogue"
-VULKAN_PACKAGES = "${VULKAN_LIB_PACKAGES}"
-
-OPENCL_LIB_PACKAGES = "libopencl-rogue"
-OPENCL_PACKAGES = "${OPENCL_LIB_PACKAGES} libopencl-rogue-tools"
+GLES_PACKAGES = "libgles1-rogue libgles2-rogue libgles3-rogue"
+VULKAN_PACKAGES = "libvk-rogue"
+OPENCL_PACKAGES = "libopencl-rogue libopencl-rogue-tools"
 
 PACKAGES = " \
     ${@bb.utils.contains('PACKAGECONFIG', 'opengl', d.getVar('GLES_PACKAGES'), '', d)} \