diff mbox series

[meta-ti,master/kirkstone] ti-img-rogue-umlibs: fix yocto package cache issue

Message ID 20230622202233.2740043-1-rs@ti.com
State Rejected
Delegated to: Ryan Eatmon
Headers show
Series [meta-ti,master/kirkstone] ti-img-rogue-umlibs: fix yocto package cache issue | expand

Commit Message

Randolph Sapp June 22, 2023, 8:22 p.m. UTC
From: Randolph Sapp <rs@ti.com>

There's a weird issue with Yocto's caching system (though it may be
intentional behavior). Changing the package config won't always update
the package contents when you are directly modifying the recipe's deploy
directory if there is a cached build.

Oddly enough, if you edit the source directory before do_install touches
the deploy directory, it seems to correctly reevaluate the cache.

Fixes:
1705f6d3 (ti-img-rogue-umlibs: make all components optional, 2023-06-21)

Signed-off-by: Randolph Sapp <rs@ti.com>
---
 .../ti-img-rogue-umlibs_23.1.6404501.bb        | 18 +++++++++---------
 1 file changed, 9 insertions(+), 9 deletions(-)
diff mbox series

Patch

diff --git a/meta-ti-bsp/recipes-graphics/powervr-umlibs/ti-img-rogue-umlibs_23.1.6404501.bb b/meta-ti-bsp/recipes-graphics/powervr-umlibs/ti-img-rogue-umlibs_23.1.6404501.bb
index c012859f..dd5ef11c 100644
--- a/meta-ti-bsp/recipes-graphics/powervr-umlibs/ti-img-rogue-umlibs_23.1.6404501.bb
+++ b/meta-ti-bsp/recipes-graphics/powervr-umlibs/ti-img-rogue-umlibs_23.1.6404501.bb
@@ -47,28 +47,28 @@  def get_file_list(package_list_var, d):
                 file_list.append(package_files)
     return " ".join(file_list)
 
-do_install:append() {
+do_install:prepend() {
     if ${@bb.utils.contains('PACKAGECONFIG', 'opengl', 'false', 'true', d)}; then
         for file in ${@get_file_list('GLES_PACKAGES', d)}; do
-            rm -rf ${D}/${file}
-            rmdir --ignore-fail-on-non-empty $(dirname ${D}/${file})
+            rm -rf ${S}/${file}
+            rmdir --ignore-fail-on-non-empty $(dirname ${S}/${file})
         done
     fi
     if ${@bb.utils.contains('PACKAGECONFIG', 'vulkan', 'false', 'true', d)}; then
         for file in ${@get_file_list('VULKAN_PACKAGES', d)}; do
-            rm -rf ${D}/${file}
-            rmdir --ignore-fail-on-non-empty $(dirname ${D}/${file})
+            rm -rf ${S}/${file}
+            rmdir --ignore-fail-on-non-empty $(dirname ${S}/${file})
         done
     fi
     if ${@bb.utils.contains('PACKAGECONFIG', 'opencl', 'false', 'true', d)}; then
         for file in ${@get_file_list('OPENCL_PACKAGES', d)}; do
-            rm -rf ${D}/${file}
-            rmdir --ignore-fail-on-non-empty $(dirname ${D}/${file})
+            rm -rf ${S}/${file}
+            rmdir --ignore-fail-on-non-empty $(dirname ${S}/${file})
         done
     fi
     if ${@bb.utils.contains('DISTRO_FEATURES', 'usrmerge', 'true', 'false', d)}; then
-        mv ${D}/lib/firmware ${D}${nonarch_base_libdir}
-        rmdir ${D}/lib
+        mv ${S}/lib/firmware ${S}${nonarch_base_libdir}
+        rmdir ${S}/lib
     fi
 }