diff mbox series

[master/kirkstone,v3] pruhsr-fw: SR2.0: Add new firmware

Message ID 20230622070336.10002-1-r-gunasekaran@ti.com
State Accepted
Delegated to: Ryan Eatmon
Headers show
Series [master/kirkstone,v3] pruhsr-fw: SR2.0: Add new firmware | expand

Commit Message

Ravi Gunasekaran June 22, 2023, 7:03 a.m. UTC
From: Ryan Eatmon <reatmon@ti.com>

We need to package up new HSR firmware for am65x-sr2.  Add dependencies
for them on the correct platforms.

Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Signed-off-by: Ravi Gunasekaran <r-gunasekaran@ti.com>
---
Changes in v3:
--------------
Filename "pruhsr-fw_am65x-sr2_git.bb" and package name "pruhsr-fw-am65x-sr2"
were mismatching. Fixed the filename similar to switch firmware
"prusw-fw-am65x-sr2_git.bb"

Changes in v2:
--------------
Names of firmware were changed to match existing filenames.

 .../pruhsr-fw/pruhsr-fw-am65x-sr2_git.bb      | 34 +++++++++++++++++++
 .../recipes-kernel/linux/kernel-rdepends.inc  |  4 +--
 2 files changed, 36 insertions(+), 2 deletions(-)
 create mode 100644 meta-ti-bsp/recipes-bsp/pruhsr-fw/pruhsr-fw-am65x-sr2_git.bb

Comments

Ryan Eatmon June 22, 2023, 11:46 a.m. UTC | #1
On 6/22/2023 2:03 AM, Ravi Gunasekaran wrote:
> From: Ryan Eatmon <reatmon@ti.com>
> 
> We need to package up new HSR firmware for am65x-sr2.  Add dependencies
> for them on the correct platforms.
> 
> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
> Signed-off-by: Ravi Gunasekaran <r-gunasekaran@ti.com>
> ---
> Changes in v3:
> --------------
> Filename "pruhsr-fw_am65x-sr2_git.bb" and package name "pruhsr-fw-am65x-sr2"
> were mismatching. Fixed the filename similar to switch firmware
> "prusw-fw-am65x-sr2_git.bb"

Thanks.  It was first on my list this morning to test my patch, but you 
beat me to the punch and found my issue.  Much appreciated.


> Changes in v2:
> --------------
> Names of firmware were changed to match existing filenames.
> 
>   .../pruhsr-fw/pruhsr-fw-am65x-sr2_git.bb      | 34 +++++++++++++++++++
>   .../recipes-kernel/linux/kernel-rdepends.inc  |  4 +--
>   2 files changed, 36 insertions(+), 2 deletions(-)
>   create mode 100644 meta-ti-bsp/recipes-bsp/pruhsr-fw/pruhsr-fw-am65x-sr2_git.bb
> 
> diff --git a/meta-ti-bsp/recipes-bsp/pruhsr-fw/pruhsr-fw-am65x-sr2_git.bb b/meta-ti-bsp/recipes-bsp/pruhsr-fw/pruhsr-fw-am65x-sr2_git.bb
> new file mode 100644
> index 00000000..c31af832
> --- /dev/null
> +++ b/meta-ti-bsp/recipes-bsp/pruhsr-fw/pruhsr-fw-am65x-sr2_git.bb
> @@ -0,0 +1,34 @@
> +SUMMARY = "PRU HSR firmware for AM65xx SR2.0"
> +
> +require recipes-bsp/ti-linux-fw/ti-linux-fw.inc
> +
> +PV = "${PRUETH_FW_AM65X_SR2_VERSION}"
> +PR = "${INC_PR}.0"
> +
> +CLEANBROKEN = "1"
> +
> +COMPATIBLE_MACHINE = "am65xx-evm|am64xx"
> +
> +PACKAGE_ARCH = "${MACHINE_ARCH}"
> +
> +S = "${WORKDIR}/git"
> +
> +TARGET = " \
> +    am65x-sr2-pru0-pruhsr-fw.elf \
> +    am65x-sr2-pru1-pruhsr-fw.elf \
> +    am65x-sr2-rtu0-pruhsr-fw.elf \
> +    am65x-sr2-rtu1-pruhsr-fw.elf \
> +    am65x-sr2-txpru0-pruhsr-fw.elf \
> +    am65x-sr2-txpru1-pruhsr-fw.elf \
> +"
> +
> +do_install() {
> +	install -d ${D}${nonarch_base_libdir}/firmware/ti-pruss
> +	for f in ${TARGET}; do
> +		install -m 0644 ${S}/ti-pruss/$f ${D}${nonarch_base_libdir}/firmware/ti-pruss/$f
> +	done
> +}
> +
> +FILES:${PN} = "${nonarch_base_libdir}/firmware"
> +
> +INSANE_SKIP:${PN} = "arch"
> diff --git a/meta-ti-bsp/recipes-kernel/linux/kernel-rdepends.inc b/meta-ti-bsp/recipes-kernel/linux/kernel-rdepends.inc
> index d2dcc3e5..7c8f3171 100644
> --- a/meta-ti-bsp/recipes-kernel/linux/kernel-rdepends.inc
> +++ b/meta-ti-bsp/recipes-kernel/linux/kernel-rdepends.inc
> @@ -16,8 +16,8 @@ RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:am57xx = " prueth-fw prusw-fw pruhsr
>   RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:ti43x = " prueth-fw pruhsr-fw pruprp-fw"
>   RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:ti33x = " prueth-fw pruhsr-fw pruprp-fw"
>   RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:am65xx = " prueth-fw-am65x"
> -RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:am65xx-evm = " prueth-fw-am65x-sr2 prusw-fw-am65x-sr2"
> -RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:am64xx = " prueth-fw-am65x-sr2"
> +RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:am65xx-evm = " prueth-fw-am65x-sr2 pruhsr-fw-am65x-sr2 prusw-fw-am65x-sr2"
> +RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:am64xx = " prueth-fw-am65x-sr2 pruhsr-fw-am65x-sr2"
>   
>   # Add run-time dependency for Cadence MHDP firmware to the rootfs
>   RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:j721e = " cadence-mhdp-fw"
diff mbox series

Patch

diff --git a/meta-ti-bsp/recipes-bsp/pruhsr-fw/pruhsr-fw-am65x-sr2_git.bb b/meta-ti-bsp/recipes-bsp/pruhsr-fw/pruhsr-fw-am65x-sr2_git.bb
new file mode 100644
index 00000000..c31af832
--- /dev/null
+++ b/meta-ti-bsp/recipes-bsp/pruhsr-fw/pruhsr-fw-am65x-sr2_git.bb
@@ -0,0 +1,34 @@ 
+SUMMARY = "PRU HSR firmware for AM65xx SR2.0"
+
+require recipes-bsp/ti-linux-fw/ti-linux-fw.inc
+
+PV = "${PRUETH_FW_AM65X_SR2_VERSION}"
+PR = "${INC_PR}.0"
+
+CLEANBROKEN = "1"
+
+COMPATIBLE_MACHINE = "am65xx-evm|am64xx"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+S = "${WORKDIR}/git"
+
+TARGET = " \
+    am65x-sr2-pru0-pruhsr-fw.elf \
+    am65x-sr2-pru1-pruhsr-fw.elf \
+    am65x-sr2-rtu0-pruhsr-fw.elf \
+    am65x-sr2-rtu1-pruhsr-fw.elf \
+    am65x-sr2-txpru0-pruhsr-fw.elf \
+    am65x-sr2-txpru1-pruhsr-fw.elf \
+"
+
+do_install() {
+	install -d ${D}${nonarch_base_libdir}/firmware/ti-pruss
+	for f in ${TARGET}; do
+		install -m 0644 ${S}/ti-pruss/$f ${D}${nonarch_base_libdir}/firmware/ti-pruss/$f
+	done
+}
+
+FILES:${PN} = "${nonarch_base_libdir}/firmware"
+
+INSANE_SKIP:${PN} = "arch"
diff --git a/meta-ti-bsp/recipes-kernel/linux/kernel-rdepends.inc b/meta-ti-bsp/recipes-kernel/linux/kernel-rdepends.inc
index d2dcc3e5..7c8f3171 100644
--- a/meta-ti-bsp/recipes-kernel/linux/kernel-rdepends.inc
+++ b/meta-ti-bsp/recipes-kernel/linux/kernel-rdepends.inc
@@ -16,8 +16,8 @@  RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:am57xx = " prueth-fw prusw-fw pruhsr
 RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:ti43x = " prueth-fw pruhsr-fw pruprp-fw"
 RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:ti33x = " prueth-fw pruhsr-fw pruprp-fw"
 RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:am65xx = " prueth-fw-am65x"
-RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:am65xx-evm = " prueth-fw-am65x-sr2 prusw-fw-am65x-sr2"
-RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:am64xx = " prueth-fw-am65x-sr2"
+RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:am65xx-evm = " prueth-fw-am65x-sr2 pruhsr-fw-am65x-sr2 prusw-fw-am65x-sr2"
+RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:am64xx = " prueth-fw-am65x-sr2 pruhsr-fw-am65x-sr2"
 
 # Add run-time dependency for Cadence MHDP firmware to the rootfs
 RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:j721e = " cadence-mhdp-fw"