[meta-oe] iotop: Use lld with clang on arm

Message ID 20220118224329.2392410-1-raj.khem@gmail.com
State New
Headers show
Series [meta-oe] iotop: Use lld with clang on arm | expand

Commit Message

Khem Raj Jan. 18, 2022, 10:43 p.m. UTC
BFD linker is crashing when using clang, workaround it by always using
lld when using clang on arm

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta-oe/recipes-extended/iotop/iotop_1.20.bb | 4 ++++
 1 file changed, 4 insertions(+)

Patch

diff --git a/meta-oe/recipes-extended/iotop/iotop_1.20.bb b/meta-oe/recipes-extended/iotop/iotop_1.20.bb
index 17c567095b..b05c8cd35d 100644
--- a/meta-oe/recipes-extended/iotop/iotop_1.20.bb
+++ b/meta-oe/recipes-extended/iotop/iotop_1.20.bb
@@ -12,6 +12,10 @@  inherit pkgconfig
 
 EXTRA_OEMAKE = "V=1 STRIP=true"
 
+# Workaround BFD linker crash with clang on arm
+# revisit when upgrading binutils and see if its fixed
+LDFLAGS:append:toolchain-clang:arm = " -fuse-ld=lld"
+
 do_install() {
     oe_runmake install DESTDIR=${D}
 }