diff mbox series

[meta-oe] redis-plus-plus: upgrade 1.3.8 -> 1.3.9

Message ID 1687157308-17342-4-git-send-email-wangmy@fujitsu.com
State Under Review
Headers show
Series [meta-oe] redis-plus-plus: upgrade 1.3.8 -> 1.3.9 | expand

Commit Message

Mingyu Wang (Fujitsu) June 19, 2023, 6:48 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

0001-CMakeLists.txt-fix-substitution-for-static-libs.patch
refresh for new version

Changelog:
===========
    Fix async interface bug
    More built-in commands support for AsyncRedis
    Fix incorrect hiredis static lib dependency when building with TSL
    Breaking change: make HSET related methods return long long instead of bool

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 ...ists.txt-fix-substitution-for-static-libs.patch | 14 +++++++-------
 ...plus-plus_1.3.8.bb => redis-plus-plus_1.3.9.bb} |  2 +-
 2 files changed, 8 insertions(+), 8 deletions(-)
 rename meta-oe/recipes-extended/redis-plus-plus/{redis-plus-plus_1.3.8.bb => redis-plus-plus_1.3.9.bb} (95%)
diff mbox series

Patch

diff --git a/meta-oe/recipes-extended/redis-plus-plus/files/0001-CMakeLists.txt-fix-substitution-for-static-libs.patch b/meta-oe/recipes-extended/redis-plus-plus/files/0001-CMakeLists.txt-fix-substitution-for-static-libs.patch
index 627b929b4..b652e6bb7 100644
--- a/meta-oe/recipes-extended/redis-plus-plus/files/0001-CMakeLists.txt-fix-substitution-for-static-libs.patch
+++ b/meta-oe/recipes-extended/redis-plus-plus/files/0001-CMakeLists.txt-fix-substitution-for-static-libs.patch
@@ -17,14 +17,14 @@  Upstream-Status: Submitted [https://github.com/sewenew/redis-plus-plus/issues/48
 
 Signed-off-by: Peter Bergin <peter.bergin@windriver.com>
 ---
- CMakeLists.txt | 5 ++---
- 1 file changed, 2 insertions(+), 3 deletions(-)
+ CMakeLists.txt | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
 
 diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 69794d9..08c265d 100644
+index 23a1840..5478271 100644
 --- a/CMakeLists.txt
 +++ b/CMakeLists.txt
-@@ -160,13 +160,12 @@ if(REDIS_PLUS_PLUS_BUILD_STATIC)
+@@ -184,13 +184,13 @@ if(REDIS_PLUS_PLUS_BUILD_STATIC)
      set(REDIS_PLUS_PLUS_HIREDIS_LIBS_STATIC ${REDIS_PLUS_PLUS_HIREDIS_LIBS})
  
      if (TARGET hiredis::hiredis_static)
@@ -32,11 +32,11 @@  index 69794d9..08c265d 100644
 +      string(REPLACE "hiredis::hiredis;" "hiredis::hiredis_static;" REDIS_PLUS_PLUS_HIREDIS_LIBS_STATIC
          "${REDIS_PLUS_PLUS_HIREDIS_LIBS_STATIC}")
      endif()
--
+ 
      if (TARGET hiredis::hiredis_ssl_static)
        # If SSL is not enabled, this line will have no effect
--      string(REPLACE "hiredis::hiredis_ssl" "hiredis::hiredis_ssl_static" REDIS_PLUS_PLUS_HIREDIS_LIBS_STATIC
-+      string(REPLACE "hiredis::hiredis_ssl;" "hiredis::hiredis_ssl_static;" REDIS_PLUS_PLUS_HIREDIS_LIBS_STATIC
+-      string(REPLACE "hiredis::hiredis_static_ssl" "hiredis::hiredis_ssl_static" REDIS_PLUS_PLUS_HIREDIS_LIBS_STATIC
++      string(REPLACE "hiredis::hiredis_static_ssl;" "hiredis::hiredis_ssl_static;" REDIS_PLUS_PLUS_HIREDIS_LIBS_STATIC
          "${REDIS_PLUS_PLUS_HIREDIS_LIBS_STATIC}")
      endif()
  
diff --git a/meta-oe/recipes-extended/redis-plus-plus/redis-plus-plus_1.3.8.bb b/meta-oe/recipes-extended/redis-plus-plus/redis-plus-plus_1.3.9.bb
similarity index 95%
rename from meta-oe/recipes-extended/redis-plus-plus/redis-plus-plus_1.3.8.bb
rename to meta-oe/recipes-extended/redis-plus-plus/redis-plus-plus_1.3.9.bb
index bea1f0b18..a8a93868e 100644
--- a/meta-oe/recipes-extended/redis-plus-plus/redis-plus-plus_1.3.8.bb
+++ b/meta-oe/recipes-extended/redis-plus-plus/redis-plus-plus_1.3.9.bb
@@ -8,7 +8,7 @@  DEPENDS += "hiredis"
 
 SRC_URI = "git://github.com/sewenew/redis-plus-plus;branch=master;protocol=https \
            file://0001-CMakeLists.txt-fix-substitution-for-static-libs.patch"
-SRCREV = "4368319fb668204f345da05b9dd79762506c67b6"
+SRCREV = "0c4ba0370e46c3d0d443c0368d02195faa791219"
 
 S = "${WORKDIR}/git"