diff mbox series

[2/5] libxml2: Do not use lld linker when building with tests on rv64

Message ID 20230616083111.3007680-2-raj.khem@gmail.com
State Accepted, archived
Commit 154e81bb6b05b23c0c673b431cb7cee868421335
Headers show
Series [1/5] kernel: Add kernel specific STRIP variable | expand

Commit Message

Khem Raj June 16, 2023, 8:31 a.m. UTC
lld ends up with errors on some tests
| riscv64-yoe-linux-ld.lld: error: section size decrease is too large

Therefore do not use lld when building ptests

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta/recipes-core/libxml/libxml2_2.10.4.bb | 2 ++
 1 file changed, 2 insertions(+)
diff mbox series

Patch

diff --git a/meta/recipes-core/libxml/libxml2_2.10.4.bb b/meta/recipes-core/libxml/libxml2_2.10.4.bb
index 288631504ce..4f3b17093e4 100644
--- a/meta/recipes-core/libxml/libxml2_2.10.4.bb
+++ b/meta/recipes-core/libxml/libxml2_2.10.4.bb
@@ -40,6 +40,8 @@  inherit autotools pkgconfig binconfig-disabled ptest
 
 inherit ${@bb.utils.contains('PACKAGECONFIG', 'python', 'python3targetconfig', '', d)}
 
+LDFLAGS:append:riscv64 = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-lld ptest', ' -fuse-ld=bfd', '', d)}"
+
 RDEPENDS:${PN}-ptest += "bash make locale-base-en-us ${@bb.utils.contains('PACKAGECONFIG', 'python', 'libgcc python3-core python3-logging python3-shell python3-stringold python3-threading python3-unittest ${PN}-python', '', d)}"
 
 RDEPENDS:${PN}-python += "${@bb.utils.contains('PACKAGECONFIG', 'python', 'python3-core', '', d)}"