diff mbox series

[AUH] python3-pyasn1: upgrading to 0.5.0 SUCCEEDED

Message ID 01010188c2544571-b0a2e009-0ce4-4493-9837-65889f31fbbd-000000@us-west-2.amazonses.com
State New
Headers show
Series [AUH] python3-pyasn1: upgrading to 0.5.0 SUCCEEDED | expand

Commit Message

auh@yoctoproject.org June 16, 2023, 3:51 a.m. UTC
Hello,

this email is a notification from the Auto Upgrade Helper
that the automatic attempt to upgrade the recipe *python3-pyasn1* to *0.5.0* has Succeeded.

Next steps:
    - apply the patch: git am 0001-python3-pyasn1-upgrade-0.4.8-0.5.0.patch
    - check the changes to upstream patches and summarize them in the commit message,
    - compile an image that contains the package
    - perform some basic sanity tests
    - amend the patch and sign it off: git commit -s --reset-author --amend
    - send it to the appropriate mailing list

Alternatively, if you believe the recipe should not be upgraded at this time,
you can fill RECIPE_NO_UPDATE_REASON in respective recipe file so that
automatic upgrades would no longer be attempted.

Please review the attached files for further information and build/update failures.
Any problem please file a bug at https://bugzilla.yoctoproject.org/enter_bug.cgi?product=Automated%20Update%20Handler

Regards,
The Upgrade Helper

-- >8 --
From 2fc6107241d1f6943f9e20a93c1bf58fba533d31 Mon Sep 17 00:00:00 2001
From: Upgrade Helper <auh@yoctoproject.org>
Date: Thu, 15 Jun 2023 13:34:44 +0000
Subject: [PATCH] python3-pyasn1: upgrade 0.4.8 -> 0.5.0

---
 .../recipes-devtools/python/python-pyasn1.inc | 12 ++++----
 ...arning-__int__-returned-non-int-on-P.patch | 28 -------------------
 .../python/python3-pyasn1_0.4.8.bb            |  2 --
 .../python/python3-pyasn1_0.5.0.bb            | 22 +++++++++++++++
 4 files changed, 27 insertions(+), 37 deletions(-)
 delete mode 100644 meta/recipes-devtools/python/python3-pyasn1/0001-Fix-DeprecationWarning-__int__-returned-non-int-on-P.patch
 delete mode 100644 meta/recipes-devtools/python/python3-pyasn1_0.4.8.bb
 create mode 100644 meta/recipes-devtools/python/python3-pyasn1_0.5.0.bb
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python-pyasn1.inc b/meta/recipes-devtools/python/python-pyasn1.inc
index 126d0388ef..0931e77341 100644
--- a/meta/recipes-devtools/python/python-pyasn1.inc
+++ b/meta/recipes-devtools/python/python-pyasn1.inc
@@ -1,10 +1,9 @@ 
 SUMMARY = "Python library implementing ASN.1 types."
 HOMEPAGE = "http://pyasn1.sourceforge.net/"
 LICENSE = "BSD-2-Clause"
-LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=a14482d15c2249de3b6f0e8a47e021fd"
+LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=190f79253908c986e6cacf380c3a5f6d"
 
-SRC_URI[md5sum] = "dffae4ff9f997a83324b3f33fe62be54"
-SRC_URI[sha256sum] = "aef77c9fb94a3ac588e87841208bdec464471d9871bd5050a287cc9a475cd0ba"
+SRC_URI[sha256sum] = "97b7290ca68e62a832558ec3976f15cbf911bf5d7c7039d8b861c2a0ece69fde"
 
 RDEPENDS:${PN}:class-target += " \
     ${PYTHON_PN}-codecs \
@@ -17,10 +16,9 @@  BBCLASSEXTEND = "native nativesdk"
 
 inherit ptest
 
-SRC_URI += " \
-	file://run-ptest \
-	file://0001-Fix-DeprecationWarning-__int__-returned-non-int-on-P.patch \
-"
+SRC_URI = "${PYPI_SRC_URI} \
+           file://run-ptest \
+           "
 
 RDEPENDS:${PN}-ptest += " \
 	${PYTHON_PN}-pytest \
diff --git a/meta/recipes-devtools/python/python3-pyasn1/0001-Fix-DeprecationWarning-__int__-returned-non-int-on-P.patch b/meta/recipes-devtools/python/python3-pyasn1/0001-Fix-DeprecationWarning-__int__-returned-non-int-on-P.patch
deleted file mode 100644
index 30ac9a6684..0000000000
--- a/meta/recipes-devtools/python/python3-pyasn1/0001-Fix-DeprecationWarning-__int__-returned-non-int-on-P.patch
+++ /dev/null
@@ -1,28 +0,0 @@ 
-From db8f1a7930c6b5826357646746337dafc983f953 Mon Sep 17 00:00:00 2001
-From: Ilya Etingof <etingof@gmail.com>
-Date: Sat, 21 Mar 2020 19:05:03 +0100
-Subject: [PATCH] Fix `DeprecationWarning: __int__ returned non-int` on Py3
-
-In `BitString.__int__()`
-Upstream-Status: Backport
-Signed-off-by: Yulong Liu <yulong.liu@windriver.com>
----
- pyasn1/type/univ.py | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/pyasn1/type/univ.py b/pyasn1/type/univ.py
-index 10924c3..488241f 100644
---- a/pyasn1/type/univ.py
-+++ b/pyasn1/type/univ.py
-@@ -551,7 +551,7 @@ class BitString(base.SimpleAsn1Type):
-         return self.clone(SizedInteger(self._value >> count).setBitLength(max(0, len(self._value) - count)))
- 
-     def __int__(self):
--        return self._value
-+        return int(self._value)
- 
-     def __float__(self):
-         return float(self._value)
--- 
-2.25.1
-
diff --git a/meta/recipes-devtools/python/python3-pyasn1_0.4.8.bb b/meta/recipes-devtools/python/python3-pyasn1_0.4.8.bb
deleted file mode 100644
index a5e2a71362..0000000000
--- a/meta/recipes-devtools/python/python3-pyasn1_0.4.8.bb
+++ /dev/null
@@ -1,2 +0,0 @@ 
-inherit pypi setuptools3
-require python-pyasn1.inc
diff --git a/meta/recipes-devtools/python/python3-pyasn1_0.5.0.bb b/meta/recipes-devtools/python/python3-pyasn1_0.5.0.bb
new file mode 100644
index 0000000000..51ce432261
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-pyasn1_0.5.0.bb
@@ -0,0 +1,22 @@ 
+# FIXME: the LIC_FILES_CHKSUM values have been updated by 'devtool upgrade'.
+# The following is the difference between the old and the new license text.
+# Please update the LICENSE value if needed, and summarize the changes in
+# the commit message via 'License-Update:' tag.
+# (example: 'License-Update: copyright years updated.')
+#
+# The changes:
+#
+# --- LICENSE.rst
+# +++ LICENSE.rst
+# @@ -1,4 +1,4 @@
+# -Copyright (c) 2005-2019, Ilya Etingof <etingof@gmail.com>
+# +Copyright (c) 2005-2020, Ilya Etingof <etingof@gmail.com>
+#  All rights reserved.
+#  
+#  Redistribution and use in source and binary forms, with or without
+# 
+#
+
+inherit pypi setuptools3
+require python-pyasn1.inc
+