diff mbox series

[meta-arago,master/kirkstone] ti-test-extras: add package group for large tests

Message ID 20230615172807.673971-1-rs@ti.com
State Accepted
Delegated to: Ryan Eatmon
Headers show
Series [meta-arago,master/kirkstone] ti-test-extras: add package group for large tests | expand

Commit Message

Randolph Sapp June 15, 2023, 5:28 p.m. UTC
From: Randolph Sapp <rs@ti.com>

This is required for images that expect ti-test to be installed but
actually use a ramdisk for primary storage. Piglit and the corresponding
cts tests are the real problems at the moment so we're moving those
first. Other tests may follow.

Signed-off-by: Randolph Sapp <rs@ti.com>
---
 .../recipes-core/images/tisdk-default-image.bb   |  1 +
 .../recipes-core/packagegroups/ti-test-extras.bb | 16 ++++++++++++++++
 .../recipes-core/packagegroups/ti-test.bb        |  3 ---
 3 files changed, 17 insertions(+), 3 deletions(-)
 create mode 100644 meta-arago-distro/recipes-core/packagegroups/ti-test-extras.bb

Comments

Denys Dmytriyenko June 15, 2023, 5:45 p.m. UTC | #1
On Thu, Jun 15, 2023 at 12:28:07PM -0500, rs@ti.com wrote:
> From: Randolph Sapp <rs@ti.com>
> 
> This is required for images that expect ti-test to be installed but
> actually use a ramdisk for primary storage. Piglit and the corresponding
> cts tests are the real problems at the moment so we're moving those
> first. Other tests may follow.

Why not make it a single packagegroup recipe producing 2 packages? Other 
packagegroups already doing it - tisdk-matrix, tisdk-addons, tisdk-opencl.


> Signed-off-by: Randolph Sapp <rs@ti.com>
> ---
>  .../recipes-core/images/tisdk-default-image.bb   |  1 +
>  .../recipes-core/packagegroups/ti-test-extras.bb | 16 ++++++++++++++++
>  .../recipes-core/packagegroups/ti-test.bb        |  3 ---
>  3 files changed, 17 insertions(+), 3 deletions(-)
>  create mode 100644 meta-arago-distro/recipes-core/packagegroups/ti-test-extras.bb
> 
> diff --git a/meta-arago-distro/recipes-core/images/tisdk-default-image.bb b/meta-arago-distro/recipes-core/images/tisdk-default-image.bb
> index 3b9747c1..bb825e09 100644
> --- a/meta-arago-distro/recipes-core/images/tisdk-default-image.bb
> +++ b/meta-arago-distro/recipes-core/images/tisdk-default-image.bb
> @@ -12,6 +12,7 @@ IMAGE_INSTALL += "\
>      packagegroup-arago-console \
>      packagegroup-arago-base-tisdk \
>      ti-test \
> +    ti-test-extras \
>      ${@bb.utils.contains('DISTRO_FEATURES','opengl','packagegroup-arago-tisdk-graphics','',d)} \
>      ${@bb.utils.contains('DISTRO_FEATURES','opengl','packagegroup-arago-tisdk-gtk','',d)} \
>      ${@bb.utils.contains('DISTRO_FEATURES','opengl','packagegroup-arago-tisdk-qte','',d)} \
> diff --git a/meta-arago-distro/recipes-core/packagegroups/ti-test-extras.bb b/meta-arago-distro/recipes-core/packagegroups/ti-test-extras.bb
> new file mode 100644
> index 00000000..6d69b165
> --- /dev/null
> +++ b/meta-arago-distro/recipes-core/packagegroups/ti-test-extras.bb
> @@ -0,0 +1,16 @@
> +SUMMARY = "TI Testing packagegroup for big tests"
> +LICENSE = "MIT"
> +
> +PACKAGE_ARCH = "${MACHINE_ARCH}"
> +
> +inherit packagegroup
> +
> +ARAGO_TEST_EXTRAS = "\
> +    piglit \
> +    ${@bb.utils.contains("DISTRO_FEATURES", "opengl", "opengl-es-cts", "", d)} \
> +    ${@bb.utils.contains("DISTRO_FEATURES", "vulkan", "vulkan-cts", "", d)} \
> +"
> +
> +RDEPENDS:${PN} = "\
> +    ${ARAGO_TEST_EXTRAS} \
> +"
> diff --git a/meta-arago-distro/recipes-core/packagegroups/ti-test.bb b/meta-arago-distro/recipes-core/packagegroups/ti-test.bb
> index 210bc5a9..3e45077b 100644
> --- a/meta-arago-distro/recipes-core/packagegroups/ti-test.bb
> +++ b/meta-arago-distro/recipes-core/packagegroups/ti-test.bb
> @@ -38,9 +38,6 @@ ARAGO_TEST = "\
>      nbench-byte \
>      stream \
>      cryptodev-tests \
> -    piglit \
> -    ${@bb.utils.contains("DISTRO_FEATURES", "opengl", "opengl-es-cts", "", d)} \
> -    ${@bb.utils.contains("DISTRO_FEATURES", "vulkan", "vulkan-cts", "", d)} \
>  "
>  
>  ARAGO_TEST:append:armv7a = " \
> -- 
> 2.41.0
Ryan Eatmon June 15, 2023, 5:47 p.m. UTC | #2
On 6/15/2023 12:45 PM, Denys Dmytriyenko wrote:
> On Thu, Jun 15, 2023 at 12:28:07PM -0500, rs@ti.com wrote:
>> From: Randolph Sapp <rs@ti.com>
>>
>> This is required for images that expect ti-test to be installed but
>> actually use a ramdisk for primary storage. Piglit and the corresponding
>> cts tests are the real problems at the moment so we're moving those
>> first. Other tests may follow.
> 
> Why not make it a single packagegroup recipe producing 2 packages? Other
> packagegroups already doing it - tisdk-matrix, tisdk-addons, tisdk-opencl.

In the longer term, I want to move to this.  But this is an "emergency" 
patch to try and fix a test issue for the CICD flow.  I'll migrate this 
to that new style after we get a promotion.

> 
>> Signed-off-by: Randolph Sapp <rs@ti.com>
>> ---
>>   .../recipes-core/images/tisdk-default-image.bb   |  1 +
>>   .../recipes-core/packagegroups/ti-test-extras.bb | 16 ++++++++++++++++
>>   .../recipes-core/packagegroups/ti-test.bb        |  3 ---
>>   3 files changed, 17 insertions(+), 3 deletions(-)
>>   create mode 100644 meta-arago-distro/recipes-core/packagegroups/ti-test-extras.bb
>>
>> diff --git a/meta-arago-distro/recipes-core/images/tisdk-default-image.bb b/meta-arago-distro/recipes-core/images/tisdk-default-image.bb
>> index 3b9747c1..bb825e09 100644
>> --- a/meta-arago-distro/recipes-core/images/tisdk-default-image.bb
>> +++ b/meta-arago-distro/recipes-core/images/tisdk-default-image.bb
>> @@ -12,6 +12,7 @@ IMAGE_INSTALL += "\
>>       packagegroup-arago-console \
>>       packagegroup-arago-base-tisdk \
>>       ti-test \
>> +    ti-test-extras \
>>       ${@bb.utils.contains('DISTRO_FEATURES','opengl','packagegroup-arago-tisdk-graphics','',d)} \
>>       ${@bb.utils.contains('DISTRO_FEATURES','opengl','packagegroup-arago-tisdk-gtk','',d)} \
>>       ${@bb.utils.contains('DISTRO_FEATURES','opengl','packagegroup-arago-tisdk-qte','',d)} \
>> diff --git a/meta-arago-distro/recipes-core/packagegroups/ti-test-extras.bb b/meta-arago-distro/recipes-core/packagegroups/ti-test-extras.bb
>> new file mode 100644
>> index 00000000..6d69b165
>> --- /dev/null
>> +++ b/meta-arago-distro/recipes-core/packagegroups/ti-test-extras.bb
>> @@ -0,0 +1,16 @@
>> +SUMMARY = "TI Testing packagegroup for big tests"
>> +LICENSE = "MIT"
>> +
>> +PACKAGE_ARCH = "${MACHINE_ARCH}"
>> +
>> +inherit packagegroup
>> +
>> +ARAGO_TEST_EXTRAS = "\
>> +    piglit \
>> +    ${@bb.utils.contains("DISTRO_FEATURES", "opengl", "opengl-es-cts", "", d)} \
>> +    ${@bb.utils.contains("DISTRO_FEATURES", "vulkan", "vulkan-cts", "", d)} \
>> +"
>> +
>> +RDEPENDS:${PN} = "\
>> +    ${ARAGO_TEST_EXTRAS} \
>> +"
>> diff --git a/meta-arago-distro/recipes-core/packagegroups/ti-test.bb b/meta-arago-distro/recipes-core/packagegroups/ti-test.bb
>> index 210bc5a9..3e45077b 100644
>> --- a/meta-arago-distro/recipes-core/packagegroups/ti-test.bb
>> +++ b/meta-arago-distro/recipes-core/packagegroups/ti-test.bb
>> @@ -38,9 +38,6 @@ ARAGO_TEST = "\
>>       nbench-byte \
>>       stream \
>>       cryptodev-tests \
>> -    piglit \
>> -    ${@bb.utils.contains("DISTRO_FEATURES", "opengl", "opengl-es-cts", "", d)} \
>> -    ${@bb.utils.contains("DISTRO_FEATURES", "vulkan", "vulkan-cts", "", d)} \
>>   "
>>   
>>   ARAGO_TEST:append:armv7a = " \
>> -- 
>> 2.41.0
Randolph Sapp June 15, 2023, 6:36 p.m. UTC | #3
On 6/15/23 12:47, Ryan Eatmon wrote:
> On 6/15/2023 12:45 PM, Denys Dmytriyenko wrote:
>> On Thu, Jun 15, 2023 at 12:28:07PM -0500, rs@ti.com wrote:
>>> From: Randolph Sapp <rs@ti.com>
>>>
>>> This is required for images that expect ti-test to be installed but
>>> actually use a ramdisk for primary storage. Piglit and the corresponding
>>> cts tests are the real problems at the moment so we're moving those
>>> first. Other tests may follow.
>>
>> Why not make it a single packagegroup recipe producing 2 packages? Other
>> packagegroups already doing it - tisdk-matrix, tisdk-addons, 
>> tisdk-opencl.
> 
> In the longer term, I want to move to this.  But this is an "emergency" 
> patch to try and fix a test issue for the CICD flow.  I'll migrate this 
> to that new style after we get a promotion.
> 

I assumed the standard was one file per package group. If that's 
incorrect then I'll fix it.
diff mbox series

Patch

diff --git a/meta-arago-distro/recipes-core/images/tisdk-default-image.bb b/meta-arago-distro/recipes-core/images/tisdk-default-image.bb
index 3b9747c1..bb825e09 100644
--- a/meta-arago-distro/recipes-core/images/tisdk-default-image.bb
+++ b/meta-arago-distro/recipes-core/images/tisdk-default-image.bb
@@ -12,6 +12,7 @@  IMAGE_INSTALL += "\
     packagegroup-arago-console \
     packagegroup-arago-base-tisdk \
     ti-test \
+    ti-test-extras \
     ${@bb.utils.contains('DISTRO_FEATURES','opengl','packagegroup-arago-tisdk-graphics','',d)} \
     ${@bb.utils.contains('DISTRO_FEATURES','opengl','packagegroup-arago-tisdk-gtk','',d)} \
     ${@bb.utils.contains('DISTRO_FEATURES','opengl','packagegroup-arago-tisdk-qte','',d)} \
diff --git a/meta-arago-distro/recipes-core/packagegroups/ti-test-extras.bb b/meta-arago-distro/recipes-core/packagegroups/ti-test-extras.bb
new file mode 100644
index 00000000..6d69b165
--- /dev/null
+++ b/meta-arago-distro/recipes-core/packagegroups/ti-test-extras.bb
@@ -0,0 +1,16 @@ 
+SUMMARY = "TI Testing packagegroup for big tests"
+LICENSE = "MIT"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+inherit packagegroup
+
+ARAGO_TEST_EXTRAS = "\
+    piglit \
+    ${@bb.utils.contains("DISTRO_FEATURES", "opengl", "opengl-es-cts", "", d)} \
+    ${@bb.utils.contains("DISTRO_FEATURES", "vulkan", "vulkan-cts", "", d)} \
+"
+
+RDEPENDS:${PN} = "\
+    ${ARAGO_TEST_EXTRAS} \
+"
diff --git a/meta-arago-distro/recipes-core/packagegroups/ti-test.bb b/meta-arago-distro/recipes-core/packagegroups/ti-test.bb
index 210bc5a9..3e45077b 100644
--- a/meta-arago-distro/recipes-core/packagegroups/ti-test.bb
+++ b/meta-arago-distro/recipes-core/packagegroups/ti-test.bb
@@ -38,9 +38,6 @@  ARAGO_TEST = "\
     nbench-byte \
     stream \
     cryptodev-tests \
-    piglit \
-    ${@bb.utils.contains("DISTRO_FEATURES", "opengl", "opengl-es-cts", "", d)} \
-    ${@bb.utils.contains("DISTRO_FEATURES", "vulkan", "vulkan-cts", "", d)} \
 "
 
 ARAGO_TEST:append:armv7a = " \