diff mbox series

[46/55] shaderc: upgrade 2023.2 -> 2023.4

Message ID 20230614092918.4065570-46-alex@linutronix.de
State Accepted, archived
Commit e7987b03e949a26be90be2654c7da4e3783667da
Headers show
Series [01/55] insane.bbclass: add a SUMMARY/HOMEPAGE check (oe-core recipes only) | expand

Commit Message

Alexander Kanavin June 14, 2023, 9:29 a.m. UTC
Signed-off-by: Alexander Kanavin <alex@linutronix.de>
---
 ...isable-building-external-dependencies.patch | 18 ++++++++----------
 .../{shaderc_2023.2.bb => shaderc_2023.4.bb}   |  2 +-
 2 files changed, 9 insertions(+), 11 deletions(-)
 rename meta/recipes-graphics/shaderc/{shaderc_2023.2.bb => shaderc_2023.4.bb} (95%)
diff mbox series

Patch

diff --git a/meta/recipes-graphics/shaderc/files/0001-cmake-disable-building-external-dependencies.patch b/meta/recipes-graphics/shaderc/files/0001-cmake-disable-building-external-dependencies.patch
index cc9a4000281..35855bd8326 100644
--- a/meta/recipes-graphics/shaderc/files/0001-cmake-disable-building-external-dependencies.patch
+++ b/meta/recipes-graphics/shaderc/files/0001-cmake-disable-building-external-dependencies.patch
@@ -1,7 +1,7 @@ 
-From 071a9d71bea91bbefcf15e061fc87e53568f3188 Mon Sep 17 00:00:00 2001
+From d3fbd6b9427f29606540528d17fe02930cd78d0c Mon Sep 17 00:00:00 2001
 From: Jose Quaresma <quaresma.jose@gmail.com>
 Date: Sat, 13 Feb 2021 00:45:56 +0000
-Subject: [PATCH 1/3] cmake: disable building external dependencies
+Subject: [PATCH] cmake: disable building external dependencies
 
 - add cmake option to disable the build of the third_party dependencies
 - change the update_build_version.py to use pkg-config when third_party dependencies not found
@@ -9,24 +9,25 @@  Subject: [PATCH 1/3] cmake: disable building external dependencies
 Upstream-Status: Inappropriate [OE-core specific]
 
 Signed-off-by: Jose Quaresma <quaresma.jose@gmail.com>
+
 ---
  CMakeLists.txt                | 13 ++++++++++---
  utils/update_build_version.py | 22 +++++++++++++++-------
  2 files changed, 25 insertions(+), 10 deletions(-)
 
 diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 5c74cd8..b358f6b 100644
+index 633c244..75b01da 100644
 --- a/CMakeLists.txt
 +++ b/CMakeLists.txt
-@@ -41,6 +41,7 @@ else()
+@@ -67,6 +67,7 @@ else()
  endif()
  
  option(SHADERC_ENABLE_WERROR_COMPILE "Enable passing -Werror to compiler, if available" ON)
 +option(BUILD_EXTERNAL "Build external dependencies in /third_party" ON)
  
- set (CMAKE_CXX_STANDARD 11)
+ set (CMAKE_CXX_STANDARD 17)
  
-@@ -101,8 +102,14 @@ endif(MSVC)
+@@ -129,8 +130,14 @@ endif(MSVC)
  
  
  # Configure subdirectories.
@@ -43,7 +44,7 @@  index 5c74cd8..b358f6b 100644
  
  add_subdirectory(libshaderc_util)
  add_subdirectory(libshaderc)
-@@ -112,7 +119,7 @@ add_subdirectory(examples)
+@@ -142,7 +149,7 @@ endif()
  add_custom_target(build-version
    ${PYTHON_EXECUTABLE}
    ${CMAKE_CURRENT_SOURCE_DIR}/utils/update_build_version.py
@@ -104,6 +105,3 @@  index 5785390..f72b762 100755
      mkdir_p(os.path.dirname(output_file))
  
      if os.path.isfile(output_file):
--- 
-2.30.1
-
diff --git a/meta/recipes-graphics/shaderc/shaderc_2023.2.bb b/meta/recipes-graphics/shaderc/shaderc_2023.4.bb
similarity index 95%
rename from meta/recipes-graphics/shaderc/shaderc_2023.2.bb
rename to meta/recipes-graphics/shaderc/shaderc_2023.4.bb
index 07fae0bb7ec..739e7ae81c9 100644
--- a/meta/recipes-graphics/shaderc/shaderc_2023.2.bb
+++ b/meta/recipes-graphics/shaderc/shaderc_2023.4.bb
@@ -6,7 +6,7 @@  HOMEPAGE = "https://github.com/google/shaderc"
 LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
 
-SRCREV = "55f4bbd993de3a3cad34cb41cd07b82fa1c77dd6"
+SRCREV = "7a8b3da0583425cf511336cf3afbdcf2ebc8b36b"
 SRC_URI = "git://github.com/google/shaderc.git;protocol=https;branch=main \
            file://0001-cmake-disable-building-external-dependencies.patch \
            file://0002-libshaderc_util-fix-glslang-header-file-location.patch \