Patchwork [0/3] Bug 2134 - bitbake package-index fails for rpm

login
register
mail settings
Submitter Andrei Gherzan
Date April 11, 2012, 2:26 p.m.
Message ID <cover.1334154247.git.andrei@gherzan.ro>
Download mbox
Permalink /patch/25599/
State New
Headers show

Pull-request

git://git.yoctoproject.org/poky-contrib ag/package-index

Comments

Andrei Gherzan - April 11, 2012, 2:26 p.m.
The bug is that the native python used to run genpkgmetadata.py is picking up
host's python modules.

More about this. RPM is built without python. And this modules is needed by the
above py file.

So: 
1. rpm-native should be built with python support.
2. native python should only look into STAGING_DIR_NATIVE directory for
modules.
3. createrepo scripts should use native python


The following changes since commit 190f6d791d51aaa4cfb9f1cf932bc205ff674fb5:

  runqemu-internal: Add console=tty for qemuppc and NFS (2012-04-06 01:12:47 +0100)

are available in the git repository at:
  git://git.yoctoproject.org/poky-contrib ag/package-index
  http://git.yoctoproject.org/cgit.cgi/poky-contrib/log/?h=ag/package-index

Andrei Gherzan (3):
  createrepo: Python scripts should use the python interpreter from env
  package-index: Force NATIVE python to use modules from
    STAGING_DIR_NATIVE
  rpm-native: Compile python rpm module (with-python)

 meta/recipes-core/meta/package-index.bb            |    3 +
 meta/recipes-devtools/rpm/rpm_5.4.0.bb             |    2 -
 ...n-scripts-should-use-interpreter-from-env.patch |   47 ++++++++++++++++++++
 .../createrepo/createrepo_0.4.11.bb                |    3 +-
 4 files changed, 52 insertions(+), 3 deletions(-)
 create mode 100644 meta/recipes-support/createrepo/createrepo/python-scripts-should-use-interpreter-from-env.patch
Saul Wold - April 13, 2012, 10:17 p.m.
On 04/11/2012 07:26 AM, Andrei Gherzan wrote:
> The bug is that the native python used to run genpkgmetadata.py is picking up
> host's python modules.
>
> More about this. RPM is built without python. And this modules is needed by the
> above py file.
>
> So:
> 1. rpm-native should be built with python support.
> 2. native python should only look into STAGING_DIR_NATIVE directory for
> modules.
> 3. createrepo scripts should use native python
>
>
> The following changes since commit 190f6d791d51aaa4cfb9f1cf932bc205ff674fb5:
>
>    runqemu-internal: Add console=tty for qemuppc and NFS (2012-04-06 01:12:47 +0100)
>
> are available in the git repository at:
>    git://git.yoctoproject.org/poky-contrib ag/package-index
>    http://git.yoctoproject.org/cgit.cgi/poky-contrib/log/?h=ag/package-index
>
> Andrei Gherzan (3):
>    createrepo: Python scripts should use the python interpreter from env
>    package-index: Force NATIVE python to use modules from
>      STAGING_DIR_NATIVE
>    rpm-native: Compile python rpm module (with-python)
>
>   meta/recipes-core/meta/package-index.bb            |    3 +
>   meta/recipes-devtools/rpm/rpm_5.4.0.bb             |    2 -
>   ...n-scripts-should-use-interpreter-from-env.patch |   47 ++++++++++++++++++++
>   .../createrepo/createrepo_0.4.11.bb                |    3 +-
>   4 files changed, 52 insertions(+), 3 deletions(-)
>   create mode 100644 meta/recipes-support/createrepo/createrepo/python-scripts-should-use-interpreter-from-env.patch
>

Merged into OE-Core

Thanks
	Sau!