Patchwork [1/1] meta-toolchain: runqemu falied on FC16/Opensuse12.1 x86_64

login
register
mail settings
Submitter Robert Yang
Date April 9, 2012, 10:22 a.m.
Message ID <39c1bc8164acaa0d6f461bd8d614a7dbd30df22c.1333966697.git.liezhi.yang@windriver.com>
Download mbox | patch
Permalink /patch/25375/
State Accepted
Commit 5f1becfba0b801eeacb1c626659fe46cd6df25bf
Headers show

Comments

Robert Yang - April 9, 2012, 10:22 a.m.
runqemu can't launch a target image on Fedora 16 64bit or Opensuse 12.1
64bit, this is because runqemu needs the host's libGL.so, which requires
GLIBC_2.14 which is defined in libc.so.6, but our default libc.so.6 is
version 2.13, here is the message from Richard:

The easiest solution would be to change the nativesdk libc to 2.15. I don't
think we plan to do this for the target libc for 1.2 but we could change
nativesdk's version if its well tested

[YOCTO #1968]

Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
---
 meta/conf/distro/include/tcmode-default.inc |    4 ++--
 1 files changed, 2 insertions(+), 2 deletions(-)

Patch

diff --git a/meta/conf/distro/include/tcmode-default.inc b/meta/conf/distro/include/tcmode-default.inc
index b481163..3dc0932 100644
--- a/meta/conf/distro/include/tcmode-default.inc
+++ b/meta/conf/distro/include/tcmode-default.inc
@@ -44,9 +44,9 @@  PREFERRED_VERSION_linux-libc-headers ?= "${LINUXLIBCVERSION}"
 PREFERRED_VERSION_linux-libc-headers-nativesdk ?= "${LINUXLIBCVERSION}"
 PREFERRED_VERSION_eglibc                   ?= "${EGLIBCVERSION}"
 PREFERRED_VERSION_eglibc-locale            ?= "${EGLIBCVERSION}"
-PREFERRED_VERSION_eglibc-nativesdk         ?= "${EGLIBCVERSION}"
+PREFERRED_VERSION_eglibc-nativesdk         ?= "2.15"
 PREFERRED_VERSION_eglibc-initial           ?= "${EGLIBCVERSION}"
-PREFERRED_VERSION_eglibc-initial-nativesdk ?= "${EGLIBCVERSION}"
+PREFERRED_VERSION_eglibc-initial-nativesdk ?= "2.15"
 PREFERRED_VERSION_cross-localedef-native   ?= "${EGLIBCVERSION}"
 PREFERRED_VERSION_uclibc                   ?= "${UCLIBCVERSION}"
 PREFERRED_VERSION_uclibc-initial           ?= "${UCLIBCVERSION}"