diff mbox series

python3-pip: upgrade 23.0.1 -> 23.1.2

Message ID 1685610221-29015-16-git-send-email-wangmy@fujitsu.com
State Accepted, archived
Commit d859e35c533976d05bc7e74e05c3fc111654670f
Headers show
Series python3-pip: upgrade 23.0.1 -> 23.1.2 | expand

Commit Message

Mingyu Wang (Fujitsu) June 1, 2023, 9:03 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

License-Update:
  -Copyright changed from "(C) 2016 Jason R Coombs <jaraco@jaraco.com>"
   to "Jason R. Coombs"
  -The wrapping position has been adjusted

Changelog:
===========
- Upgrade setuptools to 67.7.2
- Revert #11487, as it causes issues with virtualenvs created by the Windows
  Store distribution of Python. (#11987)
- Fix grammar by changing "A new release of pip available:" to "A new release
  of pip is available:" in the notice used for indicating that. (#11529)
- Normalize paths before checking if installed scripts are on PATH. (#11719)
- Correct the way to decide if keyring is available. (#11774)
- More consistent resolution backtracking by removing legacy hack related to
  setuptools resolution (#11837)
- Include AUTHORS.txt in pip's wheels. (#11882)
- The uninstall and install --force-reinstall commands no longer call
  normalize_path() repeatedly on the same paths. Instead, these results are
  cached for the duration of an uninstall operation, resulting in improved
  performance, particularly on Windows. (#11889)
- Fix and improve the parsing of hashes embedded in URL fragments. (#11936)
- When package A depends on package B provided as a direct URL dependency
  including a hash embedded in the link, the --require-hashes option did not
  warn when user supplied hashes were missing for package B. (#11938)
- Correctly report requested_extras in the installation report when extras
  are specified for a local directory installation. (#11946)
- When installing an archive from a direct URL or local file, populate
  download_info.info.hashes in the installation report, in addition to the
  legacy download_info.info.hash key. (#11948)

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../python/{python3-pip_23.0.1.bb => python3-pip_23.1.2.bb}   | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
 rename meta/recipes-devtools/python/{python3-pip_23.0.1.bb => python3-pip_23.1.2.bb} (96%)
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python3-pip_23.0.1.bb b/meta/recipes-devtools/python/python3-pip_23.1.2.bb
similarity index 96%
rename from meta/recipes-devtools/python/python3-pip_23.0.1.bb
rename to meta/recipes-devtools/python/python3-pip_23.1.2.bb
index d9b9906ff9..a0ebd765bf 100644
--- a/meta/recipes-devtools/python/python3-pip_23.0.1.bb
+++ b/meta/recipes-devtools/python/python3-pip_23.1.2.bb
@@ -13,7 +13,7 @@  LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=63ec52baf95163b597008bb46db68030 \
                     file://src/pip/_vendor/msgpack/COPYING;md5=cd9523181d9d4fbf7ffca52eaa2a5751 \
                     file://src/pip/_vendor/packaging/LICENSE;md5=faadaedca9251a90b205c9167578ce91 \
                     file://src/pip/_vendor/packaging/LICENSE.APACHE;md5=2ee41112a44fe7014dce33e26468ba93 \
-                    file://src/pip/_vendor/pkg_resources/LICENSE;md5=9a33897f1bca1160d7aad3835152e158 \
+                    file://src/pip/_vendor/pkg_resources/LICENSE;md5=7a7126e068206290f3fe9f8d6c713ea6 \
                     file://src/pip/_vendor/platformdirs/LICENSE;md5=ea4f5a41454746a9ed111e3d8723d17a \
                     file://src/pip/_vendor/pygments/LICENSE;md5=36a13c90514e2899f1eba7f41c3ee592 \
                     file://src/pip/_vendor/pyparsing/LICENSE;md5=657a566233888513e1f07ba13e2f47f1 \
@@ -33,7 +33,7 @@  inherit pypi python_setuptools_build_meta
 
 SRC_URI += "file://no_shebang_mangling.patch"
 
-SRC_URI[sha256sum] = "cd015ea1bfb0fcef59d8a286c1f8bebcb983f6317719d415dc5351efb7cd7024"
+SRC_URI[sha256sum] = "0e7c86f486935893c708287b30bd050a36ac827ec7fe5e43fe7cb198dd835fba"
 
 do_install:append() {
     rm -f ${D}/${bindir}/pip