diff mbox series

[meta-python,v2] python3-snagboot: new recipe

Message ID 20230527190902.6482-1-brgl@bgdev.pl
State Under Review
Headers show
Series [meta-python,v2] python3-snagboot: new recipe | expand

Commit Message

Bartosz Golaszewski May 27, 2023, 7:09 p.m. UTC
From: Bartosz Golaszewski <bartosz.golaszewski@linaro.org>

Add a recipe that builds snagrecover and snagflash. These tools are
useful for yocto-based distros used to control DUTs in board farms.

Signed-off-by: Bartosz Golaszewski <bartosz.golaszewski@linaro.org>
---
v1 -> v2:
- move recipe to meta-python as it depends on python3-pyusb
- install udev rules

 .../python/python3-snagboot_1.0.bb            | 21 +++++++++++++++++++
 1 file changed, 21 insertions(+)
 create mode 100644 meta-python/recipes-devtools/python/python3-snagboot_1.0.bb
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-snagboot_1.0.bb b/meta-python/recipes-devtools/python/python3-snagboot_1.0.bb
new file mode 100644
index 000000000..1853596b4
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-snagboot_1.0.bb
@@ -0,0 +1,21 @@ 
+SUMMARY = "Snagboot intends to be an open-source replacement vendor-specific tools used to recover and/or reflash embedded platforms."
+
+LICENSE = "GPL-2.0-only"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+SRC_URI[sha256sum] = "c2d21cadddecfd97dd62a8b66b6f88bd56272627b9b71272e9dda6f868ee8715"
+
+inherit pypi python_setuptools_build_meta
+
+RDEPENDS:${PN} += " \
+    bash \
+    python3-fcntl \
+    python3-pyusb \
+    python3-pyyaml \
+    python3-setuptools \
+    python3-six \
+"
+
+do_install:append() {
+    install -D -m 0644 ${S}/src/snagrecover/80-snagboot.rules ${D}${sysconfdir}/udev/rules.d/80-snagboot.rules
+}