diff mbox series

[meta-oe] switchtec-user: add new recipe

Message ID 20230526122134.63056-1-cvubrugier@fastmail.fm
State Under Review
Headers show
Series [meta-oe] switchtec-user: add new recipe | expand

Commit Message

Christophe Vu-Brugier May 26, 2023, 12:21 p.m. UTC
From: Christophe Vu-Brugier <christophe.vu-brugier@seagate.com>

switchtec-user provides an easy to use CLI and C library for
communicating with Microsemi's Switchtec management interface.

https://github.com/Microsemi/switchtec-user/

Signed-off-by: Christophe Vu-Brugier <christophe.vu-brugier@seagate.com>
---
 ...0001-cli-Fix-format-security-warning.patch | 27 +++++++++++++++++++
 .../switchtec-user/switchtec-user_4.1.bb      | 23 ++++++++++++++++
 2 files changed, 50 insertions(+)
 create mode 100644 meta-oe/recipes-support/switchtec-user/switchtec-user/0001-cli-Fix-format-security-warning.patch
 create mode 100644 meta-oe/recipes-support/switchtec-user/switchtec-user_4.1.bb
diff mbox series

Patch

diff --git a/meta-oe/recipes-support/switchtec-user/switchtec-user/0001-cli-Fix-format-security-warning.patch b/meta-oe/recipes-support/switchtec-user/switchtec-user/0001-cli-Fix-format-security-warning.patch
new file mode 100644
index 0000000000..ff2743eb68
--- /dev/null
+++ b/meta-oe/recipes-support/switchtec-user/switchtec-user/0001-cli-Fix-format-security-warning.patch
@@ -0,0 +1,27 @@ 
+From 2d61587f85d1bf57287d12b470afb94c0bf9249d Mon Sep 17 00:00:00 2001
+From: Davide Cavalca <dcavalca@fedoraproject.org>
+Date: Mon, 27 Jun 2022 16:54:35 -0700
+Subject: [PATCH] cli: Fix format security warning
+
+Upstream-Status: Submitted [https://github.com/Microsemi/switchtec-user/pull/316]
+
+---
+ cli/graph.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/cli/graph.c b/cli/graph.c
+index 5748914..95609de 100644
+--- a/cli/graph.c
++++ b/cli/graph.c
+@@ -134,7 +134,7 @@ static void draw_status(WINDOW *win, int x_off, int x_cnt, const char *status)
+ 	mvwprintw(win, 0, 0, "     ");
+ 	for (i = 0; i < x_cnt * 2 + x_off; i++)
+ 		mvwaddch(win, 1, i, ' ');
+-	mvwprintw(win, 1, x_off, status);
++	mvwprintw(win, 1, x_off, "%s", status);
+ 	wrefresh(win);
+ }
+ 
+-- 
+2.39.2
+
diff --git a/meta-oe/recipes-support/switchtec-user/switchtec-user_4.1.bb b/meta-oe/recipes-support/switchtec-user/switchtec-user_4.1.bb
new file mode 100644
index 0000000000..6d5c9f1a67
--- /dev/null
+++ b/meta-oe/recipes-support/switchtec-user/switchtec-user_4.1.bb
@@ -0,0 +1,23 @@ 
+SUMMARY = "Easy to use CLI and C library for communicating with Microsemi's Switchtec management interface"
+HOMEPAGE = "https://github.com/Microsemi/switchtec-user"
+SECTION = "console/utils"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3d6b07c89629cff2990d2e8e1f4c2382"
+DEPENDS = "ncurses openssl"
+SRCREV = "762ba441d2c02685f98e5f56e984db033bab279a"
+
+SRC_URI = " \
+        git://github.com/Microsemi/switchtec-user.git;protocol=https;branch=master \
+        file://0001-cli-Fix-format-security-warning.patch \
+"
+SRC_URI[sha256sum] = "f98c1fe23e1d7a11fb23e8bcf9b563929fc805ea669191a7fd525ad16519f655"
+
+S = "${WORKDIR}/git"
+
+inherit autotools-brokensep pkgconfig
+
+EXTRA_OEMAKE = "DESTDIR=\"${D}\" PREFIX=\"${prefix}\" LDCONFIG=\"true\""
+
+do_install () {
+        oe_runmake install
+}