[2/3] iotop: move to the C port of iotop

Message ID 20220114115246.3985850-2-ross.burton@arm.com
State New
Headers show
Series [1/3] cxxtest: move to setuptools | expand

Commit Message

Ross Burton Jan. 14, 2022, 11:52 a.m. UTC
The Python iotop implentation hasn't had a release since 2013[1], and
there is a C port which is actively maintained and will have a lower
impact on the system being monitored.

[1] https://repo.or.cz/iotop.git/tag/10c60fedf5051421f4e62b89e2e51e7cc669ce34

Signed-off-by: Ross Burton <ross.burton@arm.com>
---
 meta-oe/recipes-extended/iotop/iotop_0.6.bb  | 29 --------------------
 meta-oe/recipes-extended/iotop/iotop_1.20.bb | 17 ++++++++++++
 2 files changed, 17 insertions(+), 29 deletions(-)
 delete mode 100644 meta-oe/recipes-extended/iotop/iotop_0.6.bb
 create mode 100644 meta-oe/recipes-extended/iotop/iotop_1.20.bb

Comments

Khem Raj Jan. 15, 2022, 1:25 a.m. UTC | #1
It fails on clang/arm see
https://errors.yoctoproject.org/Errors/Details/622623/

On Fri, Jan 14, 2022 at 3:52 AM Ross Burton <ross@burtonini.com> wrote:
>
> The Python iotop implentation hasn't had a release since 2013[1], and
> there is a C port which is actively maintained and will have a lower
> impact on the system being monitored.
>
> [1] https://repo.or.cz/iotop.git/tag/10c60fedf5051421f4e62b89e2e51e7cc669ce34
>
> Signed-off-by: Ross Burton <ross.burton@arm.com>
> ---
>  meta-oe/recipes-extended/iotop/iotop_0.6.bb  | 29 --------------------
>  meta-oe/recipes-extended/iotop/iotop_1.20.bb | 17 ++++++++++++
>  2 files changed, 17 insertions(+), 29 deletions(-)
>  delete mode 100644 meta-oe/recipes-extended/iotop/iotop_0.6.bb
>  create mode 100644 meta-oe/recipes-extended/iotop/iotop_1.20.bb
>
> diff --git a/meta-oe/recipes-extended/iotop/iotop_0.6.bb b/meta-oe/recipes-extended/iotop/iotop_0.6.bb
> deleted file mode 100644
> index 97958dd4a2..0000000000
> --- a/meta-oe/recipes-extended/iotop/iotop_0.6.bb
> +++ /dev/null
> @@ -1,29 +0,0 @@
> -SUMMARY = "Simple top-like I/O monitor"
> -DESCRIPTION = "iotop does for I/O usage what top(1) does for CPU usage. \
> -    It watches I/O usage information output by the Linux kernel and displays \
> -    a table of current I/O usage by processes on the system."
> -HOMEPAGE = "http://guichaz.free.fr/iotop/"
> -
> -LICENSE = "GPLv2+"
> -LIC_FILES_CHKSUM = "file://COPYING;md5=4325afd396febcb659c36b49533135d4"
> -
> -PV .= "+git${SRCPV}"
> -
> -SRCREV = "1bfb3bc70febb1ffb95146b6dcd65257228099a3"
> -SRC_URI = "git://repo.or.cz/iotop.git;branch=master"
> -
> -S = "${WORKDIR}/git"
> -
> -UPSTREAM_CHECK_URI = "http://repo.or.cz/iotop.git/tags"
> -UPSTREAM_CHECK_REGEX = "iotop-(?P<pver>\d+(\.\d+)+)"
> -
> -inherit distutils3
> -
> -do_install:append() {
> -    rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/site.pyo || true
> -    rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/site.py  || true
> -}
> -
> -RDEPENDS:${PN} = "python3-curses \
> -                  python3-codecs python3-ctypes python3-pprint \
> -                  python3-shell python3-core"
> diff --git a/meta-oe/recipes-extended/iotop/iotop_1.20.bb b/meta-oe/recipes-extended/iotop/iotop_1.20.bb
> new file mode 100644
> index 0000000000..17c567095b
> --- /dev/null
> +++ b/meta-oe/recipes-extended/iotop/iotop_1.20.bb
> @@ -0,0 +1,17 @@
> +SUMMARY = "A top utility for I/O"
> +LICENSE = "GPLv2+"
> +LIC_FILES_CHKSUM = "file://LICENSE;md5=48e7be78bd2671d08c9c3bad71f1cfaa"
> +
> +DEPENDS = "ncurses"
> +
> +SRC_URI = "https://github.com/Tomas-M/iotop/releases/download/v1.20/iotop-1.20.tar.xz"
> +SRC_URI[sha256sum] = "e0227dd4b71ce3ffe50225b85cf9abb38a99c1d2dff69e3f1db7d059d7490d51"
> +UPSTREAM_CHECK_URI = "https://github.com/Tomas-M/iotop/releases"
> +
> +inherit pkgconfig
> +
> +EXTRA_OEMAKE = "V=1 STRIP=true"
> +
> +do_install() {
> +    oe_runmake install DESTDIR=${D}
> +}
> --
> 2.25.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#94828): https://lists.openembedded.org/g/openembedded-devel/message/94828
> Mute This Topic: https://lists.openembedded.org/mt/88418863/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Ross Burton Jan. 15, 2022, 10:33 a.m. UTC | #2
On Sat, 15 Jan 2022 at 01:26, Khem Raj <raj.khem@gmail.com> wrote:
> It fails on clang/arm see
> https://errors.yoctoproject.org/Errors/Details/622623/

That's clang segfaulting, fun!  I don't have access to my build
machine this weekend, can you just throw in TOOLCHAIN="gcc" for now?

Ross
Khem Raj Jan. 15, 2022, 7:02 p.m. UTC | #3
On Sat, Jan 15, 2022 at 2:33 AM Ross Burton <ross@burtonini.com> wrote:

> On Sat, 15 Jan 2022 at 01:26, Khem Raj <raj.khem@gmail.com> wrote:
> > It fails on clang/arm see
> > https://errors.yoctoproject.org/Errors/Details/622623/
>
> That's clang segfaulting, fun!  I don't have access to my build
> machine this weekend, can you just throw in TOOLCHAIN="gcc" for now?
>

Yeah and it’s with glibc master so not a big deal I will still extract a
test case for reporting to llvm GitHub issue

>
> Ross
>

Patch

diff --git a/meta-oe/recipes-extended/iotop/iotop_0.6.bb b/meta-oe/recipes-extended/iotop/iotop_0.6.bb
deleted file mode 100644
index 97958dd4a2..0000000000
--- a/meta-oe/recipes-extended/iotop/iotop_0.6.bb
+++ /dev/null
@@ -1,29 +0,0 @@ 
-SUMMARY = "Simple top-like I/O monitor"
-DESCRIPTION = "iotop does for I/O usage what top(1) does for CPU usage. \
-    It watches I/O usage information output by the Linux kernel and displays \
-    a table of current I/O usage by processes on the system."
-HOMEPAGE = "http://guichaz.free.fr/iotop/"
-
-LICENSE = "GPLv2+"
-LIC_FILES_CHKSUM = "file://COPYING;md5=4325afd396febcb659c36b49533135d4"
-
-PV .= "+git${SRCPV}"
-
-SRCREV = "1bfb3bc70febb1ffb95146b6dcd65257228099a3"
-SRC_URI = "git://repo.or.cz/iotop.git;branch=master"
-
-S = "${WORKDIR}/git"
-
-UPSTREAM_CHECK_URI = "http://repo.or.cz/iotop.git/tags"
-UPSTREAM_CHECK_REGEX = "iotop-(?P<pver>\d+(\.\d+)+)"
-
-inherit distutils3
-
-do_install:append() {
-    rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/site.pyo || true
-    rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/site.py  || true
-}
-
-RDEPENDS:${PN} = "python3-curses \
-                  python3-codecs python3-ctypes python3-pprint \
-                  python3-shell python3-core"
diff --git a/meta-oe/recipes-extended/iotop/iotop_1.20.bb b/meta-oe/recipes-extended/iotop/iotop_1.20.bb
new file mode 100644
index 0000000000..17c567095b
--- /dev/null
+++ b/meta-oe/recipes-extended/iotop/iotop_1.20.bb
@@ -0,0 +1,17 @@ 
+SUMMARY = "A top utility for I/O"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=48e7be78bd2671d08c9c3bad71f1cfaa"
+
+DEPENDS = "ncurses"
+
+SRC_URI = "https://github.com/Tomas-M/iotop/releases/download/v1.20/iotop-1.20.tar.xz"
+SRC_URI[sha256sum] = "e0227dd4b71ce3ffe50225b85cf9abb38a99c1d2dff69e3f1db7d059d7490d51"
+UPSTREAM_CHECK_URI = "https://github.com/Tomas-M/iotop/releases"
+
+inherit pkgconfig
+
+EXTRA_OEMAKE = "V=1 STRIP=true"
+
+do_install() {
+    oe_runmake install DESTDIR=${D}
+}