diff mbox series

[kirkstone,5/7] weston: add weston user to the render group

Message ID 20230524181122.35202-6-rs@ti.com
State Accepted
Delegated to: Ryan Eatmon
Headers show
Series Rootless Weston and Weston patch cleanup | expand

Commit Message

Randolph Sapp May 24, 2023, 6:11 p.m. UTC
From: Randolph Sapp <rs@ti.com>

The weston user must be added to the render group to use dri render
devices.

Signed-off-by: Randolph Sapp <rs@ti.com>
---
 .../recipes-graphics/wayland/weston_10.0.2.bbappend          | 5 +++++
 1 file changed, 5 insertions(+)
diff mbox series

Patch

diff --git a/meta-arago-distro/recipes-graphics/wayland/weston_10.0.2.bbappend b/meta-arago-distro/recipes-graphics/wayland/weston_10.0.2.bbappend
index 989bc28c..edc1bebd 100644
--- a/meta-arago-distro/recipes-graphics/wayland/weston_10.0.2.bbappend
+++ b/meta-arago-distro/recipes-graphics/wayland/weston_10.0.2.bbappend
@@ -12,3 +12,8 @@  SRC_URI += " \
         file://0001-Revert-require-GL_EXT_unpack_subimage-commit.patch \
 "
 
+# required for weston user to interact with the render devices
+inherit extrausers
+EXTRA_USERS_PARAMS = " \
+	usermod -aG render weston; \
+"