diff mbox series

[kirkstone,6/7] weston: drop the fix-virtual-keyboard-display-issue patch

Message ID 20230524181122.35202-7-rs@ti.com
State Accepted
Delegated to: Ryan Eatmon
Headers show
Series Rootless Weston and Weston patch cleanup | expand

Commit Message

Randolph Sapp May 24, 2023, 6:11 p.m. UTC
From: Randolph Sapp <rs@ti.com>

Weston 10 changed the way it handles focus grabbing. This shouldn't be
relevant anymore.

Signed-off-by: Randolph Sapp <rs@ti.com>
---
 ...al-keyboard-display-issue-for-QT5-ap.patch | 41 -------------------
 .../wayland/weston_10.0.2.bbappend            |  1 -
 2 files changed, 42 deletions(-)
 delete mode 100644 meta-arago-distro/recipes-graphics/wayland/weston/0003-weston-Fix-virtual-keyboard-display-issue-for-QT5-ap.patch
diff mbox series

Patch

diff --git a/meta-arago-distro/recipes-graphics/wayland/weston/0003-weston-Fix-virtual-keyboard-display-issue-for-QT5-ap.patch b/meta-arago-distro/recipes-graphics/wayland/weston/0003-weston-Fix-virtual-keyboard-display-issue-for-QT5-ap.patch
deleted file mode 100644
index 32901db9..00000000
--- a/meta-arago-distro/recipes-graphics/wayland/weston/0003-weston-Fix-virtual-keyboard-display-issue-for-QT5-ap.patch
+++ /dev/null
@@ -1,41 +0,0 @@ 
-From 8034bc1862bbebb332e91917c6458ef8efb5b54e Mon Sep 17 00:00:00 2001
-From: Eric Ruei <e-ruei1@ti.com>
-Date: Fri, 8 Mar 2019 18:49:07 -0500
-Subject: [PATCH] weston: Fix virtual keyboard display issue for QT5 
- application
-
-The virtual keyboard does pop up as expected, however, it will never hide
-even when the application is terminated. This problem is due to the order
-of the text APIs( text_input_activate and test_input_show_input_panel) are
-invoked in QT5 and a potential bug of the API implementation. The virtual
-keyboard works as expected if the test_input_show_input_panel() is invoked
-prior to the test_input_activate() as most of the weston sample applications
-do. However, the problem will show up if that order is reversed and the reason
-why is that the current_panel is not set in this case and hence this panel
-cannot be hidden.
-
-It is required to set the current_panel to the text_input when the input_panel
-becomes visible at the first time.
-
-Upstream status: Pending
-
-Signed-off-by: Eric Ruei <e-ruei1@ti.com>
----
- compositor/text-backend.c | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/compositor/text-backend.c b/compositor/text-backend.c
-index 664c36f..b610dfb 100644
---- a/compositor/text-backend.c
-+++ b/compositor/text-backend.c
-@@ -349,6 +349,7 @@ text_input_show_input_panel(struct wl_client *client,
- 			       text_input->surface);
- 		wl_signal_emit(&ec->update_input_panel_signal,
- 			       &text_input->cursor_rectangle);
-+		text_input->manager->current_text_input = text_input;
- 	}
- }
- 
--- 
-1.9.1
-
diff --git a/meta-arago-distro/recipes-graphics/wayland/weston_10.0.2.bbappend b/meta-arago-distro/recipes-graphics/wayland/weston_10.0.2.bbappend
index edc1bebd..698ff03e 100644
--- a/meta-arago-distro/recipes-graphics/wayland/weston_10.0.2.bbappend
+++ b/meta-arago-distro/recipes-graphics/wayland/weston_10.0.2.bbappend
@@ -7,7 +7,6 @@  PR:append = ".arago1"
 # upstream
 
 SRC_URI += " \
-        file://0003-weston-Fix-virtual-keyboard-display-issue-for-QT5-ap.patch \
         file://0001-backend-drm-Select-plane-based-on-current-attached-C.patch \
         file://0001-Revert-require-GL_EXT_unpack_subimage-commit.patch \
 "