Patchwork [1/8] license.bbclass: Add spdx mapping to GPL-1.0

login
register
mail settings
Submitter Elizabeth Flanagan
Date March 23, 2012, 11:51 p.m.
Message ID <f0393ed61291561b5823079b9528e8df24d56a3f.1332546190.git.elizabeth.flanagan@intel.com>
Download mbox | patch
Permalink /patch/24387/
State Accepted
Commit 2bc1d04e62a8c84e3195d538f844e90c32df8acc
Headers show

Comments

Elizabeth Flanagan - March 23, 2012, 11:51 p.m.
From: Elizabeth Flanagan <elizabeth.flanagan@intel.com>

Perl is GPL-1.0. For consistency sake, adding an spdx map for
GPLv1

Signed-off-by: Elizabeth Flanagan <elizabeth.flanagan@intel.com>
---
 meta/classes/license.bbclass |    4 +++-
 1 files changed, 3 insertions(+), 1 deletions(-)

Patch

diff --git a/meta/classes/license.bbclass b/meta/classes/license.bbclass
index 9459b00..40dcbeb 100644
--- a/meta/classes/license.bbclass
+++ b/meta/classes/license.bbclass
@@ -18,12 +18,14 @@  do_populate_lic[cleandirs] = "${LICSSTATEDIR}"
 # We should really discuss standardizing this field, but that's a longer term goal.
 # For now, we can do this and it should grab the most common LICENSE naming variations.
 #
-# Changing GPL mapping to GPL-2 as it's not very likely to be GPL-1
 # We should NEVER have a GPL/LGPL without a version!!!!
 # Any mapping to MPL/LGPL/GPL should be fixed
 # see: https://wiki.yoctoproject.org/wiki/License_Audit
 
 # GPL variations
+SPDXLICENSEMAP[GPL-1] = "GPL-1.0"
+SPDXLICENSEMAP[GPLv1] = "GPL-1.0"
+SPDXLICENSEMAP[GPLv1.0] = "GPL-1.0"
 SPDXLICENSEMAP[GPL-2] = "GPL-2.0"
 SPDXLICENSEMAP[GPLv2] = "GPL-2.0"
 SPDXLICENSEMAP[GPLv2.0] = "GPL-2.0"