diff mbox series

[meta-oe,v2] bpftool: Fix externalsrc support

Message ID 20230523140020.3089451-1-dzagorui@cisco.com
State Under Review
Headers show
Series [meta-oe,v2] bpftool: Fix externalsrc support | expand

Commit Message

Denys Zagorui May 23, 2023, 2 p.m. UTC
When the externalsrc class is used the tasks listed in
SRCTREECOVEREDTASKS are deleted to prevent them being executed. If
externalsrc is used for the kernel then this will include
virtual/kernel:do_patch.

We can depend on do_shared_workdir instead as this will survive when
externalsrc is used.

Similar to [openembedded-core] (eab605bab945 "perf: Fix externalsrc support")

Signed-off-by: Denys Zagorui <dzagorui@cisco.com>
---
 meta-oe/recipes-kernel/bpftool/bpftool.bb | 4 +---
 1 file changed, 1 insertion(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/meta-oe/recipes-kernel/bpftool/bpftool.bb b/meta-oe/recipes-kernel/bpftool/bpftool.bb
index 67a821c07..d4286295c 100644
--- a/meta-oe/recipes-kernel/bpftool/bpftool.bb
+++ b/meta-oe/recipes-kernel/bpftool/bpftool.bb
@@ -7,7 +7,7 @@  PROVIDES = "virtual/bpftool"
 
 inherit bash-completion kernelsrc kernel-arch
 
-do_populate_lic[depends] += "virtual/kernel:do_patch"
+do_populate_lic[depends] += "virtual/kernel:do_shared_workdir"
 
 EXTRA_OEMAKE = "\
     V=1 \
@@ -22,8 +22,6 @@  EXTRA_OEMAKE = "\
 
 SECURITY_CFLAGS = ""
 
-do_configure[depends] += "virtual/kernel:do_shared_workdir"
-
 COMPATIBLE_HOST = "(x86_64|aarch64).*-linux"
 COMPATIBLE_HOST:libc-musl = 'null'