diff mbox series

[patchtest,08/11] python3-dill: add recipe

Message ID 20230517202244.1612047-9-tgamblin@baylibre.com
State New
Headers show
Series patchtest: layer updates | expand

Commit Message

Trevor Gamblin May 17, 2023, 8:22 p.m. UTC
python3-pylint requires python3-dill, so copy it from meta-python
to avoid requiring that layer for patchtest.

Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
---
 .../python/python3-dill_0.3.6.bb                | 17 +++++++++++++++++
 1 file changed, 17 insertions(+)
 create mode 100644 meta-patchtest/recipes-devtools/python/python3-dill_0.3.6.bb
diff mbox series

Patch

diff --git a/meta-patchtest/recipes-devtools/python/python3-dill_0.3.6.bb b/meta-patchtest/recipes-devtools/python/python3-dill_0.3.6.bb
new file mode 100644
index 0000000..bec4643
--- /dev/null
+++ b/meta-patchtest/recipes-devtools/python/python3-dill_0.3.6.bb
@@ -0,0 +1,17 @@ 
+SUMMARY = "Serialize all of python"
+HOMEPAGE = "https://pypi.org/project/dill/"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=61f24e44fc855bde43ed5a1524a37bc4"
+
+SRC_URI[sha256sum] = "e5db55f3687856d8fbdab002ed78544e1c4559a130302693d839dfe8f93f2373"
+
+inherit pypi setuptools3
+
+PYPI_PACKAGE_EXT = "tar.gz"
+
+RDEPENDS:${PN} += "\
+    ${PYTHON_PN}-multiprocessing \
+    ${PYTHON_PN}-logging \
+    ${PYTHON_PN}-profile \
+    ${PYTHON_PN}-core \
+"