Patchwork [45/58] gcc: Add "--enable-clocale=gnu" option for LSB.

login
register
mail settings
Submitter Saul Wold
Date April 16, 2011, 6:55 a.m.
Message ID <5f1cea3db666f2b95d285e32fe9174f79be44569.1302936483.git.sgw@linux.intel.com>
Download mbox | patch
Permalink /patch/2407/
State New, archived
Headers show

Comments

Saul Wold - April 16, 2011, 6:55 a.m.
From: Jingdong Lu <jingdong.lu@windriver.com>

Add "--enable-clocale=gun" option for gcc configuration explicitly for LSB distro
in order to make sure C++ library can use correct locale module.
Fixes [YOCTO #796]

Signed-off-by: Jingdong Lu <jingdong.lu@windriver.com>
---
 meta/recipes-devtools/gcc/gcc-runtime_4.5.1.bb |    3 ++-
 1 files changed, 2 insertions(+), 1 deletions(-)

Patch

diff --git a/meta/recipes-devtools/gcc/gcc-runtime_4.5.1.bb b/meta/recipes-devtools/gcc/gcc-runtime_4.5.1.bb
index 2127eb6..189c0b8 100644
--- a/meta/recipes-devtools/gcc/gcc-runtime_4.5.1.bb
+++ b/meta/recipes-devtools/gcc/gcc-runtime_4.5.1.bb
@@ -1,4 +1,4 @@ 
-PR = "r5"
+PR = "r6"
 
 require gcc-${PV}.inc
 require gcc-configure-runtime.inc
@@ -9,3 +9,4 @@  SRC_URI_append = "file://fortran-cross-compile-hack.patch"
 ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_INCDIR}"
 
 EXTRA_OECONF += "--disable-libunwind-exceptions"
+EXTRA_OECONF_append_poky-lsb = " --enable-clocale=gnu"