diff mbox series

[2/8] gnutls: add PACKAGECONFIG options for certification compression

Message ID 20230515132955.2231164-2-ross.burton@arm.com
State Accepted, archived
Commit d22a406e7ca3018e0d1c0a7b1b6254c2aba6faba
Headers show
Series [1/8] gnutls: add PACKAGECONFIG for DANE | expand

Commit Message

Ross Burton May 15, 2023, 1:29 p.m. UTC
From: Ross Burton <ross.burton@arm.com>

GnuTLS has optional support for certificate compression. These are not
widely enabled in other distributions and were previously disabled in
standard builds, so don't enable them by default.

Signed-off-by: Ross Burton <ross.burton@arm.com>
---
 meta/recipes-support/gnutls/gnutls_3.8.0.bb | 4 ++++
 1 file changed, 4 insertions(+)
diff mbox series

Patch

diff --git a/meta/recipes-support/gnutls/gnutls_3.8.0.bb b/meta/recipes-support/gnutls/gnutls_3.8.0.bb
index e6b9a527a6d..1e0f1f6912b 100644
--- a/meta/recipes-support/gnutls/gnutls_3.8.0.bb
+++ b/meta/recipes-support/gnutls/gnutls_3.8.0.bb
@@ -41,6 +41,10 @@  PACKAGECONFIG[p11-kit] = "--with-p11-kit,--without-p11-kit,p11-kit"
 PACKAGECONFIG[tpm] = "--with-tpm,--without-tpm,trousers"
 PACKAGECONFIG[fips] = "--enable-fips140-mode --with-libdl-prefix=${STAGING_BASELIBDIR}"
 PACKAGECONFIG[dane] = "--enable-libdane,--disable-libdane,unbound"
+# Certificate compression
+PACKAGECONFIG[brotli] = "--with-brotli,--without-brotli,brotli"
+PACKAGECONFIG[zlib] = "--with-zlib,--without-zlib,zlib"
+PACKAGECONFIG[zstd] = "--with-zstd,--without-zstd,zstd"
 
 EXTRA_OECONF = " \
     --enable-doc \