[v2,2/3] ref-manual/variables.rst: add SETUPTOOLS_*_ARGS

Message ID 20220113153843.2544066-2-tim.orling@konsulko.com
State New
Headers show
Series [v2,1/3] ref-manual/variables.rst: add SETUPTOOLS_SETUP_PATH | expand

Commit Message

Tim Orling Jan. 13, 2022, 3:38 p.m. UTC
Add SETUPTOOLS_BUILD_ARGS variable which can be used to pass additional
arguments to `setup.py build`.

Add SETUPTOOLS_INSTALL_ARGS variable which can be used to pass
additional arguments to `setup.py install`.

[YOCTO #14610]

Signed-off-by: Tim Orling <tim.orling@konsulko.com>
---
Changes in v2:
  - drop "default" variable examples, as this is brittle and perhaps not
    providing that much value.

 documentation/ref-manual/variables.rst | 12 ++++++++++++
 1 file changed, 12 insertions(+)

Patch

diff --git a/documentation/ref-manual/variables.rst b/documentation/ref-manual/variables.rst
index 7c2f74a39..37231a3cd 100644
--- a/documentation/ref-manual/variables.rst
+++ b/documentation/ref-manual/variables.rst
@@ -6847,6 +6847,18 @@  system and gives an overview of their function and contents.
 
          EXTRA_IMAGE_FEATURES += "read-only-rootfs"
 
+   :term:`SETUPTOOLS_BUILD_ARGS`
+      When used by recipes that inherit the
+      :ref:`setuptools3 <ref-classes-setuptools3>` class, this variable can
+      be used to specify additional arguments to be passed to ``setup.py build``
+      in the ``setuptools3_do_compile()`` task.
+
+   :term:`SETUPTOOLS_INSTALL_ARGS`
+      When used by recipes that inherit the
+      :ref:`setuptools3 <ref-classes-setuptools3>` class, this variable can
+      be used to specify additional arguments to be passed to ``setup.py install``
+      in the ``setuptools3_do_install()`` task.
+
    :term:`SETUPTOOLS_SETUP_PATH`
       When used by recipes that inherit the
       :ref:`setuptools3 <ref-classes-setuptools3>` class, this variable should