diff mbox series

[meta-oe,v2,2/3] python3-pefile: Add initial support

Message ID 20230511140744.2918627-3-jun.nie@linaro.org
State Under Review
Headers show
Series Add necessary lib and python tool to handle CoSWID tag | expand

Commit Message

Jun Nie May 11, 2023, 2:07 p.m. UTC
To parse and work with Portable Executable (PE) files

Signed-off-by: Jun Nie <jun.nie@linaro.org>
---
 .../python/python3-pefile_2023.2.7.bb               | 13 +++++++++++++
 1 file changed, 13 insertions(+)
 create mode 100644 meta-python/recipes-devtools/python/python3-pefile_2023.2.7.bb
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-pefile_2023.2.7.bb b/meta-python/recipes-devtools/python/python3-pefile_2023.2.7.bb
new file mode 100644
index 0000000000..580b17413b
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pefile_2023.2.7.bb
@@ -0,0 +1,13 @@ 
+SUMMARY = "Python PE parsing module"
+DESCRIPTION = "A multi-platform Python module to parse and work with Portable Executable (PE) files."
+HOMEPAGE = "https://github.com/erocarrera/pefile"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=38066667888b01d8118ff9cc23da1873"
+
+inherit setuptools3 pypi ptest
+SRC_URI[sha256sum] = "82e6114004b3d6911c77c3953e3838654b04511b8b66e8583db70c65998017dc"
+
+PIP_INSTALL_PACKAGE = "pefile"
+PIP_INSTALL_DIST_PATH = "${S}/dist"
+
+BBCLASSEXTEND = "native nativesdk"