Patchwork strongswan: upgrade to 4.6.2

login
register
mail settings
Submitter Zhenhua Luo
Date March 16, 2012, 11:07 a.m.
Message ID <1331896031-19776-1-git-send-email-b19537@freescale.com>
Download mbox | patch
Permalink /patch/23639/
State Superseded
Headers show

Comments

Zhenhua Luo - March 16, 2012, 11:07 a.m.
From: Zhenhua Luo <b19537@freescale.com>

Signed-off-by: Zhenhua Luo <b19537@freescale.com>
---
 .../recipes-support/strongswan/strongswan_4.5.1.bb |   21 --------------------
 .../recipes-support/strongswan/strongswan_4.6.2.bb |   21 ++++++++++++++++++++
 2 files changed, 21 insertions(+), 21 deletions(-)
 delete mode 100644 meta-oe/recipes-support/strongswan/strongswan_4.5.1.bb
 create mode 100644 meta-oe/recipes-support/strongswan/strongswan_4.6.2.bb
Khem Raj - March 16, 2012, 8:33 p.m.
there are unpackaged files Plese fix those and send a V2

WARNING: For recipe strongswan, the following files/directories were
installed but not shipped in any package:
WARNING:   /lib
WARNING:   /lib/systemd
WARNING:   /lib/systemd/system
WARNING:   /lib/systemd/system/strongswan.service
WARNING:   /usr/lib
WARNING:   /usr/lib/ipsec
WARNING:   /usr/lib/ipsec/libcharon.la
WARNING:   /usr/lib/ipsec/libstrongswan.so
WARNING:   /usr/lib/ipsec/libhydra.so.0.0.0
WARNING:   /usr/lib/ipsec/libhydra.la
WARNING:   /usr/lib/ipsec/libcharon.so.0
WARNING:   /usr/lib/ipsec/libstrongswan.a
WARNING:   /usr/lib/ipsec/libcharon.so.0.0.0
WARNING:   /usr/lib/ipsec/libstrongswan.so.0
WARNING:   /usr/lib/ipsec/libcharon.so
WARNING:   /usr/lib/ipsec/libhydra.so.0
WARNING:   /usr/lib/ipsec/libstrongswan.la
WARNING:   /usr/lib/ipsec/libcharon.a
WARNING:   /usr/lib/ipsec/libhydra.so
WARNING:   /usr/lib/ipsec/libhydra.a
WARNING:   /usr/lib/ipsec/libstrongswan.so.0.0.0
WARNING:   /usr/lib/ipsec/plugins
WARNING:   /usr/lib/ipsec/.debug
WARNING:   /usr/lib/ipsec/plugins/libstrongswan-fips-prf.so
WARNING:   /usr/lib/ipsec/plugins/libstrongswan-pem.a
WARNING:   /usr/lib/ipsec/plugins/libstrongswan-sha1.a
WARNING:   /usr/lib/ipsec/plugins/libstrongswan-aes.la
WARNING:   /usr/lib/ipsec/plugins/libstrongswan-pgp.la
WARNING:   /usr/lib/ipsec/plugins/libstrongswan-openssl.so
WARNING:   /usr/lib/ipsec/plugins/libstrongswan-pkcs1.a
WARNING:   /usr/lib/ipsec/plugins/libstrongswan-constraints.so
WARNING:   /usr/lib/ipsec/plugins/libstrongswan-dnskey.so
WARNING:   /usr/lib/ipsec/plugins/libstrongswan-pgp.a
WARNING:   /usr/lib/ipsec/plugins/libstrongswan-md5.la
WARNING:   /usr/lib/ipsec/plugins/libstrongswan-xauth.la
WARNING:   /usr/lib/ipsec/plugins/libstrongswan-xauth.so
WARNING:   /usr/lib/ipsec/plugins/libstrongswan-updown.la
WARNING:   /usr/lib/ipsec/plugins/libstrongswan-md5.so
WARNING:   /usr/lib/ipsec/plugins/libstrongswan-random.so
WARNING:   /usr/lib/ipsec/plugins/libstrongswan-pkcs8.so
WARNING:   /usr/lib/ipsec/plugins/libstrongswan-sha2.a
WARNING:   /usr/lib/ipsec/plugins/libstrongswan-gmp.la
WARNING:   /usr/lib/ipsec/plugins/libstrongswan-socket-raw.a
WARNING:   /usr/lib/ipsec/plugins/libstrongswan-gmp.so
WARNING:   /usr/lib/ipsec/plugins/libstrongswan-sha2.la
WARNING:   /usr/lib/ipsec/plugins/libstrongswan-stroke.so
WARNING:   /usr/lib/ipsec/plugins/libstrongswan-random.la
WARNING:   /usr/lib/ipsec/plugins/libstrongswan-attr.a
WARNING:   /usr/lib/ipsec/plugins/libstrongswan-pubkey.a
WARNING:   /usr/lib/ipsec/plugins/libstrongswan-dnskey.a
WARNING:   /usr/lib/ipsec/plugins/libstrongswan-pkcs8.a
WARNING:   /usr/lib/ipsec/plugins/libstrongswan-x509.a
WARNING:   /usr/lib/ipsec/plugins/libstrongswan-kernel-netlink.la
WARNING:   /usr/lib/ipsec/plugins/libstrongswan-resolve.la
WARNING:   /usr/lib/ipsec/plugins/libstrongswan-resolve.so
WARNING:   /usr/lib/ipsec/plugins/libstrongswan-pgp.so
WARNING:   /usr/lib/ipsec/plugins/libstrongswan-hmac.la
WARNING:   /usr/lib/ipsec/plugins/libstrongswan-aes.a
WARNING:   /usr/lib/ipsec/plugins/libstrongswan-kernel-netlink.so
WARNING:   /usr/lib/ipsec/plugins/libstrongswan-pubkey.la
WARNING:   /usr/lib/ipsec/plugins/libstrongswan-stroke.la
WARNING:   /usr/lib/ipsec/plugins/libstrongswan-xauth.a
WARNING:   /usr/lib/ipsec/plugins/libstrongswan-pem.so
WARNING:   /usr/lib/ipsec/plugins/libstrongswan-updown.a
WARNING:   /usr/lib/ipsec/plugins/libstrongswan-des.a
WARNING:   /usr/lib/ipsec/plugins/libstrongswan-fips-prf.a
WARNING:   /usr/lib/ipsec/plugins/libstrongswan-resolve.a
WARNING:   /usr/lib/ipsec/plugins/libstrongswan-xcbc.la
WARNING:   /usr/lib/ipsec/plugins/libstrongswan-hmac.so
WARNING:   /usr/lib/ipsec/plugins/libstrongswan-kernel-netlink.a
WARNING:   /usr/lib/ipsec/plugins/libstrongswan-openssl.la
WARNING:   /usr/lib/ipsec/plugins/libstrongswan-socket-raw.so
WARNING:   /usr/lib/ipsec/plugins/libstrongswan-hmac.a
WARNING:   /usr/lib/ipsec/plugins/libstrongswan-updown.so
WARNING:   /usr/lib/ipsec/plugins/libstrongswan-openssl.a
WARNING:   /usr/lib/ipsec/plugins/libstrongswan-sha2.so
WARNING:   /usr/lib/ipsec/plugins/libstrongswan-xcbc.so
WARNING:   /usr/lib/ipsec/plugins/libstrongswan-random.a
WARNING:   /usr/lib/ipsec/plugins/libstrongswan-dnskey.la
WARNING:   /usr/lib/ipsec/plugins/libstrongswan-xcbc.a
WARNING:   /usr/lib/ipsec/plugins/libstrongswan-revocation.la
WARNING:   /usr/lib/ipsec/plugins/libstrongswan-sha1.so
WARNING:   /usr/lib/ipsec/plugins/libstrongswan-des.la
WARNING:   /usr/lib/ipsec/plugins/libstrongswan-pem.la
WARNING:   /usr/lib/ipsec/plugins/libstrongswan-pubkey.so
WARNING:   /usr/lib/ipsec/plugins/libstrongswan-des.so
WARNING:   /usr/lib/ipsec/plugins/libstrongswan-revocation.so
WARNING:   /usr/lib/ipsec/plugins/libstrongswan-pkcs1.so
WARNING:   /usr/lib/ipsec/plugins/libstrongswan-gmp.a
WARNING:   /usr/lib/ipsec/plugins/libstrongswan-aes.so
WARNING:   /usr/lib/ipsec/plugins/libstrongswan-revocation.a
WARNING:   /usr/lib/ipsec/plugins/libstrongswan-pkcs8.la
WARNING:   /usr/lib/ipsec/plugins/libstrongswan-attr.so
WARNING:   /usr/lib/ipsec/plugins/libstrongswan-x509.so
WARNING:   /usr/lib/ipsec/plugins/libstrongswan-stroke.a
WARNING:   /usr/lib/ipsec/plugins/libstrongswan-socket-raw.la
WARNING:   /usr/lib/ipsec/plugins/libstrongswan-constraints.a
WARNING:   /usr/lib/ipsec/plugins/libstrongswan-x509.la
WARNING:   /usr/lib/ipsec/plugins/libstrongswan-attr.la
WARNING:   /usr/lib/ipsec/plugins/libstrongswan-constraints.la
WARNING:   /usr/lib/ipsec/plugins/libstrongswan-fips-prf.la
WARNING:   /usr/lib/ipsec/plugins/libstrongswan-md5.a
WARNING:   /usr/lib/ipsec/plugins/libstrongswan-sha1.la
WARNING:   /usr/lib/ipsec/plugins/libstrongswan-pkcs1.la
WARNING:   /usr/lib/ipsec/plugins/.debug
WARNING:   /usr/lib/ipsec/plugins/.debug/libstrongswan-fips-prf.so
WARNING:   /usr/lib/ipsec/plugins/.debug/libstrongswan-openssl.so
WARNING:   /usr/lib/ipsec/plugins/.debug/libstrongswan-constraints.so
WARNING:   /usr/lib/ipsec/plugins/.debug/libstrongswan-dnskey.so
WARNING:   /usr/lib/ipsec/plugins/.debug/libstrongswan-xauth.so
WARNING:   /usr/lib/ipsec/plugins/.debug/libstrongswan-md5.so
WARNING:   /usr/lib/ipsec/plugins/.debug/libstrongswan-random.so
WARNING:   /usr/lib/ipsec/plugins/.debug/libstrongswan-pkcs8.so
WARNING:   /usr/lib/ipsec/plugins/.debug/libstrongswan-gmp.so
WARNING:   /usr/lib/ipsec/plugins/.debug/libstrongswan-stroke.so
WARNING:   /usr/lib/ipsec/plugins/.debug/libstrongswan-resolve.so
WARNING:   /usr/lib/ipsec/plugins/.debug/libstrongswan-pgp.so
WARNING:   /usr/lib/ipsec/plugins/.debug/libstrongswan-kernel-netlink.so
WARNING:   /usr/lib/ipsec/plugins/.debug/libstrongswan-pem.so
WARNING:   /usr/lib/ipsec/plugins/.debug/libstrongswan-hmac.so
WARNING:   /usr/lib/ipsec/plugins/.debug/libstrongswan-socket-raw.so
WARNING:   /usr/lib/ipsec/plugins/.debug/libstrongswan-updown.so
WARNING:   /usr/lib/ipsec/plugins/.debug/libstrongswan-sha2.so
WARNING:   /usr/lib/ipsec/plugins/.debug/libstrongswan-xcbc.so
WARNING:   /usr/lib/ipsec/plugins/.debug/libstrongswan-sha1.so
WARNING:   /usr/lib/ipsec/plugins/.debug/libstrongswan-pubkey.so
WARNING:   /usr/lib/ipsec/plugins/.debug/libstrongswan-des.so
WARNING:   /usr/lib/ipsec/plugins/.debug/libstrongswan-revocation.so
WARNING:   /usr/lib/ipsec/plugins/.debug/libstrongswan-pkcs1.so
WARNING:   /usr/lib/ipsec/plugins/.debug/libstrongswan-aes.so
WARNING:   /usr/lib/ipsec/plugins/.debug/libstrongswan-attr.so
WARNING:   /usr/lib/ipsec/plugins/.debug/libstrongswan-x509.so
WARNING:   /usr/lib/ipsec/.debug/libstrongswan.so
WARNING:   /usr/lib/ipsec/.debug/libhydra.so.0.0.0
WARNING:   /usr/lib/ipsec/.debug/libcharon.so.0
WARNING:   /usr/lib/ipsec/.debug/libcharon.so.0.0.0
WARNING:   /usr/lib/ipsec/.debug/libstrongswan.so.0
WARNING:   /usr/lib/ipsec/.debug/libcharon.so
WARNING:   /usr/lib/ipsec/.debug/libhydra.so.0
WARNING:   /usr/lib/ipsec/.debug/libhydra.so
WARNING:   /usr/lib/ipsec/.debug/libstrongswan.so.0.0.0




On Fri, Mar 16, 2012 at 4:07 AM,  <b19537@freescale.com> wrote:
> From: Zhenhua Luo <b19537@freescale.com>
>
> Signed-off-by: Zhenhua Luo <b19537@freescale.com>
> ---
>  .../recipes-support/strongswan/strongswan_4.5.1.bb |   21 --------------------
>  .../recipes-support/strongswan/strongswan_4.6.2.bb |   21 ++++++++++++++++++++
>  2 files changed, 21 insertions(+), 21 deletions(-)
>  delete mode 100644 meta-oe/recipes-support/strongswan/strongswan_4.5.1.bb
>  create mode 100644 meta-oe/recipes-support/strongswan/strongswan_4.6.2.bb
>
> diff --git a/meta-oe/recipes-support/strongswan/strongswan_4.5.1.bb b/meta-oe/recipes-support/strongswan/strongswan_4.5.1.bb
> deleted file mode 100644
> index 3276fdd..0000000
> --- a/meta-oe/recipes-support/strongswan/strongswan_4.5.1.bb
> +++ /dev/null
> @@ -1,21 +0,0 @@
> -DESCRIPTION = "strongSwan is an OpenSource IPsec implementation for the \
> -Linux operating system."
> -HOMEPAGE = "http://www.strongswan.org"
> -SECTION = "console/network"
> -LICENSE = "GPLv2"
> -LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
> -DEPENDS = "gmp openssl flex-native flex bison-native"
> -
> -SRC_URI = "http://download.strongswan.org/strongswan-${PV}.tar.bz2"
> -SRC_URI[md5sum] = "81a4a699c4a1a49b74061dfa47b5a033"
> -SRC_URI[sha256sum] = "252d7369d94aa2d79e6fad078853b07ca897ea811ab1e1a2b008bcec0d1e758a"
> -
> -EXTRA_OECONF = "--disable-curl --disable-soup --disable-ldap \
> -               --enable-gmp --disable-mysql --disable-sqlite \
> -               --enable-openssl"
> -
> -inherit autotools
> -
> -RRECOMMENDS_${PN} = "kernel-module-ipsec"
> -
> -FILES_${PN}-dbg += "${libexecdir}/ipsec/.debug ${libexecdir}/ipsec/plugins/.debug"
> diff --git a/meta-oe/recipes-support/strongswan/strongswan_4.6.2.bb b/meta-oe/recipes-support/strongswan/strongswan_4.6.2.bb
> new file mode 100644
> index 0000000..3816e57
> --- /dev/null
> +++ b/meta-oe/recipes-support/strongswan/strongswan_4.6.2.bb
> @@ -0,0 +1,21 @@
> +DESCRIPTION = "strongSwan is an OpenSource IPsec implementation for the \
> +Linux operating system."
> +HOMEPAGE = "http://www.strongswan.org"
> +SECTION = "console/network"
> +LICENSE = "GPLv2"
> +LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
> +DEPENDS = "gmp openssl flex-native flex bison-native"
> +
> +SRC_URI = "http://download.strongswan.org/strongswan-${PV}.tar.bz2"
> +SRC_URI[md5sum] = "ed64e6746011930a70f3a271dc0e3c9e"
> +SRC_URI[sha256sum] = "a5ecb3fc60a94ded9197532c7ebf42e8e321223311e4a4834ea15219aa1625e4"
> +
> +EXTRA_OECONF = "--disable-curl --disable-soup --disable-ldap \
> +               --enable-gmp --disable-mysql --disable-sqlite \
> +               --enable-openssl"
> +
> +inherit autotools
> +
> +RRECOMMENDS_${PN} = "kernel-module-ipsec"
> +
> +FILES_${PN}-dbg += "${libexecdir}/ipsec/.debug ${libexecdir}/ipsec/plugins/.debug"
> --
> 1.7.0.4
>
>
>
> _______________________________________________
> Openembedded-devel mailing list
> Openembedded-devel@lists.openembedded.org
> http://lists.linuxtogo.org/cgi-bin/mailman/listinfo/openembedded-devel
Zhenhua Luo - March 21, 2012, 7:53 a.m.
Thanks, the v2 has been sent out. 


Best Regards,

Zhenhua


> -----Original Message-----

> From: openembedded-devel-bounces@lists.openembedded.org [mailto:openembedded-

> devel-bounces@lists.openembedded.org] On Behalf Of Khem Raj

> Sent: Saturday, March 17, 2012 4:33 AM

> To: openembedded-devel@lists.openembedded.org

> Subject: Re: [oe] [PATCH] strongswan: upgrade to 4.6.2

> 

> there are unpackaged files Plese fix those and send a V2

> 

> WARNING: For recipe strongswan, the following files/directories were installed

> but not shipped in any package:

> WARNING:   /lib

> WARNING:   /lib/systemd

> WARNING:   /lib/systemd/system

> WARNING:   /lib/systemd/system/strongswan.service

> WARNING:   /usr/lib

> WARNING:   /usr/lib/ipsec

> WARNING:   /usr/lib/ipsec/libcharon.la

> WARNING:   /usr/lib/ipsec/libstrongswan.so

> WARNING:   /usr/lib/ipsec/libhydra.so.0.0.0

> WARNING:   /usr/lib/ipsec/libhydra.la

> WARNING:   /usr/lib/ipsec/libcharon.so.0

> WARNING:   /usr/lib/ipsec/libstrongswan.a

> WARNING:   /usr/lib/ipsec/libcharon.so.0.0.0

> WARNING:   /usr/lib/ipsec/libstrongswan.so.0

> WARNING:   /usr/lib/ipsec/libcharon.so

> WARNING:   /usr/lib/ipsec/libhydra.so.0

> WARNING:   /usr/lib/ipsec/libstrongswan.la

> WARNING:   /usr/lib/ipsec/libcharon.a

> WARNING:   /usr/lib/ipsec/libhydra.so

> WARNING:   /usr/lib/ipsec/libhydra.a

> WARNING:   /usr/lib/ipsec/libstrongswan.so.0.0.0

> WARNING:   /usr/lib/ipsec/plugins

> WARNING:   /usr/lib/ipsec/.debug

> WARNING:   /usr/lib/ipsec/plugins/libstrongswan-fips-prf.so

> WARNING:   /usr/lib/ipsec/plugins/libstrongswan-pem.a

> WARNING:   /usr/lib/ipsec/plugins/libstrongswan-sha1.a

> WARNING:   /usr/lib/ipsec/plugins/libstrongswan-aes.la

> WARNING:   /usr/lib/ipsec/plugins/libstrongswan-pgp.la

> WARNING:   /usr/lib/ipsec/plugins/libstrongswan-openssl.so

> WARNING:   /usr/lib/ipsec/plugins/libstrongswan-pkcs1.a

> WARNING:   /usr/lib/ipsec/plugins/libstrongswan-constraints.so

> WARNING:   /usr/lib/ipsec/plugins/libstrongswan-dnskey.so

> WARNING:   /usr/lib/ipsec/plugins/libstrongswan-pgp.a

> WARNING:   /usr/lib/ipsec/plugins/libstrongswan-md5.la

> WARNING:   /usr/lib/ipsec/plugins/libstrongswan-xauth.la

> WARNING:   /usr/lib/ipsec/plugins/libstrongswan-xauth.so

> WARNING:   /usr/lib/ipsec/plugins/libstrongswan-updown.la

> WARNING:   /usr/lib/ipsec/plugins/libstrongswan-md5.so

> WARNING:   /usr/lib/ipsec/plugins/libstrongswan-random.so

> WARNING:   /usr/lib/ipsec/plugins/libstrongswan-pkcs8.so

> WARNING:   /usr/lib/ipsec/plugins/libstrongswan-sha2.a

> WARNING:   /usr/lib/ipsec/plugins/libstrongswan-gmp.la

> WARNING:   /usr/lib/ipsec/plugins/libstrongswan-socket-raw.a

> WARNING:   /usr/lib/ipsec/plugins/libstrongswan-gmp.so

> WARNING:   /usr/lib/ipsec/plugins/libstrongswan-sha2.la

> WARNING:   /usr/lib/ipsec/plugins/libstrongswan-stroke.so

> WARNING:   /usr/lib/ipsec/plugins/libstrongswan-random.la

> WARNING:   /usr/lib/ipsec/plugins/libstrongswan-attr.a

> WARNING:   /usr/lib/ipsec/plugins/libstrongswan-pubkey.a

> WARNING:   /usr/lib/ipsec/plugins/libstrongswan-dnskey.a

> WARNING:   /usr/lib/ipsec/plugins/libstrongswan-pkcs8.a

> WARNING:   /usr/lib/ipsec/plugins/libstrongswan-x509.a

> WARNING:   /usr/lib/ipsec/plugins/libstrongswan-kernel-netlink.la

> WARNING:   /usr/lib/ipsec/plugins/libstrongswan-resolve.la

> WARNING:   /usr/lib/ipsec/plugins/libstrongswan-resolve.so

> WARNING:   /usr/lib/ipsec/plugins/libstrongswan-pgp.so

> WARNING:   /usr/lib/ipsec/plugins/libstrongswan-hmac.la

> WARNING:   /usr/lib/ipsec/plugins/libstrongswan-aes.a

> WARNING:   /usr/lib/ipsec/plugins/libstrongswan-kernel-netlink.so

> WARNING:   /usr/lib/ipsec/plugins/libstrongswan-pubkey.la

> WARNING:   /usr/lib/ipsec/plugins/libstrongswan-stroke.la

> WARNING:   /usr/lib/ipsec/plugins/libstrongswan-xauth.a

> WARNING:   /usr/lib/ipsec/plugins/libstrongswan-pem.so

> WARNING:   /usr/lib/ipsec/plugins/libstrongswan-updown.a

> WARNING:   /usr/lib/ipsec/plugins/libstrongswan-des.a

> WARNING:   /usr/lib/ipsec/plugins/libstrongswan-fips-prf.a

> WARNING:   /usr/lib/ipsec/plugins/libstrongswan-resolve.a

> WARNING:   /usr/lib/ipsec/plugins/libstrongswan-xcbc.la

> WARNING:   /usr/lib/ipsec/plugins/libstrongswan-hmac.so

> WARNING:   /usr/lib/ipsec/plugins/libstrongswan-kernel-netlink.a

> WARNING:   /usr/lib/ipsec/plugins/libstrongswan-openssl.la

> WARNING:   /usr/lib/ipsec/plugins/libstrongswan-socket-raw.so

> WARNING:   /usr/lib/ipsec/plugins/libstrongswan-hmac.a

> WARNING:   /usr/lib/ipsec/plugins/libstrongswan-updown.so

> WARNING:   /usr/lib/ipsec/plugins/libstrongswan-openssl.a

> WARNING:   /usr/lib/ipsec/plugins/libstrongswan-sha2.so

> WARNING:   /usr/lib/ipsec/plugins/libstrongswan-xcbc.so

> WARNING:   /usr/lib/ipsec/plugins/libstrongswan-random.a

> WARNING:   /usr/lib/ipsec/plugins/libstrongswan-dnskey.la

> WARNING:   /usr/lib/ipsec/plugins/libstrongswan-xcbc.a

> WARNING:   /usr/lib/ipsec/plugins/libstrongswan-revocation.la

> WARNING:   /usr/lib/ipsec/plugins/libstrongswan-sha1.so

> WARNING:   /usr/lib/ipsec/plugins/libstrongswan-des.la

> WARNING:   /usr/lib/ipsec/plugins/libstrongswan-pem.la

> WARNING:   /usr/lib/ipsec/plugins/libstrongswan-pubkey.so

> WARNING:   /usr/lib/ipsec/plugins/libstrongswan-des.so

> WARNING:   /usr/lib/ipsec/plugins/libstrongswan-revocation.so

> WARNING:   /usr/lib/ipsec/plugins/libstrongswan-pkcs1.so

> WARNING:   /usr/lib/ipsec/plugins/libstrongswan-gmp.a

> WARNING:   /usr/lib/ipsec/plugins/libstrongswan-aes.so

> WARNING:   /usr/lib/ipsec/plugins/libstrongswan-revocation.a

> WARNING:   /usr/lib/ipsec/plugins/libstrongswan-pkcs8.la

> WARNING:   /usr/lib/ipsec/plugins/libstrongswan-attr.so

> WARNING:   /usr/lib/ipsec/plugins/libstrongswan-x509.so

> WARNING:   /usr/lib/ipsec/plugins/libstrongswan-stroke.a

> WARNING:   /usr/lib/ipsec/plugins/libstrongswan-socket-raw.la

> WARNING:   /usr/lib/ipsec/plugins/libstrongswan-constraints.a

> WARNING:   /usr/lib/ipsec/plugins/libstrongswan-x509.la

> WARNING:   /usr/lib/ipsec/plugins/libstrongswan-attr.la

> WARNING:   /usr/lib/ipsec/plugins/libstrongswan-constraints.la

> WARNING:   /usr/lib/ipsec/plugins/libstrongswan-fips-prf.la

> WARNING:   /usr/lib/ipsec/plugins/libstrongswan-md5.a

> WARNING:   /usr/lib/ipsec/plugins/libstrongswan-sha1.la

> WARNING:   /usr/lib/ipsec/plugins/libstrongswan-pkcs1.la

> WARNING:   /usr/lib/ipsec/plugins/.debug

> WARNING:   /usr/lib/ipsec/plugins/.debug/libstrongswan-fips-prf.so

> WARNING:   /usr/lib/ipsec/plugins/.debug/libstrongswan-openssl.so

> WARNING:   /usr/lib/ipsec/plugins/.debug/libstrongswan-constraints.so

> WARNING:   /usr/lib/ipsec/plugins/.debug/libstrongswan-dnskey.so

> WARNING:   /usr/lib/ipsec/plugins/.debug/libstrongswan-xauth.so

> WARNING:   /usr/lib/ipsec/plugins/.debug/libstrongswan-md5.so

> WARNING:   /usr/lib/ipsec/plugins/.debug/libstrongswan-random.so

> WARNING:   /usr/lib/ipsec/plugins/.debug/libstrongswan-pkcs8.so

> WARNING:   /usr/lib/ipsec/plugins/.debug/libstrongswan-gmp.so

> WARNING:   /usr/lib/ipsec/plugins/.debug/libstrongswan-stroke.so

> WARNING:   /usr/lib/ipsec/plugins/.debug/libstrongswan-resolve.so

> WARNING:   /usr/lib/ipsec/plugins/.debug/libstrongswan-pgp.so

> WARNING:   /usr/lib/ipsec/plugins/.debug/libstrongswan-kernel-netlink.so

> WARNING:   /usr/lib/ipsec/plugins/.debug/libstrongswan-pem.so

> WARNING:   /usr/lib/ipsec/plugins/.debug/libstrongswan-hmac.so

> WARNING:   /usr/lib/ipsec/plugins/.debug/libstrongswan-socket-raw.so

> WARNING:   /usr/lib/ipsec/plugins/.debug/libstrongswan-updown.so

> WARNING:   /usr/lib/ipsec/plugins/.debug/libstrongswan-sha2.so

> WARNING:   /usr/lib/ipsec/plugins/.debug/libstrongswan-xcbc.so

> WARNING:   /usr/lib/ipsec/plugins/.debug/libstrongswan-sha1.so

> WARNING:   /usr/lib/ipsec/plugins/.debug/libstrongswan-pubkey.so

> WARNING:   /usr/lib/ipsec/plugins/.debug/libstrongswan-des.so

> WARNING:   /usr/lib/ipsec/plugins/.debug/libstrongswan-revocation.so

> WARNING:   /usr/lib/ipsec/plugins/.debug/libstrongswan-pkcs1.so

> WARNING:   /usr/lib/ipsec/plugins/.debug/libstrongswan-aes.so

> WARNING:   /usr/lib/ipsec/plugins/.debug/libstrongswan-attr.so

> WARNING:   /usr/lib/ipsec/plugins/.debug/libstrongswan-x509.so

> WARNING:   /usr/lib/ipsec/.debug/libstrongswan.so

> WARNING:   /usr/lib/ipsec/.debug/libhydra.so.0.0.0

> WARNING:   /usr/lib/ipsec/.debug/libcharon.so.0

> WARNING:   /usr/lib/ipsec/.debug/libcharon.so.0.0.0

> WARNING:   /usr/lib/ipsec/.debug/libstrongswan.so.0

> WARNING:   /usr/lib/ipsec/.debug/libcharon.so

> WARNING:   /usr/lib/ipsec/.debug/libhydra.so.0

> WARNING:   /usr/lib/ipsec/.debug/libhydra.so

> WARNING:   /usr/lib/ipsec/.debug/libstrongswan.so.0.0.0

> 

> 

> 

> 

> On Fri, Mar 16, 2012 at 4:07 AM,  <b19537@freescale.com> wrote:

> > From: Zhenhua Luo <b19537@freescale.com>

> >

> > Signed-off-by: Zhenhua Luo <b19537@freescale.com>

> > ---

> >  .../recipes-support/strongswan/strongswan_4.5.1.bb |   21

> > --------------------

> >  .../recipes-support/strongswan/strongswan_4.6.2.bb |   21

> > ++++++++++++++++++++

> >  2 files changed, 21 insertions(+), 21 deletions(-)

> >  delete mode 100644

> > meta-oe/recipes-support/strongswan/strongswan_4.5.1.bb

> >  create mode 100644

> > meta-oe/recipes-support/strongswan/strongswan_4.6.2.bb

> >

> > diff --git a/meta-oe/recipes-support/strongswan/strongswan_4.5.1.bb

> > b/meta-oe/recipes-support/strongswan/strongswan_4.5.1.bb

> > deleted file mode 100644

> > index 3276fdd..0000000

> > --- a/meta-oe/recipes-support/strongswan/strongswan_4.5.1.bb

> > +++ /dev/null

> > @@ -1,21 +0,0 @@

> > -DESCRIPTION = "strongSwan is an OpenSource IPsec implementation for

> > the \ -Linux operating system."

> > -HOMEPAGE = "http://www.strongswan.org"

> > -SECTION = "console/network"

> > -LICENSE = "GPLv2"

> > -LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"

> > -DEPENDS = "gmp openssl flex-native flex bison-native"

> > -

> > -SRC_URI = "http://download.strongswan.org/strongswan-${PV}.tar.bz2"

> > -SRC_URI[md5sum] = "81a4a699c4a1a49b74061dfa47b5a033"

> > -SRC_URI[sha256sum] =

> "252d7369d94aa2d79e6fad078853b07ca897ea811ab1e1a2b008bcec0d1e758a"

> > -

> > -EXTRA_OECONF = "--disable-curl --disable-soup --disable-ldap \

> > -               --enable-gmp --disable-mysql --disable-sqlite \

> > -               --enable-openssl"

> > -

> > -inherit autotools

> > -

> > -RRECOMMENDS_${PN} = "kernel-module-ipsec"

> > -

> > -FILES_${PN}-dbg += "${libexecdir}/ipsec/.debug

> ${libexecdir}/ipsec/plugins/.debug"

> > diff --git a/meta-oe/recipes-support/strongswan/strongswan_4.6.2.bb

> > b/meta-oe/recipes-support/strongswan/strongswan_4.6.2.bb

> > new file mode 100644

> > index 0000000..3816e57

> > --- /dev/null

> > +++ b/meta-oe/recipes-support/strongswan/strongswan_4.6.2.bb

> > @@ -0,0 +1,21 @@

> > +DESCRIPTION = "strongSwan is an OpenSource IPsec implementation for

> > +the \ Linux operating system."

> > +HOMEPAGE = "http://www.strongswan.org"

> > +SECTION = "console/network"

> > +LICENSE = "GPLv2"

> > +LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"

> > +DEPENDS = "gmp openssl flex-native flex bison-native"

> > +

> > +SRC_URI = "http://download.strongswan.org/strongswan-${PV}.tar.bz2"

> > +SRC_URI[md5sum] = "ed64e6746011930a70f3a271dc0e3c9e"

> > +SRC_URI[sha256sum] =

> "a5ecb3fc60a94ded9197532c7ebf42e8e321223311e4a4834ea15219aa1625e4"

> > +

> > +EXTRA_OECONF = "--disable-curl --disable-soup --disable-ldap \

> > +               --enable-gmp --disable-mysql --disable-sqlite \

> > +               --enable-openssl"

> > +

> > +inherit autotools

> > +

> > +RRECOMMENDS_${PN} = "kernel-module-ipsec"

> > +

> > +FILES_${PN}-dbg += "${libexecdir}/ipsec/.debug

> ${libexecdir}/ipsec/plugins/.debug"

> > --

> > 1.7.0.4

> >

> >

> >

> > _______________________________________________

> > Openembedded-devel mailing list

> > Openembedded-devel@lists.openembedded.org

> > http://lists.linuxtogo.org/cgi-bin/mailman/listinfo/openembedded-devel

> 

> _______________________________________________

> Openembedded-devel mailing list

> Openembedded-devel@lists.openembedded.org

> http://lists.linuxtogo.org/cgi-bin/mailman/listinfo/openembedded-devel

Patch

diff --git a/meta-oe/recipes-support/strongswan/strongswan_4.5.1.bb b/meta-oe/recipes-support/strongswan/strongswan_4.5.1.bb
deleted file mode 100644
index 3276fdd..0000000
--- a/meta-oe/recipes-support/strongswan/strongswan_4.5.1.bb
+++ /dev/null
@@ -1,21 +0,0 @@ 
-DESCRIPTION = "strongSwan is an OpenSource IPsec implementation for the \
-Linux operating system."
-HOMEPAGE = "http://www.strongswan.org"
-SECTION = "console/network"
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
-DEPENDS = "gmp openssl flex-native flex bison-native"
-
-SRC_URI = "http://download.strongswan.org/strongswan-${PV}.tar.bz2"
-SRC_URI[md5sum] = "81a4a699c4a1a49b74061dfa47b5a033"
-SRC_URI[sha256sum] = "252d7369d94aa2d79e6fad078853b07ca897ea811ab1e1a2b008bcec0d1e758a"
-
-EXTRA_OECONF = "--disable-curl --disable-soup --disable-ldap \
-		--enable-gmp --disable-mysql --disable-sqlite \
-		--enable-openssl"
-
-inherit autotools
-
-RRECOMMENDS_${PN} = "kernel-module-ipsec"
-
-FILES_${PN}-dbg += "${libexecdir}/ipsec/.debug ${libexecdir}/ipsec/plugins/.debug"
diff --git a/meta-oe/recipes-support/strongswan/strongswan_4.6.2.bb b/meta-oe/recipes-support/strongswan/strongswan_4.6.2.bb
new file mode 100644
index 0000000..3816e57
--- /dev/null
+++ b/meta-oe/recipes-support/strongswan/strongswan_4.6.2.bb
@@ -0,0 +1,21 @@ 
+DESCRIPTION = "strongSwan is an OpenSource IPsec implementation for the \
+Linux operating system."
+HOMEPAGE = "http://www.strongswan.org"
+SECTION = "console/network"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+DEPENDS = "gmp openssl flex-native flex bison-native"
+
+SRC_URI = "http://download.strongswan.org/strongswan-${PV}.tar.bz2"
+SRC_URI[md5sum] = "ed64e6746011930a70f3a271dc0e3c9e"
+SRC_URI[sha256sum] = "a5ecb3fc60a94ded9197532c7ebf42e8e321223311e4a4834ea15219aa1625e4"
+
+EXTRA_OECONF = "--disable-curl --disable-soup --disable-ldap \
+		--enable-gmp --disable-mysql --disable-sqlite \
+		--enable-openssl"
+
+inherit autotools
+
+RRECOMMENDS_${PN} = "kernel-module-ipsec"
+
+FILES_${PN}-dbg += "${libexecdir}/ipsec/.debug ${libexecdir}/ipsec/plugins/.debug"