diff mbox series

[meta-oe,kirkstone] python3-gcovr: Add missing runtime dependency

Message ID 20230508075012.5876-1-jasper@fancydomain.eu
State New
Headers show
Series [meta-oe,kirkstone] python3-gcovr: Add missing runtime dependency | expand

Commit Message

Jasper Orschulko May 8, 2023, 7:50 a.m. UTC
python3-gcovr requires standard python module multiprocessing as runtime
dependency.

Upstream-Status: Inappropriate [configuration]

Signed-off-by: Jasper Orschulko <jasper@fancydomain.eu>
Signed-off-by: Khem Raj <raj.khem@gmail.com>

(Cherry-picked from commit 5564dbb8ff22d9ca4296a68f92f3c9d05fbdf99f)

Signed-off-by: Jasper Orschulko <jasper@fancydomain.eu>
---
 meta-python/recipes-devtools/python/python3-gcovr_5.1.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-gcovr_5.1.bb b/meta-python/recipes-devtools/python/python3-gcovr_5.1.bb
index 995f3b779..1c4279fd1 100644
--- a/meta-python/recipes-devtools/python/python3-gcovr_5.1.bb
+++ b/meta-python/recipes-devtools/python/python3-gcovr_5.1.bb
@@ -12,6 +12,6 @@  S = "${WORKDIR}/git"
 inherit setuptools3
 PIP_INSTALL_PACKAGE = "gcovr"
 
-RDEPENDS:${PN} += "${PYTHON_PN}-jinja2 ${PYTHON_PN}-lxml ${PYTHON_PN}-setuptools ${PYTHON_PN}-pygments"
+RDEPENDS:${PN} += "${PYTHON_PN}-jinja2 ${PYTHON_PN}-lxml ${PYTHON_PN}-setuptools ${PYTHON_PN}-pygments ${PYTHON_PN}-multiprocessing"
 
 BBCLASSEXTEND = "native nativesdk"