diff mbox series

[meta-oe] libplist: upgrade 2.2.0 -> 2.3.0

Message ID 1683540471-25268-3-git-send-email-wangmy@fujitsu.com
State Under Review
Headers show
Series [meta-oe] libplist: upgrade 2.2.0 -> 2.3.0 | expand

Commit Message

Mingyu Wang (Fujitsu) May 8, 2023, 10:07 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

Changelog:
=========
- Changes:
  * Rename PLIST_UINT to PLIST_INT and add plist_new_int() and plist_get_int_val()
  * Add support for JSON format
  * Add support for OpenStep format
  * Introduce error codes and format constants
  * Add return value to import/export functions to allow returning error codes
  * Add new plist_sort function
  * Add several human-readable output-only formats
  * Add new plist_write_to_string/_stream/_file functions
  * Add new plist_print function
  * Add new plist_read_from_file function
  * Add new plist_mem_free() function
  * Add a few C++ methods
  * Add C++ interface test
  * Add PLIST_NULL type
  * Some code housekeeping (mostly clang-tidy)
- Breaking:
  * plist_from_memory() gets additional parameter
- Bugfixes:
  * Fix multiple bugs in all of the parsers
  * Fix handling of PLIST_UID nodes

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 meta-oe/recipes-extended/libimobiledevice/libplist_git.bb | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Khem Raj May 9, 2023, 4:45 a.m. UTC | #1
In order to get this patch through we need to fix
libimobiledevice-glue recipe as well. See the error below

https://errors.yoctoproject.org/Errors/Details/703594/

also while you are at it, we have duplicate recipes for libplist,
please merge them into one if possible

see meta-oe/recipes-extended/libimobiledevice/libplist_git.bb and
libplist_2.2.0.bb

On Mon, May 8, 2023 at 3:08 AM wangmy <wangmy@fujitsu.com> wrote:
>
> From: Wang Mingyu <wangmy@fujitsu.com>
>
> Changelog:
> =========
> - Changes:
>   * Rename PLIST_UINT to PLIST_INT and add plist_new_int() and plist_get_int_val()
>   * Add support for JSON format
>   * Add support for OpenStep format
>   * Introduce error codes and format constants
>   * Add return value to import/export functions to allow returning error codes
>   * Add new plist_sort function
>   * Add several human-readable output-only formats
>   * Add new plist_write_to_string/_stream/_file functions
>   * Add new plist_print function
>   * Add new plist_read_from_file function
>   * Add new plist_mem_free() function
>   * Add a few C++ methods
>   * Add C++ interface test
>   * Add PLIST_NULL type
>   * Some code housekeeping (mostly clang-tidy)
> - Breaking:
>   * plist_from_memory() gets additional parameter
> - Bugfixes:
>   * Fix multiple bugs in all of the parsers
>   * Fix handling of PLIST_UID nodes
>
> Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
> ---
>  meta-oe/recipes-extended/libimobiledevice/libplist_git.bb | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/meta-oe/recipes-extended/libimobiledevice/libplist_git.bb b/meta-oe/recipes-extended/libimobiledevice/libplist_git.bb
> index 82f3e4d0c9..8f5a7f166f 100644
> --- a/meta-oe/recipes-extended/libimobiledevice/libplist_git.bb
> +++ b/meta-oe/recipes-extended/libimobiledevice/libplist_git.bb
> @@ -8,9 +8,9 @@ DEPENDS = "libxml2 glib-2.0 swig python3"
>
>  inherit autotools pkgconfig python3native python3targetconfig
>
> -PV = "2.2.0+git${SRCPV}"
> +PV = "2.3.0"
>
> -SRCREV = "db93bae96d64140230ad050061632531644c46ad"
> +SRCREV = "72480212cd8ec0ab8d0b5064df52c146cac603b4"
>  SRC_URI = "git://github.com/libimobiledevice/libplist;protocol=https;branch=master"
>
>  S = "${WORKDIR}/git"
> --
> 2.34.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#102397): https://lists.openembedded.org/g/openembedded-devel/message/102397
> Mute This Topic: https://lists.openembedded.org/mt/98757857/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta-oe/recipes-extended/libimobiledevice/libplist_git.bb b/meta-oe/recipes-extended/libimobiledevice/libplist_git.bb
index 82f3e4d0c9..8f5a7f166f 100644
--- a/meta-oe/recipes-extended/libimobiledevice/libplist_git.bb
+++ b/meta-oe/recipes-extended/libimobiledevice/libplist_git.bb
@@ -8,9 +8,9 @@  DEPENDS = "libxml2 glib-2.0 swig python3"
 
 inherit autotools pkgconfig python3native python3targetconfig
 
-PV = "2.2.0+git${SRCPV}"
+PV = "2.3.0"
 
-SRCREV = "db93bae96d64140230ad050061632531644c46ad"
+SRCREV = "72480212cd8ec0ab8d0b5064df52c146cac603b4"
 SRC_URI = "git://github.com/libimobiledevice/libplist;protocol=https;branch=master"
 
 S = "${WORKDIR}/git"