diff mbox series

[meta-oe] libssh: upgrade 0.10.4 -> 0.10.5

Message ID 1683540471-25268-4-git-send-email-wangmy@fujitsu.com
State Under Review
Headers show
Series [meta-oe] libssh: upgrade 0.10.4 -> 0.10.5 | expand

Commit Message

Mingyu Wang (Fujitsu) May 8, 2023, 10:07 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

Changelog:
=========
 * Fix CVE-2023-1667: a NULL dereference during rekeying with algorithm guessing
 * Fix CVE-2023-2283: a possible authorization bypass in
   pki_verify_data_signature under low-memory conditions.
 * Fix several memory leaks in GSSAPI handling code
 * Escape braces in ProxyCommand created from ProxyJump options for zsh
   compatibility.
 * Fix pkg-config path relocation for MinGW
 * Improve doxygen documentation
 * Fix build with cygwin due to the glob support
 * Do not enqueue outgoing packets after sending SSH2_MSG_NEWKEYS
 * Add support for SSH_SUPPRESS_DEPRECATED
 * Avoid functions declarations without prototype to build with clang 15
 * Fix spelling issues
 * Avoid expanding KnownHosts, ProxyCommands and IdentityFiles repetitively
 * Add support sk-* keys through configuration
 * Improve checking for Argp library
 * Log information about received extensions
 * Correctly handle rekey with delayed compression
 * Move the EC keys handling to OpenSSL 3.0 API
 * Record peer disconnect message
 * Avoid deadlock when write buffering occurs and we call poll recursively to
   flush the output buffer
 * Disable preauthentication compression by default
 * Add CentOS 8 Stream / OpenSSL 1.1.1 to CI
 * Add accidentally removed default compile flags
 * Solve incorrect parsing of ProxyCommand option

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../libssh/{libssh_0.10.4.bb => libssh_0.10.5.bb}               | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta-oe/recipes-support/libssh/{libssh_0.10.4.bb => libssh_0.10.5.bb} (96%)

Comments

Khem Raj May 8, 2023, 7:29 p.m. UTC | #1
This is failing ptests on musl.

{'libssh': ['torture_config']}

To run ptests in your env try building meta-oe-ptest-image-libssh

On Mon, May 8, 2023 at 3:08 AM wangmy <wangmy@fujitsu.com> wrote:
>
> From: Wang Mingyu <wangmy@fujitsu.com>
>
> Changelog:
> =========
>  * Fix CVE-2023-1667: a NULL dereference during rekeying with algorithm guessing
>  * Fix CVE-2023-2283: a possible authorization bypass in
>    pki_verify_data_signature under low-memory conditions.
>  * Fix several memory leaks in GSSAPI handling code
>  * Escape braces in ProxyCommand created from ProxyJump options for zsh
>    compatibility.
>  * Fix pkg-config path relocation for MinGW
>  * Improve doxygen documentation
>  * Fix build with cygwin due to the glob support
>  * Do not enqueue outgoing packets after sending SSH2_MSG_NEWKEYS
>  * Add support for SSH_SUPPRESS_DEPRECATED
>  * Avoid functions declarations without prototype to build with clang 15
>  * Fix spelling issues
>  * Avoid expanding KnownHosts, ProxyCommands and IdentityFiles repetitively
>  * Add support sk-* keys through configuration
>  * Improve checking for Argp library
>  * Log information about received extensions
>  * Correctly handle rekey with delayed compression
>  * Move the EC keys handling to OpenSSL 3.0 API
>  * Record peer disconnect message
>  * Avoid deadlock when write buffering occurs and we call poll recursively to
>    flush the output buffer
>  * Disable preauthentication compression by default
>  * Add CentOS 8 Stream / OpenSSL 1.1.1 to CI
>  * Add accidentally removed default compile flags
>  * Solve incorrect parsing of ProxyCommand option
>
> Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
> ---
>  .../libssh/{libssh_0.10.4.bb => libssh_0.10.5.bb}               | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>  rename meta-oe/recipes-support/libssh/{libssh_0.10.4.bb => libssh_0.10.5.bb} (96%)
>
> diff --git a/meta-oe/recipes-support/libssh/libssh_0.10.4.bb b/meta-oe/recipes-support/libssh/libssh_0.10.5.bb
> similarity index 96%
> rename from meta-oe/recipes-support/libssh/libssh_0.10.4.bb
> rename to meta-oe/recipes-support/libssh/libssh_0.10.5.bb
> index 4b2ced5e50..4995e9cfe4 100644
> --- a/meta-oe/recipes-support/libssh/libssh_0.10.4.bb
> +++ b/meta-oe/recipes-support/libssh/libssh_0.10.5.bb
> @@ -11,7 +11,7 @@ SRC_URI = "git://git.libssh.org/projects/libssh.git;protocol=https;branch=stable
>             file://0001-libgcrypt.c-Fix-prototype-of-des3_encrypt-des3_decry.patch \
>             file://run-ptest \
>            "
> -SRCREV = "e8322817a9e5aaef0698d779ddd467a209a85d85"
> +SRCREV = "479eca13aaaa46b43e68c52186e3783f06ae6f34"
>
>  S = "${WORKDIR}/git"
>
> --
> 2.34.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#102398): https://lists.openembedded.org/g/openembedded-devel/message/102398
> Mute This Topic: https://lists.openembedded.org/mt/98757858/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta-oe/recipes-support/libssh/libssh_0.10.4.bb b/meta-oe/recipes-support/libssh/libssh_0.10.5.bb
similarity index 96%
rename from meta-oe/recipes-support/libssh/libssh_0.10.4.bb
rename to meta-oe/recipes-support/libssh/libssh_0.10.5.bb
index 4b2ced5e50..4995e9cfe4 100644
--- a/meta-oe/recipes-support/libssh/libssh_0.10.4.bb
+++ b/meta-oe/recipes-support/libssh/libssh_0.10.5.bb
@@ -11,7 +11,7 @@  SRC_URI = "git://git.libssh.org/projects/libssh.git;protocol=https;branch=stable
            file://0001-libgcrypt.c-Fix-prototype-of-des3_encrypt-des3_decry.patch \
            file://run-ptest \
           "
-SRCREV = "e8322817a9e5aaef0698d779ddd467a209a85d85"
+SRCREV = "479eca13aaaa46b43e68c52186e3783f06ae6f34"
 
 S = "${WORKDIR}/git"