diff mbox series

[meta-oe,01/16] lirc: fix do_install with multilib

Message ID 20230507224354.1149327-1-Martin.Jansa@gmail.com
State New
Headers show
Series [meta-oe,01/16] lirc: fix do_install with multilib | expand

Commit Message

Martin Jansa May 7, 2023, 10:43 p.m. UTC
* use ${S} instead of ${WORKDIR}/${PN}-${PV}
  and ${BP} instead of ${PN}-${PV}
  to fix build with multilib, where PN is lib32-lirc, but S is correctly set
  as ${WORKDIR}/${BP} and do_install fails with:
  mkdir: cannot create directory ‘lib32-lirc/0.10.1-r0/lib32-lirc-0.10.1/python-pkg/dist/’: No such file or directory

Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
---
 .../meta-python/recipes-connectivity/lirc/lirc_0.10.2.bb    | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

Comments

Khem Raj May 8, 2023, 3:04 a.m. UTC | #1
Martin

Are these patches for master ? if so please rebase them on latest
master or master-next preferably, if they are for other branches then
mark them so as well.

On Sun, May 7, 2023 at 3:44 PM Martin Jansa <Martin.Jansa@gmail.com> wrote:
>
> * use ${S} instead of ${WORKDIR}/${PN}-${PV}
>   and ${BP} instead of ${PN}-${PV}
>   to fix build with multilib, where PN is lib32-lirc, but S is correctly set
>   as ${WORKDIR}/${BP} and do_install fails with:
>   mkdir: cannot create directory ‘lib32-lirc/0.10.1-r0/lib32-lirc-0.10.1/python-pkg/dist/’: No such file or directory
>
> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
> ---
>  .../meta-python/recipes-connectivity/lirc/lirc_0.10.2.bb    | 6 +++---
>  1 file changed, 3 insertions(+), 3 deletions(-)
>
> diff --git a/meta-oe/dynamic-layers/meta-python/recipes-connectivity/lirc/lirc_0.10.2.bb b/meta-oe/dynamic-layers/meta-python/recipes-connectivity/lirc/lirc_0.10.2.bb
> index 88e3f0486b..fcb347a2e5 100644
> --- a/meta-oe/dynamic-layers/meta-python/recipes-connectivity/lirc/lirc_0.10.2.bb
> +++ b/meta-oe/dynamic-layers/meta-python/recipes-connectivity/lirc/lirc_0.10.2.bb
> @@ -51,9 +51,9 @@ do_configure:append() {
>
>  # Create PYTHON_TARBALL which LIRC needs for install-nodist_pkgdataDATA
>  do_install:prepend() {
> -    rm -rf ${WORKDIR}/${PN}-${PV}/python-pkg/dist/
> -    mkdir ${WORKDIR}/${PN}-${PV}/python-pkg/dist/
> -    tar --exclude='${WORKDIR}/${PN}-${PV}/python-pkg/*' -czf ${WORKDIR}/${PN}-${PV}/python-pkg/dist/${PN}-${PV}.tar.gz ${S}
> +    rm -rf ${S}/python-pkg/dist/
> +    mkdir ${S}/python-pkg/dist/
> +    tar --exclude='${S}/python-pkg/*' -czf ${S}/python-pkg/dist/${BP}.tar.gz ${S}
>  }
>
>  # In code, path to python is a variable that is replaced with path to native version of it
> --
> 2.40.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#102363): https://lists.openembedded.org/g/openembedded-devel/message/102363
> Mute This Topic: https://lists.openembedded.org/mt/98750656/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Martin Jansa May 8, 2023, 10:23 a.m. UTC | #2
Sorry, no these are all backports for mickledore, fat fingers forgot to add
the tag in subject prefix.

Armin: do you want me to resend with fixed subject or can you pick them
from here?

On Mon, May 8, 2023 at 5:04 AM Khem Raj <raj.khem@gmail.com> wrote:

> Martin
>
> Are these patches for master ? if so please rebase them on latest
> master or master-next preferably, if they are for other branches then
> mark them so as well.
>
> On Sun, May 7, 2023 at 3:44 PM Martin Jansa <Martin.Jansa@gmail.com>
> wrote:
> >
> > * use ${S} instead of ${WORKDIR}/${PN}-${PV}
> >   and ${BP} instead of ${PN}-${PV}
> >   to fix build with multilib, where PN is lib32-lirc, but S is correctly
> set
> >   as ${WORKDIR}/${BP} and do_install fails with:
> >   mkdir: cannot create directory
> ‘lib32-lirc/0.10.1-r0/lib32-lirc-0.10.1/python-pkg/dist/’: No such file or
> directory
> >
> > Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
> > ---
> >  .../meta-python/recipes-connectivity/lirc/lirc_0.10.2.bb    | 6 +++---
> >  1 file changed, 3 insertions(+), 3 deletions(-)
> >
> > diff --git
> a/meta-oe/dynamic-layers/meta-python/recipes-connectivity/lirc/
> lirc_0.10.2.bb
> b/meta-oe/dynamic-layers/meta-python/recipes-connectivity/lirc/
> lirc_0.10.2.bb
> > index 88e3f0486b..fcb347a2e5 100644
> > --- a/meta-oe/dynamic-layers/meta-python/recipes-connectivity/lirc/
> lirc_0.10.2.bb
> > +++ b/meta-oe/dynamic-layers/meta-python/recipes-connectivity/lirc/
> lirc_0.10.2.bb
> > @@ -51,9 +51,9 @@ do_configure:append() {
> >
> >  # Create PYTHON_TARBALL which LIRC needs for install-nodist_pkgdataDATA
> >  do_install:prepend() {
> > -    rm -rf ${WORKDIR}/${PN}-${PV}/python-pkg/dist/
> > -    mkdir ${WORKDIR}/${PN}-${PV}/python-pkg/dist/
> > -    tar --exclude='${WORKDIR}/${PN}-${PV}/python-pkg/*' -czf
> ${WORKDIR}/${PN}-${PV}/python-pkg/dist/${PN}-${PV}.tar.gz ${S}
> > +    rm -rf ${S}/python-pkg/dist/
> > +    mkdir ${S}/python-pkg/dist/
> > +    tar --exclude='${S}/python-pkg/*' -czf
> ${S}/python-pkg/dist/${BP}.tar.gz ${S}
> >  }
> >
> >  # In code, path to python is a variable that is replaced with path to
> native version of it
> > --
> > 2.40.1
> >
> >
> > -=-=-=-=-=-=-=-=-=-=-=-
> > Links: You receive all messages sent to this group.
> > View/Reply Online (#102363):
> https://lists.openembedded.org/g/openembedded-devel/message/102363
> > Mute This Topic: https://lists.openembedded.org/mt/98750656/1997914
> > Group Owner: openembedded-devel+owner@lists.openembedded.org
> > Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [
> raj.khem@gmail.com]
> > -=-=-=-=-=-=-=-=-=-=-=-
> >
>
diff mbox series

Patch

diff --git a/meta-oe/dynamic-layers/meta-python/recipes-connectivity/lirc/lirc_0.10.2.bb b/meta-oe/dynamic-layers/meta-python/recipes-connectivity/lirc/lirc_0.10.2.bb
index 88e3f0486b..fcb347a2e5 100644
--- a/meta-oe/dynamic-layers/meta-python/recipes-connectivity/lirc/lirc_0.10.2.bb
+++ b/meta-oe/dynamic-layers/meta-python/recipes-connectivity/lirc/lirc_0.10.2.bb
@@ -51,9 +51,9 @@  do_configure:append() {
 
 # Create PYTHON_TARBALL which LIRC needs for install-nodist_pkgdataDATA
 do_install:prepend() {
-    rm -rf ${WORKDIR}/${PN}-${PV}/python-pkg/dist/
-    mkdir ${WORKDIR}/${PN}-${PV}/python-pkg/dist/
-    tar --exclude='${WORKDIR}/${PN}-${PV}/python-pkg/*' -czf ${WORKDIR}/${PN}-${PV}/python-pkg/dist/${PN}-${PV}.tar.gz ${S}
+    rm -rf ${S}/python-pkg/dist/
+    mkdir ${S}/python-pkg/dist/
+    tar --exclude='${S}/python-pkg/*' -czf ${S}/python-pkg/dist/${BP}.tar.gz ${S}
 }
 
 # In code, path to python is a variable that is replaced with path to native version of it