[meta-python,2/5] python3-aiohue: Upgrade 3.0.1 -> 3.0.11

Message ID 20220112183531.2712341-2-leon.anavi@konsulko.com
State New
Headers show
Series [meta-python,1/5] python3-asyncio-throttle: Add recipe | expand

Commit Message

Leon Anavi Jan. 12, 2022, 6:35 p.m. UTC
Upgrade to release 3.0.11:

- Add workaround for FOH switches
- Fix short and long flash for lights
- Fix reconnect last event id

Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
---
 .../{python3-aiohue_3.0.1.bb => python3-aiohue_3.0.11.bb} | 8 ++++++--
 1 file changed, 6 insertions(+), 2 deletions(-)
 rename meta-python/recipes-devtools/python/{python3-aiohue_3.0.1.bb => python3-aiohue_3.0.11.bb} (56%)

Patch

diff --git a/meta-python/recipes-devtools/python/python3-aiohue_3.0.1.bb b/meta-python/recipes-devtools/python/python3-aiohue_3.0.11.bb
similarity index 56%
rename from meta-python/recipes-devtools/python/python3-aiohue_3.0.1.bb
rename to meta-python/recipes-devtools/python/python3-aiohue_3.0.11.bb
index 757ab96c3..47d9964b0 100644
--- a/meta-python/recipes-devtools/python/python3-aiohue_3.0.1.bb
+++ b/meta-python/recipes-devtools/python/python3-aiohue_3.0.11.bb
@@ -4,8 +4,12 @@  SECTION = "devel/python"
 LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=dab31a1d28183826937f4b152143a33f"
 
-SRC_URI[sha256sum] = "f4933b8583d093da4c2772c40c59d262892539c7053996cea5b964a2cceaa386"
+SRC_URI[sha256sum] = "31c0b90d7dc2b62f5e1a93e78b2c0d6360ef6c0a87485c217a4f394c937fce7d"
 
 inherit pypi setuptools3
 
-RDEPENDS:${PN} += "${PYTHON_PN}-aiohttp"
+RDEPENDS:${PN} += " \
+	${PYTHON_PN}-aiohttp \
+	${PYTHON_PN}-asyncio-throttle \
+	${PYTHON_PN}-profile \
+"