diff mbox series

[1/6] python3-hatchling: fix rdepends

Message ID 20230502173422.1439794-1-ernstp@gmail.com
State New
Headers show
Series [1/6] python3-hatchling: fix rdepends | expand

Commit Message

Ernst Persson May 2, 2023, 5:34 p.m. UTC
Signed-off-by: Ernst Sjöstrand <ernstp@gmail.com>
---
 meta/recipes-devtools/python/python3-hatchling_1.13.0.bb | 7 +++++++
 1 file changed, 7 insertions(+)

Comments

Ernst Persson May 3, 2023, 9:22 a.m. UTC | #1
Oh, email, json, netserver and compression are from the python standard
library,
they are probably still needed. So this patch is wrong!
I was only thinking about PyPI requires from setup.py here.
(Couldn't they have a more unique name, like python3-core-email or
similar... ?)


Den tis 2 maj 2023 kl 19:35 skrev Ernst Sjöstrand via lists.openembedded.org
<ernstp=gmail.com@lists.openembedded.org>:

> Remove obsolete or unused rdepends.
> Add python3-charset-normalizer.
>
> Signed-off-by: Ernst Sjöstrand <ernstp@gmail.com>
> ---
>  .../python/python3-requests_2.28.2.bb                 | 11 +++--------
>  1 file changed, 3 insertions(+), 8 deletions(-)
>
> diff --git a/meta/recipes-devtools/python/python3-requests_2.28.2.bb
> b/meta/recipes-devtools/python/python3-requests_2.28.2.bb
> index 8ab1ec01212..e16490b2f5a 100644
> --- a/meta/recipes-devtools/python/python3-requests_2.28.2.bb
> +++ b/meta/recipes-devtools/python/python3-requests_2.28.2.bb
> @@ -1,5 +1,5 @@
>  SUMMARY = "Python HTTP for Humans."
> -HOMEPAGE = "http://python-requests.org"
> +HOMEPAGE = "https://requests.readthedocs.io"
>  LICENSE = "Apache-2.0"
>  LIC_FILES_CHKSUM = "file://LICENSE;md5=34400b68072d710fecd0a2940a0d1658"
>
> @@ -8,17 +8,12 @@ SRC_URI[sha256sum] =
> "98b1b2782e3c6c4904938b84c0eb932721069dfdb9134313beff7c83c2
>  inherit pypi setuptools3
>
>  RDEPENDS:${PN} += " \
> -    ${PYTHON_PN}-email \
> -    ${PYTHON_PN}-json \
> -    ${PYTHON_PN}-ndg-httpsclient \
> -    ${PYTHON_PN}-netserver \
> -    ${PYTHON_PN}-pyasn1 \
> -    ${PYTHON_PN}-pyopenssl \
> +    ${PYTHON_PN}-certifi \
> +    ${PYTHON_PN}-charset-normalizer \
>      ${PYTHON_PN}-pysocks \
>      ${PYTHON_PN}-urllib3 \
>      ${PYTHON_PN}-chardet \
>      ${PYTHON_PN}-idna \
> -    ${PYTHON_PN}-compression \
>  "
>
>  CVE_PRODUCT = "requests"
> --
> 2.39.2
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#180760):
> https://lists.openembedded.org/g/openembedded-core/message/180760
> Mute This Topic: https://lists.openembedded.org/mt/98644248/4947266
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [
> ernstp@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
>
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python3-hatchling_1.13.0.bb b/meta/recipes-devtools/python/python3-hatchling_1.13.0.bb
index 17e7f86ba66..ac1e8cc9d0d 100644
--- a/meta/recipes-devtools/python/python3-hatchling_1.13.0.bb
+++ b/meta/recipes-devtools/python/python3-hatchling_1.13.0.bb
@@ -14,4 +14,11 @@  do_compile:prepend() {
     export PYTHONPATH=src
 }
 
+RDEPENDS:${PN} += " \
+    ${PYTHON_PN}-editables \
+    ${PYTHON_PN}-packaging \
+    ${PYTHON_PN}-pathspec \
+    ${PYTHON_PN}-pluggy \
+"
+
 BBCLASSEXTEND = "native nativesdk"