diff mbox series

[meta-ti,kirkstone] ti-ipc: Stop looking for rpmsg_rpc.h in the kernel

Message ID 20230428213257.13088-1-reatmon@ti.com
State Superseded
Delegated to: Ryan Eatmon
Headers show
Series [meta-ti,kirkstone] ti-ipc: Stop looking for rpmsg_rpc.h in the kernel | expand

Commit Message

Ryan Eatmon April 28, 2023, 9:32 p.m. UTC
Stop looking for the rpmsg_rpc.h in the kernel.  While we are doing the
LTS migration for kirkstone, this file is not going to be in the kernel
for a bit.  This patch works in conjunction with a recipe change that
downloads the header and adds a -I to the CFLAGS to pick it up.  This
will be removed once the 6.1 kernel has been updated.

Signed-off-by: Ryan Eatmon <reatmon@ti.com>
---
 ...ooking-for-rpmsg_rpc.h-in-the-kernel.patch | 35 +++++++++++++++++++
 meta-ti-bsp/recipes-ti/ipc/ti-ipc_git.bb      |  6 ++++
 2 files changed, 41 insertions(+)
 create mode 100644 meta-ti-bsp/recipes-ti/ipc/ti-ipc/0001-MmRpc-Stop-looking-for-rpmsg_rpc.h-in-the-kernel.patch

Comments

Denys Dmytriyenko April 29, 2023, 3:21 p.m. UTC | #1
On Fri, Apr 28, 2023 at 04:32:57PM -0500, Ryan Eatmon via lists.yoctoproject.org wrote:
> Stop looking for the rpmsg_rpc.h in the kernel.  While we are doing the
> LTS migration for kirkstone, this file is not going to be in the kernel
> for a bit.  This patch works in conjunction with a recipe change that
> downloads the header and adds a -I to the CFLAGS to pick it up.  This
> will be removed once the 6.1 kernel has been updated.
> 
> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
> ---
>  ...ooking-for-rpmsg_rpc.h-in-the-kernel.patch | 35 +++++++++++++++++++
>  meta-ti-bsp/recipes-ti/ipc/ti-ipc_git.bb      |  6 ++++
>  2 files changed, 41 insertions(+)
>  create mode 100644 meta-ti-bsp/recipes-ti/ipc/ti-ipc/0001-MmRpc-Stop-looking-for-rpmsg_rpc.h-in-the-kernel.patch
> 
> diff --git a/meta-ti-bsp/recipes-ti/ipc/ti-ipc/0001-MmRpc-Stop-looking-for-rpmsg_rpc.h-in-the-kernel.patch b/meta-ti-bsp/recipes-ti/ipc/ti-ipc/0001-MmRpc-Stop-looking-for-rpmsg_rpc.h-in-the-kernel.patch
> new file mode 100644
> index 00000000..ef12af88
> --- /dev/null
> +++ b/meta-ti-bsp/recipes-ti/ipc/ti-ipc/0001-MmRpc-Stop-looking-for-rpmsg_rpc.h-in-the-kernel.patch
> @@ -0,0 +1,35 @@
> +From 66ca0e732c2e287814d4fc5082b818554ee42398 Mon Sep 17 00:00:00 2001
> +From: Ryan Eatmon <reatmon@ti.com>
> +Date: Fri, 28 Apr 2023 14:30:59 -0500
> +Subject: [PATCH] MmRpc: Stop looking for rpmsg_rpc.h in the kernel
> +
> +Stop looking for the rpmsg_rpc.h in the kernel.  While we are doing the
> +LTS migration for kirkstone, this file is not going to be in the kernel
> +for a bit.  This patch works in conjunction with a recipe change that
> +downloads the header and adds a -I to the CFLAGS to pick it up.  This
> +will be removed once the 6.1 kernel has been updated.
> +
> +Signed-off-by: Ryan Eatmon <reatmon@ti.com>
> +
> +Upstream-Status: Inappropriate [other]
> +
> +---
> + packages/ti/ipc/mm/MmRpc.c | 2 +-
> + 1 file changed, 1 insertion(+), 1 deletion(-)
> +
> +diff --git a/packages/ti/ipc/mm/MmRpc.c b/packages/ti/ipc/mm/MmRpc.c
> +index 2df7420..10f496b 100644
> +--- a/packages/ti/ipc/mm/MmRpc.c
> ++++ b/packages/ti/ipc/mm/MmRpc.c
> +@@ -64,7 +64,7 @@
> + #define linux_include(kd,m) <kd/include/uapi/linux/m.h>
> + #endif
> + 
> +-#include linux_include(KERNEL_INSTALL_DIR,rpmsg_rpc)
> ++#include "linux/rpmsg_rpc.h"
> + 
> + #ifdef _linux_
> + #define linux _linux
> +-- 
> +2.17.1
> +
> diff --git a/meta-ti-bsp/recipes-ti/ipc/ti-ipc_git.bb b/meta-ti-bsp/recipes-ti/ipc/ti-ipc_git.bb
> index 01b857c2..1782f02a 100644
> --- a/meta-ti-bsp/recipes-ti/ipc/ti-ipc_git.bb
> +++ b/meta-ti-bsp/recipes-ti/ipc/ti-ipc_git.bb
> @@ -8,12 +8,18 @@ PR = "${INC_PR}.2"
>  
>  DEPENDS += "virtual/kernel"
>  
> +SRC_URI:append = "https://git.ti.com/cgit/ti-linux-kernel/ti-linux-kernel/plain/include/uapi/linux/rpmsg_rpc.h?h=ti-linux-5.10.y;name=rpmsg_rpc;subdir=linux;downloadfilename=rpmsg_rpc.h"

Whitespace or use += here like below.


> +SRC_URI[rpmsg_rpc.sha256sum] = "cd237f40a37520a1f2df19fbfeefd00c0a5ad68efeaba9ba0fba60ca16ea09be"
> +
>  SRC_URI += "file://tiipclad-daemon.sh \
>              file://omap_remoteproc.conf \
>              file://tiipclad-daemon.service \
>              file://0001-Add-kernel-build-dir.patch \
> +            file://0001-MmRpc-Stop-looking-for-rpmsg_rpc.h-in-the-kernel.patch \
>             "
>  
> +CFLAGS += "-I${WORKDIR}"
> +
>  DAEMON = "UNKNOWN"
>  DAEMON:dra7xx = "lad_dra7xx"
>  DAEMON:omapl138 = "lad_omapl138"
> -- 
> 2.17.1
Ryan Eatmon May 1, 2023, 12:31 p.m. UTC | #2
On 4/29/2023 10:21, Denys Dmytriyenko wrote:
> On Fri, Apr 28, 2023 at 04:32:57PM -0500, Ryan Eatmon via lists.yoctoproject.org wrote:
>> Stop looking for the rpmsg_rpc.h in the kernel.  While we are doing the
>> LTS migration for kirkstone, this file is not going to be in the kernel
>> for a bit.  This patch works in conjunction with a recipe change that
>> downloads the header and adds a -I to the CFLAGS to pick it up.  This
>> will be removed once the 6.1 kernel has been updated.
>>
>> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
>> ---
>>   ...ooking-for-rpmsg_rpc.h-in-the-kernel.patch | 35 +++++++++++++++++++
>>   meta-ti-bsp/recipes-ti/ipc/ti-ipc_git.bb      |  6 ++++
>>   2 files changed, 41 insertions(+)
>>   create mode 100644 meta-ti-bsp/recipes-ti/ipc/ti-ipc/0001-MmRpc-Stop-looking-for-rpmsg_rpc.h-in-the-kernel.patch
>>
>> diff --git a/meta-ti-bsp/recipes-ti/ipc/ti-ipc/0001-MmRpc-Stop-looking-for-rpmsg_rpc.h-in-the-kernel.patch b/meta-ti-bsp/recipes-ti/ipc/ti-ipc/0001-MmRpc-Stop-looking-for-rpmsg_rpc.h-in-the-kernel.patch
>> new file mode 100644
>> index 00000000..ef12af88
>> --- /dev/null
>> +++ b/meta-ti-bsp/recipes-ti/ipc/ti-ipc/0001-MmRpc-Stop-looking-for-rpmsg_rpc.h-in-the-kernel.patch
>> @@ -0,0 +1,35 @@
>> +From 66ca0e732c2e287814d4fc5082b818554ee42398 Mon Sep 17 00:00:00 2001
>> +From: Ryan Eatmon <reatmon@ti.com>
>> +Date: Fri, 28 Apr 2023 14:30:59 -0500
>> +Subject: [PATCH] MmRpc: Stop looking for rpmsg_rpc.h in the kernel
>> +
>> +Stop looking for the rpmsg_rpc.h in the kernel.  While we are doing the
>> +LTS migration for kirkstone, this file is not going to be in the kernel
>> +for a bit.  This patch works in conjunction with a recipe change that
>> +downloads the header and adds a -I to the CFLAGS to pick it up.  This
>> +will be removed once the 6.1 kernel has been updated.
>> +
>> +Signed-off-by: Ryan Eatmon <reatmon@ti.com>
>> +
>> +Upstream-Status: Inappropriate [other]
>> +
>> +---
>> + packages/ti/ipc/mm/MmRpc.c | 2 +-
>> + 1 file changed, 1 insertion(+), 1 deletion(-)
>> +
>> +diff --git a/packages/ti/ipc/mm/MmRpc.c b/packages/ti/ipc/mm/MmRpc.c
>> +index 2df7420..10f496b 100644
>> +--- a/packages/ti/ipc/mm/MmRpc.c
>> ++++ b/packages/ti/ipc/mm/MmRpc.c
>> +@@ -64,7 +64,7 @@
>> + #define linux_include(kd,m) <kd/include/uapi/linux/m.h>
>> + #endif
>> +
>> +-#include linux_include(KERNEL_INSTALL_DIR,rpmsg_rpc)
>> ++#include "linux/rpmsg_rpc.h"
>> +
>> + #ifdef _linux_
>> + #define linux _linux
>> +--
>> +2.17.1
>> +
>> diff --git a/meta-ti-bsp/recipes-ti/ipc/ti-ipc_git.bb b/meta-ti-bsp/recipes-ti/ipc/ti-ipc_git.bb
>> index 01b857c2..1782f02a 100644
>> --- a/meta-ti-bsp/recipes-ti/ipc/ti-ipc_git.bb
>> +++ b/meta-ti-bsp/recipes-ti/ipc/ti-ipc_git.bb
>> @@ -8,12 +8,18 @@ PR = "${INC_PR}.2"
>>   
>>   DEPENDS += "virtual/kernel"
>>   
>> +SRC_URI:append = "https://git.ti.com/cgit/ti-linux-kernel/ti-linux-kernel/plain/include/uapi/linux/rpmsg_rpc.h?h=ti-linux-5.10.y;name=rpmsg_rpc;subdir=linux;downloadfilename=rpmsg_rpc.h"
> 
> Whitespace or use += here like below.

Doh!  I copied the line from the wrong file.  V2 incoming.

> 
>> +SRC_URI[rpmsg_rpc.sha256sum] = "cd237f40a37520a1f2df19fbfeefd00c0a5ad68efeaba9ba0fba60ca16ea09be"
>> +
>>   SRC_URI += "file://tiipclad-daemon.sh \
>>               file://omap_remoteproc.conf \
>>               file://tiipclad-daemon.service \
>>               file://0001-Add-kernel-build-dir.patch \
>> +            file://0001-MmRpc-Stop-looking-for-rpmsg_rpc.h-in-the-kernel.patch \
>>              "
>>   
>> +CFLAGS += "-I${WORKDIR}"
>> +
>>   DAEMON = "UNKNOWN"
>>   DAEMON:dra7xx = "lad_dra7xx"
>>   DAEMON:omapl138 = "lad_omapl138"
>> -- 
>> 2.17.1
diff mbox series

Patch

diff --git a/meta-ti-bsp/recipes-ti/ipc/ti-ipc/0001-MmRpc-Stop-looking-for-rpmsg_rpc.h-in-the-kernel.patch b/meta-ti-bsp/recipes-ti/ipc/ti-ipc/0001-MmRpc-Stop-looking-for-rpmsg_rpc.h-in-the-kernel.patch
new file mode 100644
index 00000000..ef12af88
--- /dev/null
+++ b/meta-ti-bsp/recipes-ti/ipc/ti-ipc/0001-MmRpc-Stop-looking-for-rpmsg_rpc.h-in-the-kernel.patch
@@ -0,0 +1,35 @@ 
+From 66ca0e732c2e287814d4fc5082b818554ee42398 Mon Sep 17 00:00:00 2001
+From: Ryan Eatmon <reatmon@ti.com>
+Date: Fri, 28 Apr 2023 14:30:59 -0500
+Subject: [PATCH] MmRpc: Stop looking for rpmsg_rpc.h in the kernel
+
+Stop looking for the rpmsg_rpc.h in the kernel.  While we are doing the
+LTS migration for kirkstone, this file is not going to be in the kernel
+for a bit.  This patch works in conjunction with a recipe change that
+downloads the header and adds a -I to the CFLAGS to pick it up.  This
+will be removed once the 6.1 kernel has been updated.
+
+Signed-off-by: Ryan Eatmon <reatmon@ti.com>
+
+Upstream-Status: Inappropriate [other]
+
+---
+ packages/ti/ipc/mm/MmRpc.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/packages/ti/ipc/mm/MmRpc.c b/packages/ti/ipc/mm/MmRpc.c
+index 2df7420..10f496b 100644
+--- a/packages/ti/ipc/mm/MmRpc.c
++++ b/packages/ti/ipc/mm/MmRpc.c
+@@ -64,7 +64,7 @@
+ #define linux_include(kd,m) <kd/include/uapi/linux/m.h>
+ #endif
+ 
+-#include linux_include(KERNEL_INSTALL_DIR,rpmsg_rpc)
++#include "linux/rpmsg_rpc.h"
+ 
+ #ifdef _linux_
+ #define linux _linux
+-- 
+2.17.1
+
diff --git a/meta-ti-bsp/recipes-ti/ipc/ti-ipc_git.bb b/meta-ti-bsp/recipes-ti/ipc/ti-ipc_git.bb
index 01b857c2..1782f02a 100644
--- a/meta-ti-bsp/recipes-ti/ipc/ti-ipc_git.bb
+++ b/meta-ti-bsp/recipes-ti/ipc/ti-ipc_git.bb
@@ -8,12 +8,18 @@  PR = "${INC_PR}.2"
 
 DEPENDS += "virtual/kernel"
 
+SRC_URI:append = "https://git.ti.com/cgit/ti-linux-kernel/ti-linux-kernel/plain/include/uapi/linux/rpmsg_rpc.h?h=ti-linux-5.10.y;name=rpmsg_rpc;subdir=linux;downloadfilename=rpmsg_rpc.h"
+SRC_URI[rpmsg_rpc.sha256sum] = "cd237f40a37520a1f2df19fbfeefd00c0a5ad68efeaba9ba0fba60ca16ea09be"
+
 SRC_URI += "file://tiipclad-daemon.sh \
             file://omap_remoteproc.conf \
             file://tiipclad-daemon.service \
             file://0001-Add-kernel-build-dir.patch \
+            file://0001-MmRpc-Stop-looking-for-rpmsg_rpc.h-in-the-kernel.patch \
            "
 
+CFLAGS += "-I${WORKDIR}"
+
 DAEMON = "UNKNOWN"
 DAEMON:dra7xx = "lad_dra7xx"
 DAEMON:omapl138 = "lad_omapl138"