[meta-oe] pcp: Fix build to exclude qt5

Message ID 20220111192633.1395522-1-raj.khem@gmail.com
State New
Headers show
Series [meta-oe] pcp: Fix build to exclude qt5 | expand

Commit Message

Khem Raj Jan. 11, 2022, 7:26 p.m. UTC
Pass right options to ar

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Cc: Lei Maohui <leimaohui@fujitsu.com>
---
 meta-oe/recipes-support/pcp/pcp.inc           |  2 ++
 .../pcp/pcp/pass-options-to-AR.patch          | 29 +++++++++++++++++++
 meta-oe/recipes-support/pcp/pcp_5.3.5.bb      |  3 +-
 3 files changed, 33 insertions(+), 1 deletion(-)
 create mode 100644 meta-oe/recipes-support/pcp/pcp/pass-options-to-AR.patch

Patch

diff --git a/meta-oe/recipes-support/pcp/pcp.inc b/meta-oe/recipes-support/pcp/pcp.inc
index f6f111b0e8..d50e7b0910 100644
--- a/meta-oe/recipes-support/pcp/pcp.inc
+++ b/meta-oe/recipes-support/pcp/pcp.inc
@@ -29,4 +29,6 @@  EXTRA_OECONF:append = " --with-dstat-symlink=yes --with-infiniband=no \
                 --with-docdir=${docdir} \
                 "
 
+PACKAGECONFIG[qt5] = "--with-qt=yes --with-qt3d=yes,--with-qt=no --with-qt3d=no,qtbase qt3d"
 
+PACKAGECONFIG ?= ""
diff --git a/meta-oe/recipes-support/pcp/pcp/pass-options-to-AR.patch b/meta-oe/recipes-support/pcp/pcp/pass-options-to-AR.patch
new file mode 100644
index 0000000000..6fa864cd21
--- /dev/null
+++ b/meta-oe/recipes-support/pcp/pcp/pass-options-to-AR.patch
@@ -0,0 +1,29 @@ 
+Do not pass cr option
+
+These options are already coming from builddefs
+
+Upstream-Status: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+--- a/src/include/builddefs.in
++++ b/src/include/builddefs.in
+@@ -167,7 +167,7 @@ OBJECTS = $(ASFILES:.s=.o) \
+ 
+ #NB: don't override $(MAKE); gnumake sets it well, propagating -j etc.
+ #MAKE	= @make@
+-AR	= @ar@
++AR	= @ar@ cqs
+ CC	= @cc@
+ CXX	= @cxx@
+ LD	= @ld@
+--- a/src/include/buildrules
++++ b/src/include/buildrules
+@@ -93,7 +93,7 @@ $(STATICLIBTARGET) : $(SUBDIRS) $(OBJECT
+ ifeq ($(TARGET_OS), darwin)
+ 	libtool -static -o $(STATICLIBTARGET) $?
+ else
+-	$(AR) cr $(STATICLIBTARGET) $?
++	$(AR) $(STATICLIBTARGET) $?
+ endif
+ endif
+ 
diff --git a/meta-oe/recipes-support/pcp/pcp_5.3.5.bb b/meta-oe/recipes-support/pcp/pcp_5.3.5.bb
index 2dafab1b57..cdf506577a 100644
--- a/meta-oe/recipes-support/pcp/pcp_5.3.5.bb
+++ b/meta-oe/recipes-support/pcp/pcp_5.3.5.bb
@@ -11,11 +11,12 @@  DEPENDS += "perl-native bison-native flex-native python3-native python3-setuptoo
 
 
 SRC_URI += "file://0001-Remove-unsuitble-part-for-cross-compile.patch \
+            file://pass-options-to-AR.patch \
            "
 
 export PCP_DIR="${RECIPE_SYSROOT_NATIVE}"
 #export PCP_RUN_DIR="${RECIPE_SYSROOT_NATIVE}"
-EXTRA_OEMAKE = "CC="${CC}" LD="${LD}" AR="${AR}""
+EXTRA_OEMAKE = "CC="${CC}" LD="${LD}""
 inherit useradd systemd 
 
 SYSTEMD_AUTO_ENABLE:${PN} = "enable"