diff mbox series

[meta-arago,master/kirkstone,6/6] glfw: convert to append and drop patches

Message ID 20230426213214.3501230-8-rs@ti.com
State Superseded
Delegated to: Ryan Eatmon
Headers show
Series None | expand

Commit Message

Randolph Sapp April 26, 2023, 9:32 p.m. UTC
From: Randolph Sapp <rs@ti.com>

A reasonable version of glfw is now provided by meta-oe. Also the EGL
version this package needs to build a against can be satisfied by Mesa
EGL so this old patch isn't required anymore.

Add a PACKAGECONFIG variable for wayland and use it. This append can be
dropped entirely when meta-oe accepts my PACKAGECONFIG patch [1].

[1] https://lists.openembedded.org/g/openembedded-devel/message/102202

Signed-off-by: Randolph Sapp <rs@ti.com>
---
 ...xt-remove-check-for-Wayland-Egl-prov.patch | 27 -------------------
 .../recipes-graphics/glfw/glfw_%.bbappend     |  6 +++++
 .../recipes-graphics/glfw/glfw_git.bb         | 24 -----------------
 3 files changed, 6 insertions(+), 51 deletions(-)
 delete mode 100644 meta-arago-extras/recipes-graphics/glfw/glfw/0001-HACK-CMakeList.txt-remove-check-for-Wayland-Egl-prov.patch
 create mode 100644 meta-arago-extras/recipes-graphics/glfw/glfw_%.bbappend
 delete mode 100644 meta-arago-extras/recipes-graphics/glfw/glfw_git.bb

Comments

Andrew Davis April 26, 2023, 11:23 p.m. UTC | #1
On 4/26/23 4:32 PM, rs@ti.com wrote:
> From: Randolph Sapp <rs@ti.com>
> 
> A reasonable version of glfw is now provided by meta-oe. Also the EGL
> version this package needs to build a against can be satisfied by Mesa
> EGL so this old patch isn't required anymore.
> 
> Add a PACKAGECONFIG variable for wayland and use it. This append can be
> dropped entirely when meta-oe accepts my PACKAGECONFIG patch [1].
> 
> [1] https://lists.openembedded.org/g/openembedded-devel/message/102202
> 
> Signed-off-by: Randolph Sapp <rs@ti.com>
> ---

Seems reasonable,

Acked-by: Andrew Davis <afd@ti.com>

>   ...xt-remove-check-for-Wayland-Egl-prov.patch | 27 -------------------
>   .../recipes-graphics/glfw/glfw_%.bbappend     |  6 +++++
>   .../recipes-graphics/glfw/glfw_git.bb         | 24 -----------------
>   3 files changed, 6 insertions(+), 51 deletions(-)
>   delete mode 100644 meta-arago-extras/recipes-graphics/glfw/glfw/0001-HACK-CMakeList.txt-remove-check-for-Wayland-Egl-prov.patch
>   create mode 100644 meta-arago-extras/recipes-graphics/glfw/glfw_%.bbappend
>   delete mode 100644 meta-arago-extras/recipes-graphics/glfw/glfw_git.bb
> 
> diff --git a/meta-arago-extras/recipes-graphics/glfw/glfw/0001-HACK-CMakeList.txt-remove-check-for-Wayland-Egl-prov.patch b/meta-arago-extras/recipes-graphics/glfw/glfw/0001-HACK-CMakeList.txt-remove-check-for-Wayland-Egl-prov.patch
> deleted file mode 100644
> index 6116fc12..00000000
> --- a/meta-arago-extras/recipes-graphics/glfw/glfw/0001-HACK-CMakeList.txt-remove-check-for-Wayland-Egl-prov.patch
> +++ /dev/null
> @@ -1,27 +0,0 @@
> -From c6e30af80018f7a6fc7b8b0e810718f4bd646cf6 Mon Sep 17 00:00:00 2001
> -From: Denys Dmytriyenko <denys@ti.com>
> -Date: Thu, 12 Apr 2018 12:29:39 -0400
> -Subject: [PATCH] HACK: CMakeList.txt: remove check for Wayland-Egl, provided
> - by SGX libs
> -
> -Signed-off-by: Denys Dmytriyenko <denys@ti.com>
> ----
> - CMakeLists.txt | 2 +-
> - 1 file changed, 1 insertion(+), 1 deletion(-)
> -
> -diff --git a/CMakeLists.txt b/CMakeLists.txt
> -index 1f5d6ef..eaf780f 100644
> ---- a/CMakeLists.txt
> -+++ b/CMakeLists.txt
> -@@ -266,7 +266,7 @@ if (_GLFW_WAYLAND)
> -     find_package(ECM REQUIRED NO_MODULE)
> -     list(APPEND CMAKE_MODULE_PATH "${ECM_MODULE_PATH}")
> -
> --    find_package(Wayland REQUIRED Client Cursor Egl)
> -+    find_package(Wayland REQUIRED Client Cursor)
> -     find_package(WaylandScanner REQUIRED)
> -     find_package(WaylandProtocols 1.12 REQUIRED)
> -
> ---
> -2.7.4
> -
> diff --git a/meta-arago-extras/recipes-graphics/glfw/glfw_%.bbappend b/meta-arago-extras/recipes-graphics/glfw/glfw_%.bbappend
> new file mode 100644
> index 00000000..8f80e55d
> --- /dev/null
> +++ b/meta-arago-extras/recipes-graphics/glfw/glfw_%.bbappend
> @@ -0,0 +1,6 @@
> +# Add some wayland configuration options until meta-oe adds some good
> +# PACKAGECONFIGS
> +
> +PACKAGECONFIG[wayland] = "-DGLFW_USE_WAYLAND=ON,,wayland wayland-native wayland-protocols extra-cmake-modules libxkbcommon"
> +
> +PACKAGECONFIG += " wayland"
> diff --git a/meta-arago-extras/recipes-graphics/glfw/glfw_git.bb b/meta-arago-extras/recipes-graphics/glfw/glfw_git.bb
> deleted file mode 100644
> index 0e83979f..00000000
> --- a/meta-arago-extras/recipes-graphics/glfw/glfw_git.bb
> +++ /dev/null
> @@ -1,24 +0,0 @@
> -SUMMARY = "GLFW cross platform graphics framework"
> -DESCRIPTION = "A multi-platform library for OpenGL and OpenGLES, window and input"
> -HOMEPAGE = "http://glfw.org/"
> -LICENSE = "Zlib & Libpng"
> -LIC_FILES_CHKSUM = "file://LICENSE.md;md5=90c6dd54408744b0f8a55f2a6c7ad870"
> -
> -PV = "3.2.1+git${SRCPV}"
> -PR = "r0"
> -
> -BRANCH = "master"
> -SRC_URI = "git://github.com/glfw/glfw.git;protocol=https;branch=${BRANCH}"
> -SRCREV = "0a3c4f5d80b041ee1a12c8da3503653d98bd1a15"
> -
> -SRC_URI += "file://0001-HACK-CMakeList.txt-remove-check-for-Wayland-Egl-prov.patch"
> -
> -DEPENDS = "extra-cmake-modules glib-2.0 virtual/libgles2 virtual/egl weston wayland wayland-native wayland-protocols"
> -
> -S = "${WORKDIR}/git"
> -
> -inherit cmake pkgconfig
> -
> -EXTRA_OECMAKE += "-DGLFW_USE_WAYLAND=ON -DGLFW_BUILD_EXAMPLES=OFF -DGLFW_BUILD_TESTS=OFF"
> -
> -FILES:${PN}-dev += "${libdir}/cmake"
diff mbox series

Patch

diff --git a/meta-arago-extras/recipes-graphics/glfw/glfw/0001-HACK-CMakeList.txt-remove-check-for-Wayland-Egl-prov.patch b/meta-arago-extras/recipes-graphics/glfw/glfw/0001-HACK-CMakeList.txt-remove-check-for-Wayland-Egl-prov.patch
deleted file mode 100644
index 6116fc12..00000000
--- a/meta-arago-extras/recipes-graphics/glfw/glfw/0001-HACK-CMakeList.txt-remove-check-for-Wayland-Egl-prov.patch
+++ /dev/null
@@ -1,27 +0,0 @@ 
-From c6e30af80018f7a6fc7b8b0e810718f4bd646cf6 Mon Sep 17 00:00:00 2001
-From: Denys Dmytriyenko <denys@ti.com>
-Date: Thu, 12 Apr 2018 12:29:39 -0400
-Subject: [PATCH] HACK: CMakeList.txt: remove check for Wayland-Egl, provided
- by SGX libs
-
-Signed-off-by: Denys Dmytriyenko <denys@ti.com>
----
- CMakeLists.txt | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 1f5d6ef..eaf780f 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -266,7 +266,7 @@ if (_GLFW_WAYLAND)
-     find_package(ECM REQUIRED NO_MODULE)
-     list(APPEND CMAKE_MODULE_PATH "${ECM_MODULE_PATH}")
- 
--    find_package(Wayland REQUIRED Client Cursor Egl)
-+    find_package(Wayland REQUIRED Client Cursor)
-     find_package(WaylandScanner REQUIRED)
-     find_package(WaylandProtocols 1.12 REQUIRED)
- 
--- 
-2.7.4
-
diff --git a/meta-arago-extras/recipes-graphics/glfw/glfw_%.bbappend b/meta-arago-extras/recipes-graphics/glfw/glfw_%.bbappend
new file mode 100644
index 00000000..8f80e55d
--- /dev/null
+++ b/meta-arago-extras/recipes-graphics/glfw/glfw_%.bbappend
@@ -0,0 +1,6 @@ 
+# Add some wayland configuration options until meta-oe adds some good
+# PACKAGECONFIGS
+
+PACKAGECONFIG[wayland] = "-DGLFW_USE_WAYLAND=ON,,wayland wayland-native wayland-protocols extra-cmake-modules libxkbcommon"
+
+PACKAGECONFIG += " wayland"
diff --git a/meta-arago-extras/recipes-graphics/glfw/glfw_git.bb b/meta-arago-extras/recipes-graphics/glfw/glfw_git.bb
deleted file mode 100644
index 0e83979f..00000000
--- a/meta-arago-extras/recipes-graphics/glfw/glfw_git.bb
+++ /dev/null
@@ -1,24 +0,0 @@ 
-SUMMARY = "GLFW cross platform graphics framework"
-DESCRIPTION = "A multi-platform library for OpenGL and OpenGLES, window and input"
-HOMEPAGE = "http://glfw.org/"
-LICENSE = "Zlib & Libpng"
-LIC_FILES_CHKSUM = "file://LICENSE.md;md5=90c6dd54408744b0f8a55f2a6c7ad870"
-
-PV = "3.2.1+git${SRCPV}"
-PR = "r0"
-
-BRANCH = "master"
-SRC_URI = "git://github.com/glfw/glfw.git;protocol=https;branch=${BRANCH}"
-SRCREV = "0a3c4f5d80b041ee1a12c8da3503653d98bd1a15"
-
-SRC_URI += "file://0001-HACK-CMakeList.txt-remove-check-for-Wayland-Egl-prov.patch"
-
-DEPENDS = "extra-cmake-modules glib-2.0 virtual/libgles2 virtual/egl weston wayland wayland-native wayland-protocols"
-
-S = "${WORKDIR}/git"
-
-inherit cmake pkgconfig
-
-EXTRA_OECMAKE += "-DGLFW_USE_WAYLAND=ON -DGLFW_BUILD_EXAMPLES=OFF -DGLFW_BUILD_TESTS=OFF"
-
-FILES:${PN}-dev += "${libdir}/cmake"