Patchwork [meta-oe,5/6] cloud9: remove unneded systemd code

login
register
mail settings
Submitter Jason Kridner
Date March 9, 2012, 11:05 a.m.
Message ID <2ig0lhu1ti0mhyknnc4ow74t.1331291074225@email.android.com>
Download mbox | patch
Permalink /patch/22961/
State Not Applicable
Headers show

Comments

Jason Kridner - March 9, 2012, 11:05 a.m.
How is it that the service to start the server running is unneeded?


-------- Original message --------
Subject: [oe] [meta-oe 5/6] cloud9: remove unneded systemd code
From: Andreas Müller <schnitzeltony@googlemail.com>

To: "openembedded-devel@lists.openembedded.org" <openembedded-devel@lists.openembedded.org>
CC:



Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>

---
 meta-oe/recipes-devtools/cloud9/cloud9_0.5.1.bb |    6 +-----
 1 files changed, 1 insertions(+), 5 deletions(-)

--
1.7.6.4


_______________________________________________
Openembedded-devel mailing list
Openembedded-devel@lists.openembedded.org
http://lists.linuxtogo.org/cgi-bin/mailman/listinfo/openembedded-devel
Andreas Müller - March 9, 2012, 11:14 a.m.
On Fri, Mar 9, 2012 at 12:05 PM, Kridner, Jason <jdk@ti.com> wrote:
> How is it that the service to start the server running is unneeded?
>
The installations are done automatically by systemd.bbclass.

Andreas
Koen Kooi - March 9, 2012, 11:15 a.m.
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Op 09-03-12 12:05, Kridner, Jason schreef:
> How is it that the service to start the server running is unneeded?

It's already handled by systemd.bbclass:

> diff --git a/meta-oe/recipes-devtools/cloud9/cloud9_0.5.1.bb
> b/meta-oe/recipes-devtools/cloud9/cloud9_0.5.1.bb

> 
> inherit systemd

regards,

Koen
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (Darwin)
Comment: GPGTools - http://gpgtools.org

iEYEARECAAYFAk9Z5kcACgkQMkyGM64RGpGwUgCfQsYIjUowtseCnqwTVKw03wpM
Q5IAnRLjcbDIp8HECVYNefGFjrSRrs9g
=/r1q
-----END PGP SIGNATURE-----
MONDON Daniel - March 9, 2012, 2:02 p.m.
Hi,

I'm checking if i can translate my (flash player) application into
JavaFX.
I've got 2 hardwares : X86 (Ubuntu) and Arm (Angstrom).

Depending of
http://docs.oracle.com/javafx/2.0/release_notes_linux/jfxpub-release_not
es_linux.htm
I've make a Hello JavaFX application running on X86 (Ubuntu 11.04).

But i don't found if "JDk 6 update 26 or higher" is implemented on
Angstrom. I already have a JDK 6 Update 24, but not enought for JavaFX.

I already have gtk2 2.10.0 : what about gtk2 2.18+?

Thanks,
Daniel.
Henning Heinold - March 9, 2012, 9:09 p.m.
On Fri, Mar 09, 2012 at 03:02:28PM +0100, MONDON Daniel wrote:
> Hi,
> 
> I'm checking if i can translate my (flash player) application into
> JavaFX.
> I've got 2 hardwares : X86 (Ubuntu) and Arm (Angstrom).
> 
> Depending of
> http://docs.oracle.com/javafx/2.0/release_notes_linux/jfxpub-release_not
> es_linux.htm
> I've make a Hello JavaFX application running on X86 (Ubuntu 11.04).
> 
> But i don't found if "JDk 6 update 26 or higher" is implemented on
> Angstrom. I already have a JDK 6 Update 24, but not enought for JavaFX.
> 
> I already have gtk2 2.10.0 : what about gtk2 2.18+?
> 
> Thanks,
> Daniel.

Hi,

you can try the meta-java layer located at https://github.com/woglinde/meta-java which has
icedtea 1.11.1 with openjdk b24.

Bye Henning
MONDON Daniel - March 15, 2012, 8:28 a.m.
Hi,

When OpenEmbedded GTK2 2.18 or more will be available (running on ARM)?

Thanks
Daniel.
Martin Jansa - March 15, 2012, 8:31 a.m.
On Thu, Mar 15, 2012 at 09:28:41AM +0100, MONDON Daniel wrote:
> Hi,
> 
> When OpenEmbedded GTK2 2.18 or more will be available (running on ARM)?

http://git.openembedded.org/openembedded-core/tree/meta/recipes-gnome/gtk+
has 2.24.8
MONDON Daniel - March 15, 2012, 12:56 p.m.
Hi,

When OpenEmbedded JDk 6 update 26 or higher will be available (running
on ARM)?

Thanks
Daniel.
Eric BENARD - March 15, 2012, 1:04 p.m.
Hi Daniel,

Le Thu, 15 Mar 2012 13:56:15 +0100,
"MONDON Daniel" <Daniel.MONDON@lpgsystems.com> a écrit :
> When OpenEmbedded JDk 6 update 26 or higher will be available (running
> on ARM)?
> 
you can start from https://github.com/woglinde/meta-java and upgrade
it to the newer version you need, then you can send the patches as
described in the readme so that all the community can benefit from this
upgrade.

Thanks in advance,

Eric
Henning Heinold - March 15, 2012, 2:02 p.m.
On Thu, Mar 15, 2012 at 02:04:02PM +0100, Eric Bénard wrote:
> Hi Daniel,
> 
> Le Thu, 15 Mar 2012 13:56:15 +0100,
> "MONDON Daniel" <Daniel.MONDON@lpgsystems.com> a écrit :
> > When OpenEmbedded JDk 6 update 26 or higher will be available (running
> > on ARM)?
> > 
> you can start from https://github.com/woglinde/meta-java and upgrade
> it to the newer version you need, then you can send the patches as
> described in the readme so that all the community can benefit from this
> upgrade.
> 
> Thanks in advance,
> 
> Eric
> -- 
> http://eukrea.com/en/news/104-2012
> 

openjdk7 is comming soon.

Bye Henning
Eibach, Dirk - March 15, 2012, 2:08 p.m.
> openjdk7 is comming soon.

Good new. Getting Caciocavallo started should be much easier this way
...

Cheers
Dirk

Patch

diff --git a/meta-oe/recipes-devtools/cloud9/cloud9_0.5.1.bb b/meta-oe/recipes-devtools/cloud9/cloud9_0.5.1.bb

index 7041527..8a3f206 100644

--- a/meta-oe/recipes-devtools/cloud9/cloud9_0.5.1.bb

+++ b/meta-oe/recipes-devtools/cloud9/cloud9_0.5.1.bb

@@ -5,7 +5,7 @@  LIC_FILES_CHKSUM = "file://LICENSE;md5=4784c3bcff601fd8f9515f52a11e7018"


 DEPENDS = "libxml2 nodejs-native"

-PR = "r14"

+PR = "r15"


 SRC_URI = "git://github.com/ajaxorg/cloud9.git;name=cloud9ide \
            git://github.com/ajaxorg/o3;destsuffix=o3;name=o3 \
@@ -98,9 +98,6 @@  do_install () {

  install -m 0644 ${WORKDIR}/o3/modules/o3.js ${D}${datadir}/cloud9/support/jsdav/support/node-o3-xml-v4/lib/o3-xml/o3.js
  install -m 0755 ${WORKDIR}/o3/o3.node ${D}${datadir}/cloud9/support/jsdav/support/node-o3-xml-v4/lib/o3-xml/o3.node

- install -m 0755 -d ${D}${systemd_unitdir}/system

- install -m 0644 ${WORKDIR}/cloud9.service ${D}${systemd_unitdir}/system/

-

   install -m 0755 -d ${D}${sysconfdir}/avahi/services/
   install -m 0644 ${WORKDIR}/cloud9-avahi.service ${D}${sysconfdir}/avahi/services/
 }
@@ -109,7 +106,6 @@  FILES_${PN}-dbg += "${datadir}/cloud9/support/jsdav/support/node-o3-xml-v4/lib/o

                     ${datadir}/cloud9/support/jsdav/support/node-o3-xml-v4/lib/.debug \
                    "

-FILES_${PN} += "${systemd_unitdir}/system"

 RDEPENDS_${PN} = "nodejs gzip"

 inherit systemd