diff mbox series

[meta-python] python3-icu: upgrade 2.10.2 -> 2.11

Message ID 1682306676-11881-2-git-send-email-wangmy@fujitsu.com
State Under Review
Headers show
Series [meta-python] python3-icu: upgrade 2.10.2 -> 2.11 | expand

Commit Message

Mingyu Wang (Fujitsu) April 24, 2023, 3:24 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

Changelog:
===========
 - fixed bug PluralFormat.format accepting python strings, which are immutable
 - fixed bug with UWordBreak wrapping wrong enum (UBreakIteratorType)
 - added wrappers for UBreakIteratorType, ULine|SentenceBreakTag
 - added wrappers for DateTimePatternGenerator::set|getDateTimeFormat()
 - added wrappers for Precision::incrementExact()
 - Locale objects can now be sorted (Fredrik Roubert)
 - added wrapper for Calendar::inTemporalLeapYear()
 - added wrappers for Calendar::get|getTemporalMonthCode()
 - changed all Calendar setters to return self instead of None, setter chaining

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../python/{python3-icu_2.10.2.bb => python3-icu_2.11.bb}       | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-icu_2.10.2.bb => python3-icu_2.11.bb} (83%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-icu_2.10.2.bb b/meta-python/recipes-devtools/python/python3-icu_2.11.bb
similarity index 83%
rename from meta-python/recipes-devtools/python/python3-icu_2.10.2.bb
rename to meta-python/recipes-devtools/python/python3-icu_2.11.bb
index cbcc2f87b..c66455c7e 100644
--- a/meta-python/recipes-devtools/python/python3-icu_2.10.2.bb
+++ b/meta-python/recipes-devtools/python/python3-icu_2.11.bb
@@ -8,7 +8,7 @@  LIC_FILES_CHKSUM = "file://LICENSE;md5=0724597863f1581ab01429e0423e779f"
 DEPENDS += "icu"
 
 PYPI_PACKAGE = "PyICU"
-SRC_URI[sha256sum] = "0c3309eea7fab6857507ace62403515b60fe096cbfb4f90d14f55ff75c5441c1"
+SRC_URI[sha256sum] = "3ab531264cfe9132b3d2ac5d708da9a4649d25f6e6813730ac88cf040a08a844"
 
 SRC_URI += "file://0001-Fix-host-contamination-of-include-files.patch"