diff mbox series

[meta-python,2/2] python3-pandas: Fix TMPDIR references in dbg files

Message ID 20230416145802.2419372-2-raj.khem@gmail.com
State New
Headers show
Series [meta-python,1/2] python3-h5py: Fix TMPDIR references in dbg files | expand

Commit Message

Khem Raj April 16, 2023, 2:58 p.m. UTC
These are embedded into comments in C source code generated with cython
during do_compile.

Fixes

WARNING: python3-pandas-1.5.3-r0 do_package_qa: QA Issue: File /usr/src/debug/python3-pandas/1.5.3-r0/pandas/_libs/hashing.c in package python3-pandas-src contains reference to TMPDIR

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 .../recipes-devtools/python/python3-pandas_1.5.3.bb    | 10 ++++++++++
 1 file changed, 10 insertions(+)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-pandas_1.5.3.bb b/meta-python/recipes-devtools/python/python3-pandas_1.5.3.bb
index aa8dfe279d..129c3147cf 100644
--- a/meta-python/recipes-devtools/python/python3-pandas_1.5.3.bb
+++ b/meta-python/recipes-devtools/python/python3-pandas_1.5.3.bb
@@ -14,6 +14,16 @@  DEPENDS += " \
     ${PYTHON_PN}-numpy-native ${PYTHON_PN}-cython-native \
 "
 
+PACKAGESPLITFUNCS =+ "fix_cythonized_sources"
+
+fix_cythonized_sources() {
+	for f in `grep -l -r -e '\/* Generated by Cython.*/$' ${PKGD}/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}`; do
+		if [ -e $f ]; then
+			sed -i -e 's#${RECIPE_SYSROOT_NATIVE}##g' $f
+		fi
+	done
+}
+
 CFLAGS:append:toolchain-clang = " -Wno-error=deprecated-declarations"
 
 RDEPENDS:${PN} += " \