diff mbox series

systemd: upgrade 253.1 -> 253.3

Message ID 1681438725-24175-1-git-send-email-wangmy@fujitsu.com
State New
Headers show
Series systemd: upgrade 253.1 -> 253.3 | expand

Commit Message

Mingyu Wang (Fujitsu) April 14, 2023, 2:18 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

Changelog:
https://github.com/systemd/systemd-stable/blob/v253.3/NEWS

0025-systemctl-explicitly-cast-the-constants-to-uint64_t.patch
removed since it's included in 253.3

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 ...md-boot_253.1.bb => systemd-boot_253.3.bb} |  0
 meta/recipes-core/systemd/systemd.inc         |  3 +-
 ...citly-cast-the-constants-to-uint64_t.patch | 44 -------------------
 .../{systemd_253.1.bb => systemd_253.3.bb}    |  0
 4 files changed, 1 insertion(+), 46 deletions(-)
 rename meta/recipes-core/systemd/{systemd-boot_253.1.bb => systemd-boot_253.3.bb} (100%)
 delete mode 100644 meta/recipes-core/systemd/systemd/0025-systemctl-explicitly-cast-the-constants-to-uint64_t.patch
 rename meta/recipes-core/systemd/{systemd_253.1.bb => systemd_253.3.bb} (100%)
diff mbox series

Patch

diff --git a/meta/recipes-core/systemd/systemd-boot_253.1.bb b/meta/recipes-core/systemd/systemd-boot_253.3.bb
similarity index 100%
rename from meta/recipes-core/systemd/systemd-boot_253.1.bb
rename to meta/recipes-core/systemd/systemd-boot_253.3.bb
diff --git a/meta/recipes-core/systemd/systemd.inc b/meta/recipes-core/systemd/systemd.inc
index 14608f9abc..d50f2c9cba 100644
--- a/meta/recipes-core/systemd/systemd.inc
+++ b/meta/recipes-core/systemd/systemd.inc
@@ -14,11 +14,10 @@  LICENSE = "GPL-2.0-only & LGPL-2.1-only"
 LIC_FILES_CHKSUM = "file://LICENSE.GPL2;md5=751419260aa954499f7abaabaa882bbe \
                     file://LICENSE.LGPL2.1;md5=4fbd65380cdd255951079008b364516c"
 
-SRCREV = "6c327d74aa0d350482e82a247d7018559699798d"
+SRCREV = "ed18c2ab79e8b94182d5dcf31d58457763f3e3e1"
 SRCBRANCH = "v253-stable"
 SRC_URI = "git://github.com/systemd/systemd-stable.git;protocol=https;branch=${SRCBRANCH} \
            file://0026-src-boot-efi-efi-string.c-define-wchar_t-from-__WCHA.patch \
-           file://0025-systemctl-explicitly-cast-the-constants-to-uint64_t.patch \
            "
 
 S = "${WORKDIR}/git"
diff --git a/meta/recipes-core/systemd/systemd/0025-systemctl-explicitly-cast-the-constants-to-uint64_t.patch b/meta/recipes-core/systemd/systemd/0025-systemctl-explicitly-cast-the-constants-to-uint64_t.patch
deleted file mode 100644
index d840de870f..0000000000
--- a/meta/recipes-core/systemd/systemd/0025-systemctl-explicitly-cast-the-constants-to-uint64_t.patch
+++ /dev/null
@@ -1,44 +0,0 @@ 
-From fad29ce1f5cc7b12bc13671d9ad80775771a67eb Mon Sep 17 00:00:00 2001
-From: Frantisek Sumsal <frantisek@sumsal.cz>
-Date: Fri, 3 Mar 2023 12:17:27 +0100
-Subject: [PATCH] systemctl: explicitly cast the constants to uint64_t
-
-Otherwise under certain conditions `va_arg()` might get garbage instead
-of the expected value, i.e.:
-
-$ sudo build-o0/systemctl disable asdfasfaf
-sd_bus_message_appendv: Got uint64_t: 0
-Failed to disable unit: Unit file asdfasfaf.service does not exist.
-
-$ sudo build-o1/systemctl disable asdfasfaf
-sd_bus_message_appendv: Got uint64_t: 7954875719681572864
-Failed to disable unit: Invalid argument
-
-(reproduced on an armv7hl machine)
-
-Resolves: #26568
-Follow-up to: bf1bea43f15
-Related issue: https://github.com/systemd/systemd/pull/14470#discussion_r362893735
-
-Upstream-Status: Backport [https://github.com/systemd/systemd/commit/c63bfd0884cf20e48befbee49d41f667660a8802]
-Signed-off-by: Alexander Kanavin <alex@linutronix.de>
----
- src/systemctl/systemctl-enable.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/systemctl/systemctl-enable.c b/src/systemctl/systemctl-enable.c
-index 86d9f602fa..f94a286122 100644
---- a/src/systemctl/systemctl-enable.c
-+++ b/src/systemctl/systemctl-enable.c
-@@ -211,7 +211,7 @@ int verb_enable(int argc, char *argv[], void *userdata) {
- 
-                 if (send_runtime) {
-                         if (streq(method, "DisableUnitFilesWithFlagsAndInstallInfo"))
--                                r = sd_bus_message_append(m, "t", arg_runtime ? UNIT_FILE_RUNTIME : 0);
-+                                r = sd_bus_message_append(m, "t", arg_runtime ? (uint64_t) UNIT_FILE_RUNTIME : UINT64_C(0));
-                         else
-                                 r = sd_bus_message_append(m, "b", arg_runtime);
-                         if (r < 0)
--- 
-2.39.2
-
diff --git a/meta/recipes-core/systemd/systemd_253.1.bb b/meta/recipes-core/systemd/systemd_253.3.bb
similarity index 100%
rename from meta/recipes-core/systemd/systemd_253.1.bb
rename to meta/recipes-core/systemd/systemd_253.3.bb