diff mbox series

[5/5] python3-build: add missing run-time dependencies

Message ID 20230413091557.10659-6-brgl@bgdev.pl
State Accepted, archived
Commit f4a4de1dc3521695c14dfc206fa4cd0e10c250aa
Headers show
Series python3: fix run-time availability of python3-build | expand

Commit Message

Bartosz Golaszewski April 13, 2023, 9:15 a.m. UTC
From: Bartosz Golaszewski <bartosz.golaszewski@linaro.org>

python3-build has several run-time dependencies that are missing from
the recipe. This makes it impossible to use the module in self-hosted
images. Add missing RDEPENDS.

Signed-off-by: Bartosz Golaszewski <bartosz.golaszewski@linaro.org>
---
 meta/recipes-devtools/python/python3-build_0.10.0.bb | 11 ++++++++++-
 1 file changed, 10 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python3-build_0.10.0.bb b/meta/recipes-devtools/python/python3-build_0.10.0.bb
index 770a32023d..b446fa391d 100644
--- a/meta/recipes-devtools/python/python3-build_0.10.0.bb
+++ b/meta/recipes-devtools/python/python3-build_0.10.0.bb
@@ -18,6 +18,15 @@  do_compile:prepend:class-native() {
     export PYTHONPATH="${S}/src"
 }
 
-RDEPENDS:${PN} += "python3-packaging python3-pyproject-hooks"
+RDEPENDS:${PN} += " \
+    python3-compression \
+    python3-difflib \
+    python3-ensurepip \
+    python3-logging \
+    python3-packaging \
+    python3-pyproject-hooks \
+    python3-tomllib \
+    python3-venv \
+"
 
 BBCLASSEXTEND = "native nativesdk"