diff mbox series

[meta-python] python3-pillow: upgrade 9.4.0 -> 9.5.0

Message ID 1681115263-24378-3-git-send-email-wangmy@fujitsu.com
State Under Review
Headers show
Series [meta-python] python3-pillow: upgrade 9.4.0 -> 9.5.0 | expand

Commit Message

Mingyu Wang (Fujitsu) April 10, 2023, 8:27 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

License-Update:
 Alex Clark -> Jeffrey A. Clark (Alex)
 Update HPND wording in LICENSE file

Changelog:
==========
    Added ImageSourceData to TAGS_V2 #7053
    Clear PPM half token after use #7052
    Removed absolute path to ldconfig #7044
    Support custom comments and PLT markers when saving JPEG2000 images #6903
    Load before getting size in __array_interface__ #7034
    Support creating BGR;15, BGR;16 and BGR;24 images, but drop support for BGR;32 #7010
    Consider transparency when applying APNG blend mask #7018
    Round duration when saving animated WebP images #6996
    Added reading of JPEG2000 comments #6909
    Decrement reference count #7003
    Allow libtiff_support_custom_tags to be missing #7020
    Improved I;16N support #6834
    Added QOI reading #6852
    Added saving RGBA images as PDFs #6925
    Do not raise an error if os.environ does not contain PATH #6935
    Close OleFileIO instance when closing or exiting FPX or MIC #7005
    Added __int__ to IFDRational for Python >= 3.11 #6998
    Added memoryview support to Dib.frombytes() #6988
    Close file pointer copy in the libtiff encoder if still open #6986
    Raise an error if ImageDraw co-ordinates are incorrectly ordered #6978
    Added "corners" argument to ImageDraw rounded_rectangle() #6954
    Added memoryview support to frombytes() #6974
    Allow comments in FITS images #6973
    Support saving PDF with different X and Y resolutions #6961
    Fixed writing int as UNDEFINED tag #6950
    Raise an error if EXIF data is too long when saving JPEG #6939
    Handle more than one directory returned by pkg-config #6896
    Do not retry past formats when loading all formats for the first time #6902
    Do not retry specified formats if they failed when opening #6893
    Do not unintentionally load TIFF format at first #6892
    Stop reading when EPS line becomes too long #6897
    Allow writing IFDRational to BYTE tag #6890
    Raise ValueError for BoxBlur filter with negative radius #6874
    Support arbitrary number of loaded modules on Windows #6761

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../{python3-pillow_9.4.0.bb => python3-pillow_9.5.0.bb}      | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
 rename meta-python/recipes-devtools/python/{python3-pillow_9.4.0.bb => python3-pillow_9.5.0.bb} (91%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-pillow_9.4.0.bb b/meta-python/recipes-devtools/python/python3-pillow_9.5.0.bb
similarity index 91%
rename from meta-python/recipes-devtools/python/python3-pillow_9.4.0.bb
rename to meta-python/recipes-devtools/python/python3-pillow_9.5.0.bb
index 86705d2d8..76b3a82db 100644
--- a/meta-python/recipes-devtools/python/python3-pillow_9.4.0.bb
+++ b/meta-python/recipes-devtools/python/python3-pillow_9.5.0.bb
@@ -3,7 +3,7 @@  Clark and Contributors. PIL is the Python Imaging Library by Fredrik Lundh and \
 Contributors."
 HOMEPAGE = "https://pillow.readthedocs.io"
 LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=bc416d18f294943285560364be7cbec1"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=b22dc6b663b9175820e5e03337c7596b"
 
 SRC_URI = "git://github.com/python-pillow/Pillow.git;branch=main;protocol=https \
            file://0001-support-cross-compiling.patch \
@@ -61,4 +61,4 @@  do_install_ptest() {
 
 BBCLASSEXTEND = "native"
 
-SRCREV = "a5bbab1c1e63b439de191ef2040173713b26d2da"
+SRCREV = "204590600c6a8c5246d0564d3312abd6e6b0ed70"