diff mbox series

[meta-ti,master/kirkstone,4/4] linux-ti-next: Remove unneeded do_compile append

Message ID 20230405184714.26036-4-afd@ti.com
State Superseded
Delegated to: Ryan Eatmon
Headers show
Series [meta-ti,master/kirkstone,1/4] linux-ti-mainline: Use upstream configs with upstream kernel | expand

Commit Message

Andrew Davis April 5, 2023, 6:47 p.m. UTC
Looks to be a leftover copy/paste error from when we did more in this
append for other kernel build types. Not needed here so remove.

Signed-off-by: Andrew Davis <afd@ti.com>
---
 meta-ti-bsp/recipes-kernel/linux/linux-ti-next_git.bb | 4 ----
 1 file changed, 4 deletions(-)

Comments

Denys Dmytriyenko April 5, 2023, 7:07 p.m. UTC | #1
On Wed, Apr 05, 2023 at 01:47:14PM -0500, Andrew Davis via lists.yoctoproject.org wrote:
> Looks to be a leftover copy/paste error from when we did more in this
> append for other kernel build types. Not needed here so remove.

It isn't a copy/paste error - it used to build kernel DTBs prior to 
KERNEL_DEVICETREE getting populated with the list of built .dtb/.dtbo 
files. Now KERNEL_DEVICETREE contains a preset of upstream DTBs and 
the code can be removed, true.


> Signed-off-by: Andrew Davis <afd@ti.com>
> ---
>  meta-ti-bsp/recipes-kernel/linux/linux-ti-next_git.bb | 4 ----
>  1 file changed, 4 deletions(-)
> 
> diff --git a/meta-ti-bsp/recipes-kernel/linux/linux-ti-next_git.bb b/meta-ti-bsp/recipes-kernel/linux/linux-ti-next_git.bb
> index 62831c9c..1e86ed97 100644
> --- a/meta-ti-bsp/recipes-kernel/linux/linux-ti-next_git.bb
> +++ b/meta-ti-bsp/recipes-kernel/linux/linux-ti-next_git.bb
> @@ -23,7 +23,3 @@ DEFCONFIG_NAME = "multi_v7_defconfig"
>  DEFCONFIG_NAME:omapl138 = "davinci_all_defconfig"
>  DEFCONFIG_NAME:k3 = "defconfig"
>  KERNEL_CONFIG_COMMAND = "oe_runmake -C ${S} O=${B} ${DEFCONFIG_NAME}"
> -
> -kernel_do_compile:append() {
> -	oe_runmake dtbs CC="${KERNEL_CC} $cc_extra " LD="${KERNEL_LD}" ${KERNEL_EXTRA_ARGS}
> -}
> -- 
> 2.39.2
Andrew Davis April 11, 2023, 5:41 p.m. UTC | #2
On 4/5/23 2:07 PM, Denys Dmytriyenko wrote:
> On Wed, Apr 05, 2023 at 01:47:14PM -0500, Andrew Davis via lists.yoctoproject.org wrote:
>> Looks to be a leftover copy/paste error from when we did more in this
>> append for other kernel build types. Not needed here so remove.
> 
> It isn't a copy/paste error - it used to build kernel DTBs prior to
> KERNEL_DEVICETREE getting populated with the list of built .dtb/.dtbo
> files. Now KERNEL_DEVICETREE contains a preset of upstream DTBs and
> the code can be removed, true.
> 

Ah, good to know, will update commit message.

Andrew

> 
>> Signed-off-by: Andrew Davis <afd@ti.com>
>> ---
>>   meta-ti-bsp/recipes-kernel/linux/linux-ti-next_git.bb | 4 ----
>>   1 file changed, 4 deletions(-)
>>
>> diff --git a/meta-ti-bsp/recipes-kernel/linux/linux-ti-next_git.bb b/meta-ti-bsp/recipes-kernel/linux/linux-ti-next_git.bb
>> index 62831c9c..1e86ed97 100644
>> --- a/meta-ti-bsp/recipes-kernel/linux/linux-ti-next_git.bb
>> +++ b/meta-ti-bsp/recipes-kernel/linux/linux-ti-next_git.bb
>> @@ -23,7 +23,3 @@ DEFCONFIG_NAME = "multi_v7_defconfig"
>>   DEFCONFIG_NAME:omapl138 = "davinci_all_defconfig"
>>   DEFCONFIG_NAME:k3 = "defconfig"
>>   KERNEL_CONFIG_COMMAND = "oe_runmake -C ${S} O=${B} ${DEFCONFIG_NAME}"
>> -
>> -kernel_do_compile:append() {
>> -	oe_runmake dtbs CC="${KERNEL_CC} $cc_extra " LD="${KERNEL_LD}" ${KERNEL_EXTRA_ARGS}
>> -}
>> -- 
>> 2.39.2
diff mbox series

Patch

diff --git a/meta-ti-bsp/recipes-kernel/linux/linux-ti-next_git.bb b/meta-ti-bsp/recipes-kernel/linux/linux-ti-next_git.bb
index 62831c9c..1e86ed97 100644
--- a/meta-ti-bsp/recipes-kernel/linux/linux-ti-next_git.bb
+++ b/meta-ti-bsp/recipes-kernel/linux/linux-ti-next_git.bb
@@ -23,7 +23,3 @@  DEFCONFIG_NAME = "multi_v7_defconfig"
 DEFCONFIG_NAME:omapl138 = "davinci_all_defconfig"
 DEFCONFIG_NAME:k3 = "defconfig"
 KERNEL_CONFIG_COMMAND = "oe_runmake -C ${S} O=${B} ${DEFCONFIG_NAME}"
-
-kernel_do_compile:append() {
-	oe_runmake dtbs CC="${KERNEL_CC} $cc_extra " LD="${KERNEL_LD}" ${KERNEL_EXTRA_ARGS}
-}