diff mbox series

[meta-security] libwhisker2-perl: adjust perl-version variable

Message ID 20230405113726.469558-1-patrick@stwcx.xyz
State New
Headers show
Series [meta-security] libwhisker2-perl: adjust perl-version variable | expand

Commit Message

Patrick Williams April 5, 2023, 11:37 a.m. UTC
The PERLVERSION likely has the wrong value in the native context
due to reasons discussed in openembedded-core[1].  The upstream
suggestion was to avoid use of PERLVERSION and switch to the direct
function.

1. https://lore.kernel.org/openembedded-core/20230405003850.384813-1-patrick@stwcx.xyz/T/#u

Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
---
 recipes-perl/perl/libwhisker2-perl_2.5.bb | 7 ++++---
 1 file changed, 4 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/recipes-perl/perl/libwhisker2-perl_2.5.bb b/recipes-perl/perl/libwhisker2-perl_2.5.bb
index 42c0b42..c58d883 100644
--- a/recipes-perl/perl/libwhisker2-perl_2.5.bb
+++ b/recipes-perl/perl/libwhisker2-perl_2.5.bb
@@ -19,9 +19,10 @@  PACKAGEGROUP ??=""
 PACKAGEGROUP[ssl] = ", , libnet-ssleay-perl, libnet-ssleay-perl"
 
 do_install() {
-    install -d 755 ${D}${PERLLIBDIRS}/vendor_perl/${PERLVERSION}
-    install -d 755 ${D}${datadir}/perl/${PERLVERSION}
-    oe_runmake install DESTDIR=${D} INSTALLDIR=${PERLLIBDIRS}/vendor_perl/${PERLVERSION} MANDIR=${datadir}/perl/${PERLVERSION}
+    perl_version="${@get_perl_version(d)}"
+    install -d 755 ${D}${PERLLIBDIRS}/vendor_perl/${perl_version}
+    install -d 755 ${D}${datadir}/perl/${perl_version}
+    oe_runmake install DESTDIR=${D} INSTALLDIR=${PERLLIBDIRS}/vendor_perl/${perl_version} MANDIR=${datadir}/perl/${perl_version}
 }
 
 FILES:${PN} += "${datadir}/perl"